Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить значение тока в зависимости от трёх параметров - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить значение тока в зависимости от трёх параметров (Формулы/Formulas)
Определить значение тока в зависимости от трёх параметров
Dmitry_Rublevsky Дата: Пятница, 26.08.2016, 11:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Доброго времени суток!
Возникла проблема с использованием функции "ЕСЛИ" (введно слишком много аргументов)

Синтаксис так-то правильный. Может быть как-то можно будет упростить данную формулу?
Заранее благодарю!
К сообщению приложен файл: 0222959.xls(94Kb)


Сообщение отредактировал Dmitry_Rublevsky - Пятница, 26.08.2016, 11:48
 
Ответить
СообщениеДоброго времени суток!
Возникла проблема с использованием функции "ЕСЛИ" (введно слишком много аргументов)

Синтаксис так-то правильный. Может быть как-то можно будет упростить данную формулу?
Заранее благодарю!

Автор - Dmitry_Rublevsky
Дата добавления - 26.08.2016 в 11:14
Manyasha Дата: Пятница, 26.08.2016, 11:22 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1587
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
Dmitry_Rublevsky, меняйте название темы в соответствии с Правилами форума!


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеDmitry_Rublevsky, меняйте название темы в соответствии с Правилами форума!

Автор - Manyasha
Дата добавления - 26.08.2016 в 11:22
Dmitry_Rublevsky Дата: Пятница, 26.08.2016, 11:25 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Manyasha, исправил
 
Ответить
СообщениеManyasha, исправил

Автор - Dmitry_Rublevsky
Дата добавления - 26.08.2016 в 11:25
Manyasha Дата: Пятница, 26.08.2016, 11:36 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1587
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
Dmitry_Rublevsky, это название тоже не подходит
Цитата
2.Очень ВАЖНО! При создании темы, давайте теме название, отражающее суть Вашей проблемы

что Вы пытаетесь посчитать? Силу тока в зависимости от характеристик проводов и кабелей? Так и назовите свою тему


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеDmitry_Rublevsky, это название тоже не подходит
Цитата
2.Очень ВАЖНО! При создании темы, давайте теме название, отражающее суть Вашей проблемы

что Вы пытаетесь посчитать? Силу тока в зависимости от характеристик проводов и кабелей? Так и назовите свою тему

Автор - Manyasha
Дата добавления - 26.08.2016 в 11:36
buchlotnik Дата: Пятница, 26.08.2016, 11:39 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Синтаксис так-то правильный
был бы правильный - система бы не ругалась - скобок понаставили не в тех местах:
Код
=ЕСЛИ(И(J6=1;J7="В воздухе");ВПР(J9;$CV$64:$DA$81;2;0);ЕСЛИ(И(J6=2;J7="В воздухе");ВПР(J9;$CV$64:$DA$81;3;0);ЕСЛИ(И(J6=2;J7="В земле");ВПР(J9;$CV$64:$DA$81;4;0);ЕСЛИ(И(J6=3;J7="В воздухе");ВПР(J9;$CV$64:$DA$81;5;0);ЕСЛИ(И(J6=3;J7="В земле");ВПР(J9;$CV$64:$DA$81;6;0))))))

а упростить можно:
Код
=ИНДЕКС($CW$67:$DA$81;ПОИСКПОЗ(J9;CV67:CV81;0);ПОИСКПОЗ(J6&J7;CW65:DA65&CW66:DA66;0))
(формула массива)
К сообщению приложен файл: 0629074.xls(92Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Синтаксис так-то правильный
был бы правильный - система бы не ругалась - скобок понаставили не в тех местах:
Код
=ЕСЛИ(И(J6=1;J7="В воздухе");ВПР(J9;$CV$64:$DA$81;2;0);ЕСЛИ(И(J6=2;J7="В воздухе");ВПР(J9;$CV$64:$DA$81;3;0);ЕСЛИ(И(J6=2;J7="В земле");ВПР(J9;$CV$64:$DA$81;4;0);ЕСЛИ(И(J6=3;J7="В воздухе");ВПР(J9;$CV$64:$DA$81;5;0);ЕСЛИ(И(J6=3;J7="В земле");ВПР(J9;$CV$64:$DA$81;6;0))))))

а упростить можно:
Код
=ИНДЕКС($CW$67:$DA$81;ПОИСКПОЗ(J9;CV67:CV81;0);ПОИСКПОЗ(J6&J7;CW65:DA65&CW66:DA66;0))
(формула массива)

Автор - buchlotnik
Дата добавления - 26.08.2016 в 11:39
AlexM Дата: Пятница, 26.08.2016, 11:40 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Формула массива
Код
=ГПР(J6&J7;ЕСЛИ({1:0};CW65:DA65&CW66:DA66;ИНДЕКС(CW67:DA81;ПОИСКПОЗ(J9;CV67:CV81;);));2;)
К сообщению приложен файл: Question_01.xls(90Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула массива
Код
=ГПР(J6&J7;ЕСЛИ({1:0};CW65:DA65&CW66:DA66;ИНДЕКС(CW67:DA81;ПОИСКПОЗ(J9;CV67:CV81;);));2;)

Автор - AlexM
Дата добавления - 26.08.2016 в 11:40
Roman777 Дата: Пятница, 26.08.2016, 11:41 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 75 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
Код
=ЕСЛИ(J7="В воздухе";СМЕЩ(Q4;ПОИСКПОЗ(J9;P6:P12)+1;ПОИСКПОЗ(J6;Q4:U4)-2);СМЕЩ(Q4;ПОИСКПОЗ(J9;P6:P12)+1;ПОИСКПОЗ(J6;Q4:U4)-1))
К сообщению приложен файл: 7156997.xls(83Kb)


Много чего не знаю!!!!
 
Ответить
Сообщение
Код
=ЕСЛИ(J7="В воздухе";СМЕЩ(Q4;ПОИСКПОЗ(J9;P6:P12)+1;ПОИСКПОЗ(J6;Q4:U4)-2);СМЕЩ(Q4;ПОИСКПОЗ(J9;P6:P12)+1;ПОИСКПОЗ(J6;Q4:U4)-1))

Автор - Roman777
Дата добавления - 26.08.2016 в 11:41
китин Дата: Пятница, 26.08.2016, 11:46 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 545 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
во нагородили то :D ну и мои 5 коп формула массива
Код
=СУММПРОИЗВ(ЕСЛИ(ЕТЕКСТ($CW$67:$DA$81);0;$CW$67:$DA$81)*($J$9=$CV$67:$CV$81)*($J$6=$CW$65:$DA$65)*($J$7=$CW$66:$DA$66))
К сообщению приложен файл: 123456.xlsm(59Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениево нагородили то :D ну и мои 5 коп формула массива
Код
=СУММПРОИЗВ(ЕСЛИ(ЕТЕКСТ($CW$67:$DA$81);0;$CW$67:$DA$81)*($J$9=$CV$67:$CV$81)*($J$6=$CW$65:$DA$65)*($J$7=$CW$66:$DA$66))

Автор - китин
Дата добавления - 26.08.2016 в 11:46
Dmitry_Rublevsky Дата: Пятница, 26.08.2016, 11:46 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Спасибо всем большое!
 
Ответить
СообщениеСпасибо всем большое!

Автор - Dmitry_Rublevsky
Дата добавления - 26.08.2016 в 11:46
AlexM Дата: Пятница, 26.08.2016, 12:05 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Еще формула массива
Код
=ГПР(J6&J7;ЕСЛИ({1:0};CW65:DA65&CW66:DA66;ВПР(J9;CV67:DA81;{2;3;4;5;6};));2;)
и обычная формула
Код
=ПРОСМОТР(2;1/(J6&J7=CW65:DA65&CW66:DA66);ВПР(J9;CV67:DA81;{2;3;4;5;6};))


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 26.08.2016, 13:23
 
Ответить
СообщениеЕще формула массива
Код
=ГПР(J6&J7;ЕСЛИ({1:0};CW65:DA65&CW66:DA66;ВПР(J9;CV67:DA81;{2;3;4;5;6};));2;)
и обычная формула
Код
=ПРОСМОТР(2;1/(J6&J7=CW65:DA65&CW66:DA66);ВПР(J9;CV67:DA81;{2;3;4;5;6};))

Автор - AlexM
Дата добавления - 26.08.2016 в 12:05
jakim Дата: Пятница, 26.08.2016, 15:05 | Сообщение № 11
Группа: Друзья
Ранг: Ветеран
Сообщений: 680
Репутация: 172 ±
Замечаний: 0% ±

Для Вас подойдет и такой вариант формулы.

Код
=AGGREGATE(15;6;D6:H20/(C6:C20=B6)/(D4:H4=B3)/(D5:H5=B4);1)
К сообщению приложен файл: 123456.xlsx(11Kb)
 
Ответить
Сообщение
Для Вас подойдет и такой вариант формулы.

Код
=AGGREGATE(15;6;D6:H20/(C6:C20=B6)/(D4:H4=B3)/(D5:H5=B4);1)

Автор - jakim
Дата добавления - 26.08.2016 в 15:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить значение тока в зависимости от трёх параметров (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!