Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Kак преоброзовать номер столбца таблицы в прос. массив. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Kак преоброзовать номер столбца таблицы в прос. массив. (Формулы/Formulas)
Kак преоброзовать номер столбца таблицы в прос. массив.
rafsit61 Дата: Пятница, 26.08.2016, 12:29 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010
Всем Здравствуйте!
Подскажите, пожалуйста, как преобразовать номер столбца таблицы в просматриваемый массив?
Или номер столбца заменить буквенными значениями листа
Номер столбца - величина переменная
Пример прилагаю в таблице.
И ещё вопрос, как выйти на свои ранние подписки
Благодарю заранее, кто откликнется
К сообщению приложен файл: 01.xlsx(15Kb)
 
Ответить
СообщениеВсем Здравствуйте!
Подскажите, пожалуйста, как преобразовать номер столбца таблицы в просматриваемый массив?
Или номер столбца заменить буквенными значениями листа
Номер столбца - величина переменная
Пример прилагаю в таблице.
И ещё вопрос, как выйти на свои ранние подписки
Благодарю заранее, кто откликнется

Автор - rafsit61
Дата добавления - 26.08.2016 в 12:29
Nic70y Дата: Пятница, 26.08.2016, 12:41 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3478
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1[[#Все];[Имя]];ПОИСКПОЗ("А-2";ИНДЕКС(Таблица1[#Все];;ПОИСКПОЗ(S4;Таблица1[#Заголовки];));));"")
вдруг правильно
тег фигню выдал, придётся в вба-шном:[vba]
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1[[#Все];[Имя]];ПОИСКПОЗ("А-2";ИНДЕКС(Таблица1[#Все];;ПОИСКПОЗ(S4;Таблица1[#Заголовки];));));"")
[/vba]
К сообщению приложен файл: 2840144.xlsx(13Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 26.08.2016, 12:44
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1[[#Все];[Имя]];ПОИСКПОЗ("А-2";ИНДЕКС(Таблица1[#Все];;ПОИСКПОЗ(S4;Таблица1[#Заголовки];));));"")
вдруг правильно
тег фигню выдал, придётся в вба-шном:[vba]
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1[[#Все];[Имя]];ПОИСКПОЗ("А-2";ИНДЕКС(Таблица1[#Все];;ПОИСКПОЗ(S4;Таблица1[#Заголовки];));));"")
[/vba]

Автор - Nic70y
Дата добавления - 26.08.2016 в 12:41
rafsit61 Дата: Пятница, 26.08.2016, 12:49 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010
Nic70y, Спасибо огромное. Буду разбираться.
 
Ответить
СообщениеNic70y, Спасибо огромное. Буду разбираться.

Автор - rafsit61
Дата добавления - 26.08.2016 в 12:49
pabchek Дата: Пятница, 26.08.2016, 13:51 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Или может так?
Код
=ПРОСМОТР($P$3;ИНДЕКС($B$3:$M$14;;ПОИСКПОЗ($S4;$B$2:$M$2;0));$A$3:$A$14)
К сообщению приложен файл: 6180271.xlsx(13Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 26.08.2016, 13:53
 
Ответить
СообщениеИли может так?
Код
=ПРОСМОТР($P$3;ИНДЕКС($B$3:$M$14;;ПОИСКПОЗ($S4;$B$2:$M$2;0));$A$3:$A$14)

Автор - pabchek
Дата добавления - 26.08.2016 в 13:51
rafsit61 Дата: Пятница, 26.08.2016, 20:05 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010
pabchek, Спасибо. Мне не совсем понятно, как работает эта функция, но результат тот же. Буду разбираться, спасибо.
 
Ответить
Сообщениеpabchek, Спасибо. Мне не совсем понятно, как работает эта функция, но результат тот же. Буду разбираться, спасибо.

Автор - rafsit61
Дата добавления - 26.08.2016 в 20:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Kак преоброзовать номер столбца таблицы в прос. массив. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!