Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных не нарушая порядка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных не нарушая порядка (Формулы/Formulas)
Перенос данных не нарушая порядка
n0leg68 Дата: Воскресенье, 28.08.2016, 01:03 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 74
Репутация: 9 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте)))
В строке А заданы даты, (цвета я выделил в файле) в синий мне требуется автоматически как не будь перенести в том же порядке что и в желтом (числа, буквы и пустые строки), но требуется чтобы поиск производился целиком в строках F1:F30 и при совпадении дат они перенеслись.
Может быть в условии задать чтобы сравнивалось кол-во одинаковых дат или как то еще… Помогите народ)))
К сообщению приложен файл: _Microsoft_Exce.xlsx(9Kb)


Сообщение отредактировал n0leg68 - Воскресенье, 28.08.2016, 01:08
 
Ответить
СообщениеЗдравствуйте)))
В строке А заданы даты, (цвета я выделил в файле) в синий мне требуется автоматически как не будь перенести в том же порядке что и в желтом (числа, буквы и пустые строки), но требуется чтобы поиск производился целиком в строках F1:F30 и при совпадении дат они перенеслись.
Может быть в условии задать чтобы сравнивалось кол-во одинаковых дат или как то еще… Помогите народ)))

Автор - n0leg68
Дата добавления - 28.08.2016 в 01:03
gling Дата: Воскресенье, 28.08.2016, 08:03 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1641
Репутация: 399 ±
Замечаний: 0% ±

2010
Здравствуйте. Может формула массива подойдет. Только вместо пустой ячейки проставляет ноль.
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$1:$F$30;НАИМЕНЬШИЙ(ЕСЛИ($E$1:$E$30=A1;СТРОКА($E$1:$E$30);"");СТРОКА()));"")
К сообщению приложен файл: n0leg68.xlsx(10Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Может формула массива подойдет. Только вместо пустой ячейки проставляет ноль.
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$1:$F$30;НАИМЕНЬШИЙ(ЕСЛИ($E$1:$E$30=A1;СТРОКА($E$1:$E$30);"");СТРОКА()));"")

Автор - gling
Дата добавления - 28.08.2016 в 08:03
Pelena Дата: Воскресенье, 28.08.2016, 08:25 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11605
Репутация: 2573 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Или так, только числа будут сохранены как текст
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$1:$F$30;ПОИСКПОЗ(A1;$E$1:$E$30;0)+СТРОКА()-1)&"";"")

Если уж совсем точно, чтобы числа как числа отображались
Код
=ЕСЛИ(ИНДЕКС($F$1:$F$30;ПОИСКПОЗ(A1;$E$1:$E$30;0)+СТРОКА()-1)="";"";ИНДЕКС($F$1:$F$30;ПОИСКПОЗ(A1;$E$1:$E$30;0)+СТРОКА()-1))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли так, только числа будут сохранены как текст
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$1:$F$30;ПОИСКПОЗ(A1;$E$1:$E$30;0)+СТРОКА()-1)&"";"")

Если уж совсем точно, чтобы числа как числа отображались
Код
=ЕСЛИ(ИНДЕКС($F$1:$F$30;ПОИСКПОЗ(A1;$E$1:$E$30;0)+СТРОКА()-1)="";"";ИНДЕКС($F$1:$F$30;ПОИСКПОЗ(A1;$E$1:$E$30;0)+СТРОКА()-1))

Автор - Pelena
Дата добавления - 28.08.2016 в 08:25
jakim Дата: Воскресенье, 28.08.2016, 10:43 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 804
Репутация: 206 ±
Замечаний: 0% ±

Ещё один вариант с формулой

Код
=IFERROR(INDEX(E$1:E$30;AGGREGATE(15;6;ROW($1:$100)/($E$1:$E$30=$H$1);ROWS($1:1)));"")
К сообщению приложен файл: 8711570.xlsx(10Kb)
 
Ответить
Сообщение
Ещё один вариант с формулой

Код
=IFERROR(INDEX(E$1:E$30;AGGREGATE(15;6;ROW($1:$100)/($E$1:$E$30=$H$1);ROWS($1:1)));"")

Автор - jakim
Дата добавления - 28.08.2016 в 10:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных не нарушая порядка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!