Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднее значение в диапазоне дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение в диапазоне дат (Формулы/Formulas)
Среднее значение в диапазоне дат
duckky Дата: Среда, 31.08.2016, 07:24 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе утро, помогите, пожалуйста с форматом для функции ТЕКСТ, так как я подставляя
Код
ТЕКСТ(ячейка;"ДД.ММ.ГГГГ")
получаю, например, "01.01.2016", но дату с "" формула следующая не считает.
Прошу помочь с формулой в столбце I так, чтобы можно было протягивать её вниз и она привязывалась к датам из столбцов G и H
К сообщению приложен файл: date_format.xlsx(15Kb)


Сообщение отредактировал duckky - Среда, 31.08.2016, 07:25
 
Ответить
СообщениеДоброе утро, помогите, пожалуйста с форматом для функции ТЕКСТ, так как я подставляя
Код
ТЕКСТ(ячейка;"ДД.ММ.ГГГГ")
получаю, например, "01.01.2016", но дату с "" формула следующая не считает.
Прошу помочь с формулой в столбце I так, чтобы можно было протягивать её вниз и она привязывалась к датам из столбцов G и H

Автор - duckky
Дата добавления - 31.08.2016 в 07:24
китин Дата: Среда, 31.08.2016, 07:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3433
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
чёт вы там нагородили :D так не проще будет? (если правильно понял)
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН($C$3:$C$100;$B$3:$B$100;">="&G7;$B$3:$B$100;"<="&H7);0)
а можно и так извратиться
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ($C$8:$C$38*($B$8:$B$38>=G7)*($B$8:$B$38<=H7))/СУММПРОИЗВ(ЕЧИСЛО($C$8:$C$38)*($B$8:$B$38>=G7)*($B$8:$B$38<=H7));0)
К сообщению приложен файл: 222333.xlsx(16Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 31.08.2016, 07:53
 
Ответить
Сообщениечёт вы там нагородили :D так не проще будет? (если правильно понял)
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН($C$3:$C$100;$B$3:$B$100;">="&G7;$B$3:$B$100;"<="&H7);0)
а можно и так извратиться
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ($C$8:$C$38*($B$8:$B$38>=G7)*($B$8:$B$38<=H7))/СУММПРОИЗВ(ЕЧИСЛО($C$8:$C$38)*($B$8:$B$38>=G7)*($B$8:$B$38<=H7));0)

Автор - китин
Дата добавления - 31.08.2016 в 07:47
Pelena Дата: Среда, 31.08.2016, 08:02 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9857
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Или сводной с группировкой по месяцам
[p.s.]В предыдущих формулах H7 не надо включать ;) [/p.s.]
К сообщению приложен файл: 9827714.xlsx(20Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли сводной с группировкой по месяцам
[p.s.]В предыдущих формулах H7 не надо включать ;) [/p.s.]

Автор - Pelena
Дата добавления - 31.08.2016 в 08:02
duckky Дата: Среда, 31.08.2016, 08:20 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В предыдущих формулах H7 не надо включать

А почему не надо? там как раз указывается максимальная дата для условия.

и ещё
Код
&H7

знак "&" что означает?
 
Ответить
Сообщение
В предыдущих формулах H7 не надо включать

А почему не надо? там как раз указывается максимальная дата для условия.

и ещё
Код
&H7

знак "&" что означает?

Автор - duckky
Дата добавления - 31.08.2016 в 08:20
Pelena Дата: Среда, 31.08.2016, 08:27 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9857
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
почему не надо?

Потому что в Н7 уже следующий месяц.
Вместо
Код
"<="&H7
надо
Код
"<"&H7


& - это сцепление строк


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
почему не надо?

Потому что в Н7 уже следующий месяц.
Вместо
Код
"<="&H7
надо
Код
"<"&H7


& - это сцепление строк

Автор - Pelena
Дата добавления - 31.08.2016 в 08:27
duckky Дата: Среда, 31.08.2016, 09:33 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, за помощь
 
Ответить
СообщениеСпасибо, за помощь

Автор - duckky
Дата добавления - 31.08.2016 в 09:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение в диапазоне дат (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!