Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Составление списка групп и количества пользователей в них - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление списка групп и количества пользователей в них (Формулы/Formulas)
Составление списка групп и количества пользователей в них
Strateg_ru Дата: Воскресенье, 04.09.2016, 17:13 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, уважаемые эксперты форума!
Требуется Ваша помощь в следующем вопросе...

Дано:
В диапазоне Группы!B2:J17 относительно "произвольно" расставлены названия групп. Названия уникальны. В пустых ячейках - формулы, выдающие по условию - "".
В Пользователи!B:B - напротив имени пользователя стоит одна из групп вышеприведённого диапазона (вставляется вручную).

Нужно:
На странице Количество, в столбце А - выводить список групп из диапазона Группы!B2:J17 строго слева направо и сверху вниз. Если в данном диапазоне добавляется ещё одна группа, она добавляется за предыдущей, а всё следующие "двигаются" на одну вниз.
В столбце В - должно стоять количество пользователей (группы из соседней - левой ячейки), напротив которых, на странице Пользователей, стоит эта группа.

Количественные требования к формуле - групп в диапазоне - до 1000. Пользователей в группе - до 100.

Образцы помечены цветом.
К сообщению приложен файл: _1.xlsx(11Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые эксперты форума!
Требуется Ваша помощь в следующем вопросе...

Дано:
В диапазоне Группы!B2:J17 относительно "произвольно" расставлены названия групп. Названия уникальны. В пустых ячейках - формулы, выдающие по условию - "".
В Пользователи!B:B - напротив имени пользователя стоит одна из групп вышеприведённого диапазона (вставляется вручную).

Нужно:
На странице Количество, в столбце А - выводить список групп из диапазона Группы!B2:J17 строго слева направо и сверху вниз. Если в данном диапазоне добавляется ещё одна группа, она добавляется за предыдущей, а всё следующие "двигаются" на одну вниз.
В столбце В - должно стоять количество пользователей (группы из соседней - левой ячейки), напротив которых, на странице Пользователей, стоит эта группа.

Количественные требования к формуле - групп в диапазоне - до 1000. Пользователей в группе - до 100.

Образцы помечены цветом.

Автор - Strateg_ru
Дата добавления - 04.09.2016 в 17:13
buchlotnik Дата: Воскресенье, 04.09.2016, 17:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
жуть какую-то соорудил
Код
=ЕСЛИОШИБКА(ИНДЕКС(Группы!$A$1:$J$17;ЦЕЛОЕ(НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(Группы!$B$2:$J$17)>0;СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1))%);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(Группы!$B$2:$J$17)>0;СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1));100));"")
массивка. Нули форматом убрал
UPD Чутка сократил
Код
=ЕСЛИОШИБКА(ИНДЕКС(Группы!$A$1:$J$17;ЦЕЛОЕ(НАИМЕНЬШИЙ(ЕСЛИ(Группы!$B$2:$J$17<>"";СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1))%);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Группы!$B$2:$J$17<>"";СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1));100));"")
К сообщению приложен файл: 5008578.xlsx(20Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Воскресенье, 04.09.2016, 18:08
 
Ответить
Сообщениежуть какую-то соорудил
Код
=ЕСЛИОШИБКА(ИНДЕКС(Группы!$A$1:$J$17;ЦЕЛОЕ(НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(Группы!$B$2:$J$17)>0;СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1))%);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ДЛСТР(Группы!$B$2:$J$17)>0;СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1));100));"")
массивка. Нули форматом убрал
UPD Чутка сократил
Код
=ЕСЛИОШИБКА(ИНДЕКС(Группы!$A$1:$J$17;ЦЕЛОЕ(НАИМЕНЬШИЙ(ЕСЛИ(Группы!$B$2:$J$17<>"";СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1))%);ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Группы!$B$2:$J$17<>"";СТРОКА(Группы!$B$2:$J$17)*100+СТОЛБЕЦ(Группы!$B$2:$J$17);"");СТРОКА(A1));100));"")

Автор - buchlotnik
Дата добавления - 04.09.2016 в 17:52
Nic70y Дата: Воскресенье, 04.09.2016, 17:56 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
примерно тоже, наверное, не проверял :(
Код
=ИНДЕКС(Группы!A$1:J$17;НАИМЕНЬШИЙ(ЕСЛИ(Группы!B$2:J$17<>"";СТРОКА(A$2:G$17));СТРОКА(A1));ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Группы!B$2:J$17<>"";СТРОКА(A$2:G$17)+СТОЛБЕЦ(Группы!B$2:J$17)/1000);СТРОКА(A1));1)*1000;))
Код
=СЧЁТЕСЛИ(Пользователи!B:B;A2)
К сообщению приложен файл: 7351264.xlsx(13Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениепримерно тоже, наверное, не проверял :(
Код
=ИНДЕКС(Группы!A$1:J$17;НАИМЕНЬШИЙ(ЕСЛИ(Группы!B$2:J$17<>"";СТРОКА(A$2:G$17));СТРОКА(A1));ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(Группы!B$2:J$17<>"";СТРОКА(A$2:G$17)+СТОЛБЕЦ(Группы!B$2:J$17)/1000);СТРОКА(A1));1)*1000;))
Код
=СЧЁТЕСЛИ(Пользователи!B:B;A2)

Автор - Nic70y
Дата добавления - 04.09.2016 в 17:56
buchlotnik Дата: Воскресенье, 04.09.2016, 18:09 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
примерно тоже, наверное
то же, то же. Только чутка покороче и пошустрее, чем у меня hands


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
примерно тоже, наверное
то же, то же. Только чутка покороче и пошустрее, чем у меня hands

Автор - buchlotnik
Дата добавления - 04.09.2016 в 18:09
Strateg_ru Дата: Воскресенье, 04.09.2016, 22:12 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Друзья, спасибо огромное!
У Nic70y немного запутался с диапазоном J и G, но формула полностью решает свою задачу!
Всем плюсую.
Тему можно закрывать.
 
Ответить
СообщениеДрузья, спасибо огромное!
У Nic70y немного запутался с диапазоном J и G, но формула полностью решает свою задачу!
Всем плюсую.
Тему можно закрывать.

Автор - Strateg_ru
Дата добавления - 04.09.2016 в 22:12
krosav4ig Дата: Понедельник, 05.09.2016, 00:40 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
еще вариант, без формул, с использованием надстройки Power Query
К сообщению приложен файл: 7183958.xlsx(27Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Понедельник, 05.09.2016, 00:43
 
Ответить
Сообщениееще вариант, без формул, с использованием надстройки Power Query

Автор - krosav4ig
Дата добавления - 05.09.2016 в 00:40
Strateg_ru Дата: Понедельник, 05.09.2016, 10:04 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
krosav4ig, хм, Power Query - новая для меня штука... спасибо, поизучаю.
 
Ответить
Сообщениеkrosav4ig, хм, Power Query - новая для меня штука... спасибо, поизучаю.

Автор - Strateg_ru
Дата добавления - 05.09.2016 в 10:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Составление списка групп и количества пользователей в них (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!