Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор минимальных значений из неравных диапазонов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор минимальных значений из неравных диапазонов (Формулы/Formulas)
Выбор минимальных значений из неравных диапазонов
Артемий Дата: Среда, 07.09.2016, 18:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, товарищи! Долгое время бьюсь над одной проблемой. Файл прикрепляю. В первую строчку столбца Н каждого цвета необходимо вставить минимальное значение из столбца Е того же цвета. По тому же принципу в первую строчку столбца I каждого цвета необходимо вставить максимальное значение из столбца F того же цвета. Желательно, чтобы это всё было в виде формулы, которую можно будет протягивать ниже. Заранее спасибо!
К сообщению приложен файл: ToForum.xlsx(10Kb)
 
Ответить
СообщениеЗдравствуйте, товарищи! Долгое время бьюсь над одной проблемой. Файл прикрепляю. В первую строчку столбца Н каждого цвета необходимо вставить минимальное значение из столбца Е того же цвета. По тому же принципу в первую строчку столбца I каждого цвета необходимо вставить максимальное значение из столбца F того же цвета. Желательно, чтобы это всё было в виде формулы, которую можно будет протягивать ниже. Заранее спасибо!

Автор - Артемий
Дата добавления - 07.09.2016 в 18:33
Pelena Дата: Среда, 07.09.2016, 18:46 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9842
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Если правильно поняла, формула массива
Код
=ЕСЛИ(G1="";"";МИН(ЕСЛИ(C1&D1=$C$1:$C$55&$D$1:$D$55;$E$1:$E$55)))
К сообщению приложен файл: 6679706.xlsx(13Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла, формула массива
Код
=ЕСЛИ(G1="";"";МИН(ЕСЛИ(C1&D1=$C$1:$C$55&$D$1:$D$55;$E$1:$E$55)))

Автор - Pelena
Дата добавления - 07.09.2016 в 18:46
Nic70y Дата: Среда, 07.09.2016, 19:00 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3474
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
немассивный вариант
Код
=ЕСЛИ($G1<>"";МИН(E1:ИНДЕКС(E:E;СЧЁТЕСЛИМН($C:$C;$C1;$D:$D;$D1)+СТРОКА()-1));"")
или
Код
=ЕСЛИ(G1="";"";МИН(E1:ИНДЕКС(E:E;ЕСЛИОШИБКА(ПОИСКПОЗ("*";$G2:$G$55;)+СТРОКА()-1;55))))
К сообщению приложен файл: 4426570.xlsx(14Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Среда, 07.09.2016, 19:13
 
Ответить
Сообщениенемассивный вариант
Код
=ЕСЛИ($G1<>"";МИН(E1:ИНДЕКС(E:E;СЧЁТЕСЛИМН($C:$C;$C1;$D:$D;$D1)+СТРОКА()-1));"")
или
Код
=ЕСЛИ(G1="";"";МИН(E1:ИНДЕКС(E:E;ЕСЛИОШИБКА(ПОИСКПОЗ("*";$G2:$G$55;)+СТРОКА()-1;55))))

Автор - Nic70y
Дата добавления - 07.09.2016 в 19:00
Артемий Дата: Четверг, 08.09.2016, 09:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо большое! Да, всё верно, это как раз то, что мне было нужно! Спасибо!!
 
Ответить
СообщениеСпасибо большое! Да, всё верно, это как раз то, что мне было нужно! Спасибо!!

Автор - Артемий
Дата добавления - 08.09.2016 в 09:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор минимальных значений из неравных диапазонов (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!