Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Накопительный итог из разных столбцов по критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Накопительный итог из разных столбцов по критериям (Формулы/Formulas)
Накопительный итог из разных столбцов по критериям
Viper Дата: Четверг, 15.09.2016, 11:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Друзья нужна ваша помощь!
Помогите с формулой подсчитывающей накопительный результат по месяцам, первый и последний месяц можно изменять, также можно указывать вид деятельности (в файле выделены желтым).
Результат подсчитывается в "зеленых" ячейках.
Я кроме как указывать формулу для каждого месяца отдельно ничего придумать не смог... :(

Спасибо,
К сообщению приложен файл: 9138730.xls(38Kb)
 
Ответить
СообщениеДрузья нужна ваша помощь!
Помогите с формулой подсчитывающей накопительный результат по месяцам, первый и последний месяц можно изменять, также можно указывать вид деятельности (в файле выделены желтым).
Результат подсчитывается в "зеленых" ячейках.
Я кроме как указывать формулу для каждого месяца отдельно ничего придумать не смог... :(

Спасибо,

Автор - Viper
Дата добавления - 15.09.2016 в 11:39
_Boroda_ Дата: Четверг, 15.09.2016, 11:54 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(C$6:AX$13*(A$6:A$13=A17)*(B$6:B$13=B17)*(C$5:AX$5=B$20)*(СТОЛБЕЦ(C:AX)>B$22*4-2)*(СТОЛБЕЦ(C:AX)<B$23*4+3))
К сообщению приложен файл: 9138730_1.xls(43Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(C$6:AX$13*(A$6:A$13=A17)*(B$6:B$13=B17)*(C$5:AX$5=B$20)*(СТОЛБЕЦ(C:AX)>B$22*4-2)*(СТОЛБЕЦ(C:AX)<B$23*4+3))

Автор - _Boroda_
Дата добавления - 15.09.2016 в 11:54
Pelena Дата: Четверг, 15.09.2016, 11:55 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9882
Репутация: 2266 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=СУММПРОИЗВ($C$6:$AX$13*($A$6:$A$13=A17)*($B$6:$B$13=B17)*(СТОЛБЕЦ($C$6:$AX$13)>=$B$22*4-3)*(СТОЛБЕЦ($C$6:$AX$13)<=$B$23*4)*($C$5:$AX$5=$B$20))
К сообщению приложен файл: 5091776.xls(38Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ($C$6:$AX$13*($A$6:$A$13=A17)*($B$6:$B$13=B17)*(СТОЛБЕЦ($C$6:$AX$13)>=$B$22*4-3)*(СТОЛБЕЦ($C$6:$AX$13)<=$B$23*4)*($C$5:$AX$5=$B$20))

Автор - Pelena
Дата добавления - 15.09.2016 в 11:55
китин Дата: Четверг, 15.09.2016, 12:10 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и мой вариант
Код
=СУММПРОИЗВ($C$6:$AX$13*($B$6:$B$13=$B17)*($A$6:$A$13=$A17)*(МЕСЯЦ(1&$C$4:$AX$4)>=$B$22)*(МЕСЯЦ(1&$C$4:$AX$4)<=$B$23)*($C$5:$AX$5=$B$20))
[p.s.]убрал объединение ячеек.
К сообщению приложен файл: 444222.xls(40Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 15.09.2016, 12:11
 
Ответить
Сообщениеи мой вариант
Код
=СУММПРОИЗВ($C$6:$AX$13*($B$6:$B$13=$B17)*($A$6:$A$13=$A17)*(МЕСЯЦ(1&$C$4:$AX$4)>=$B$22)*(МЕСЯЦ(1&$C$4:$AX$4)<=$B$23)*($C$5:$AX$5=$B$20))
[p.s.]убрал объединение ячеек.

Автор - китин
Дата добавления - 15.09.2016 в 12:10
Viper Дата: Четверг, 15.09.2016, 12:21 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Огромное спасибо! Работает! постараюсь разобраться в формуле. Еще один вопрос, если кол-во столбцов в одном месяце будет другим, какой частью формулы это регулируется?

Pelena, Спасибо большое за участие) но формула перестает считать правильно как только указать вид деятельности В или Г
 
Ответить
Сообщение_Boroda_, Огромное спасибо! Работает! постараюсь разобраться в формуле. Еще один вопрос, если кол-во столбцов в одном месяце будет другим, какой частью формулы это регулируется?

Pelena, Спасибо большое за участие) но формула перестает считать правильно как только указать вид деятельности В или Г

Автор - Viper
Дата добавления - 15.09.2016 в 12:21
Pelena Дата: Четверг, 15.09.2016, 12:28 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9882
Репутация: 2266 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
формула перестает считать правильно как только указать вид деятельности В или Г

Напутала со столбцами
Код
=СУММПРОИЗВ($C$6:$AX$13*($A$6:$A$13=A17)*($B$6:$B$13=B17)*(СТОЛБЕЦ($C$6:$AX$13)>=$B$22*4-1)*(СТОЛБЕЦ($C$6:$AX$13)<=$B$23*4+2)*($C$5:$AX$5=$B$20))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
формула перестает считать правильно как только указать вид деятельности В или Г

Напутала со столбцами
Код
=СУММПРОИЗВ($C$6:$AX$13*($A$6:$A$13=A17)*($B$6:$B$13=B17)*(СТОЛБЕЦ($C$6:$AX$13)>=$B$22*4-1)*(СТОЛБЕЦ($C$6:$AX$13)<=$B$23*4+2)*($C$5:$AX$5=$B$20))

Автор - Pelena
Дата добавления - 15.09.2016 в 12:28
_Boroda_ Дата: Четверг, 15.09.2016, 12:40 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
если кол-во столбцов в одном месяце будет другим, какой частью формулы это регулируется?

Видите в формуле две четверки? вот ими и регулируется.
Еще есть двойка и тройка
2 = кол-во столбцов ДО января
3 = 2 + 1


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
если кол-во столбцов в одном месяце будет другим, какой частью формулы это регулируется?

Видите в формуле две четверки? вот ими и регулируется.
Еще есть двойка и тройка
2 = кол-во столбцов ДО января
3 = 2 + 1

Автор - _Boroda_
Дата добавления - 15.09.2016 в 12:40
Viper Дата: Четверг, 15.09.2016, 12:50 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо большое, разобрался!
 
Ответить
Сообщение_Boroda_, Спасибо большое, разобрался!

Автор - Viper
Дата добавления - 15.09.2016 в 12:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Накопительный итог из разных столбцов по критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!