Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и сумма из диапазона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и сумма из диапазона (Формулы/Formulas)
Поиск и сумма из диапазона
Shadovi4 Дата: Четверг, 15.09.2016, 15:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго дня, знатоки!

Есть некий отчет, о заправках ТС, который выгружается с определенного сайта (под зеленой линией), из него делается поиск и подставляется в таблицу (над зеленой линией). Вопрос:
1. ТС за день может заправиться несколько раз, нужно, чтобы эти суммы суммировались
2. Почему то значения не подставляются в верхнюю таблицу, если до этого через Ctrl+F не заменить все даты на аналогичные, т.е. 10.08.2016 на 10.08.2016. Может че то с форматом, хз...
К сообщению приложен файл: 2649473.xlsx(19Kb)
 
Ответить
СообщениеДоброго дня, знатоки!

Есть некий отчет, о заправках ТС, который выгружается с определенного сайта (под зеленой линией), из него делается поиск и подставляется в таблицу (над зеленой линией). Вопрос:
1. ТС за день может заправиться несколько раз, нужно, чтобы эти суммы суммировались
2. Почему то значения не подставляются в верхнюю таблицу, если до этого через Ctrl+F не заменить все даты на аналогичные, т.е. 10.08.2016 на 10.08.2016. Может че то с форматом, хз...

Автор - Shadovi4
Дата добавления - 15.09.2016 в 15:27
китин Дата: Четверг, 15.09.2016, 15:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3438
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну не знаю как понял формула массива
Код
=СУММПРОИЗВ((ЕСЛИ(ЕЧИСЛО(--$D$11:$D$1000);--$D$11:$D$1000))*($A3=$L$11:$L$1000)*(ЕСЛИ(ЕЧИСЛО(--$B$11:$L$1000);--$B$11:$L$1000=C$2)))
К сообщению приложен файл: 44444444.xlsx(19Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену не знаю как понял формула массива
Код
=СУММПРОИЗВ((ЕСЛИ(ЕЧИСЛО(--$D$11:$D$1000);--$D$11:$D$1000))*($A3=$L$11:$L$1000)*(ЕСЛИ(ЕЧИСЛО(--$B$11:$L$1000);--$B$11:$L$1000=C$2)))

Автор - китин
Дата добавления - 15.09.2016 в 15:47
Pelena Дата: Четверг, 15.09.2016, 15:53 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Похожая формула массива
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(--$D$11:$D$1000;0);(ЕСЛИОШИБКА(--$B$11:$B$1000;0)=C$2)*($K$11:$K$1000=$B3))


А А3 надо учитывать? В исходной формуле, вроде нет ссылки (?)
К сообщению приложен файл: 9948524.xlsx(19Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПохожая формула массива
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(--$D$11:$D$1000;0);(ЕСЛИОШИБКА(--$B$11:$B$1000;0)=C$2)*($K$11:$K$1000=$B3))


А А3 надо учитывать? В исходной формуле, вроде нет ссылки (?)

Автор - Pelena
Дата добавления - 15.09.2016 в 15:53
Shadovi4 Дата: Четверг, 15.09.2016, 16:01 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А А3 надо учитывать? В исходной формуле, вроде нет ссылки (?)

В А3 указан номер ТС, что вы имеете в виду?

Спасибо, формулы рабочие обе, буду масштабировать. Единственно, объясните, пожалуйста, почему у меня моя формула не работала если даты не менялись?
 
Ответить
Сообщение
А А3 надо учитывать? В исходной формуле, вроде нет ссылки (?)

В А3 указан номер ТС, что вы имеете в виду?

Спасибо, формулы рабочие обе, буду масштабировать. Единственно, объясните, пожалуйста, почему у меня моя формула не работала если даты не менялись?

Автор - Shadovi4
Дата добавления - 15.09.2016 в 16:01
китин Дата: Четверг, 15.09.2016, 16:02 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3438
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а у вас в выгрузке все отформатировано как текст. Поэтому мы и поставили бинарное отрицание (--)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа у вас в выгрузке все отформатировано как текст. Поэтому мы и поставили бинарное отрицание (--)

Автор - китин
Дата добавления - 15.09.2016 в 16:02
_Boroda_ Дата: Четверг, 15.09.2016, 16:04 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9371
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А у меня такая получилась
Код
=СУММ(ЕСЛИОШИБКА($D$11:$D$999*(--$B$11:$B$999=C$2)*($K$11:$K$999=$B3);))

Тоже формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
К сообщению приложен файл: 2649473_1.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА у меня такая получилась
Код
=СУММ(ЕСЛИОШИБКА($D$11:$D$999*(--$B$11:$B$999=C$2)*($K$11:$K$999=$B3);))

Тоже формула массива (вводится одновременным нажатием Контрл Шифт Ентер)

Автор - _Boroda_
Дата добавления - 15.09.2016 в 16:04
Pelena Дата: Четверг, 15.09.2016, 16:07 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9864
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
что вы имеете в виду?

Номер карты и номер ТС однозначно связаны?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
что вы имеете в виду?

Номер карты и номер ТС однозначно связаны?

Автор - Pelena
Дата добавления - 15.09.2016 в 16:07
Shadovi4 Дата: Пятница, 16.09.2016, 10:17 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010

Номер карты и номер ТС однозначно связаны?

Так точно, но если карту потеряет...

Всем спасибо, все формулы рабочие


Сообщение отредактировал Shadovi4 - Пятница, 16.09.2016, 10:19
 
Ответить
Сообщение

Номер карты и номер ТС однозначно связаны?

Так точно, но если карту потеряет...

Всем спасибо, все формулы рабочие

Автор - Shadovi4
Дата добавления - 16.09.2016 в 10:17
Shadovi4 Дата: Пятница, 16.09.2016, 12:30 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Возникла проблема, в выгружаемом отчете номер карты может быть указан по разному. Вот такие есть варианты: 257000001, 0257000001, 0257 000001. Формулы считают только если указан первый вариант
 
Ответить
СообщениеВозникла проблема, в выгружаемом отчете номер карты может быть указан по разному. Вот такие есть варианты: 257000001, 0257000001, 0257 000001. Формулы считают только если указан первый вариант

Автор - Shadovi4
Дата добавления - 16.09.2016 в 12:30
ShAM Дата: Суббота, 17.09.2016, 09:51 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1233
Репутация: 209 ±
Замечаний: 0% ±

Excel 2010
Здесь уже была подсказка:
Поэтому мы и поставили бинарное отрицание (--)
Попробуйте поменять формулу так (добавил"--", взял у _Boroda_):
Код
=СУММ(ЕСЛИОШИБКА($D$11:$D$999*(--$B$11:$B$999=C$2)*(--$K$11:$K$999=$B3))


Сообщение отредактировал ShAM - Суббота, 17.09.2016, 09:54
 
Ответить
СообщениеЗдесь уже была подсказка:
Поэтому мы и поставили бинарное отрицание (--)
Попробуйте поменять формулу так (добавил"--", взял у _Boroda_):
Код
=СУММ(ЕСЛИОШИБКА($D$11:$D$999*(--$B$11:$B$999=C$2)*(--$K$11:$K$999=$B3))

Автор - ShAM
Дата добавления - 17.09.2016 в 09:51
Shadovi4 Дата: Понедельник, 19.09.2016, 09:42 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Попробовал, не помогло, вообще перестало считать
 
Ответить
СообщениеПопробовал, не помогло, вообще перестало считать

Автор - Shadovi4
Дата добавления - 19.09.2016 в 09:42
китин Дата: Понедельник, 19.09.2016, 09:43 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3438
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вообще перестало считать

покажите


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
вообще перестало считать

покажите

Автор - китин
Дата добавления - 19.09.2016 в 09:43
Shadovi4 Дата: Понедельник, 19.09.2016, 17:44 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
вообще перестало считать

покажите
К сообщению приложен файл: my_report.xlsx(17Kb)
 
Ответить
Сообщение
вообще перестало считать

покажите

Автор - Shadovi4
Дата добавления - 19.09.2016 в 17:44
_Boroda_ Дата: Понедельник, 19.09.2016, 17:48 | Сообщение № 14
Группа: Модераторы
Ранг: Экселист
Сообщений: 9371
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А так?
Код
=СУММ(ЕСЛИОШИБКА($D$7:$D$7634*(--$B$7:$B$7634=C$3)*(--ПОДСТАВИТЬ($K$7:$K$7634;" ";)=--ПОДСТАВИТЬ($B4;" ";));))
К сообщению приложен файл: my_report_1.xlsx(17Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА так?
Код
=СУММ(ЕСЛИОШИБКА($D$7:$D$7634*(--$B$7:$B$7634=C$3)*(--ПОДСТАВИТЬ($K$7:$K$7634;" ";)=--ПОДСТАВИТЬ($B4;" ";));))

Автор - _Boroda_
Дата добавления - 19.09.2016 в 17:48
Shadovi4 Дата: Вторник, 20.09.2016, 14:58 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А так работает исправно, спасибо
 
Ответить
СообщениеА так работает исправно, спасибо

Автор - Shadovi4
Дата добавления - 20.09.2016 в 14:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и сумма из диапазона (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!