Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднее буквенное значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее буквенное значение (Формулы/Formulas)
Среднее буквенное значение
Gajka02 Дата: Суббота, 17.09.2016, 16:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. На работе столкнулась с проблемой.
Есть всего три обозначения буквенные которые вносятся в таблицу и необходимо посчитать среднее. Реально ли это вообще?
обозначения с (среднее), в (высокое), н (низкое)

Помогите пожалуйста.
 
Ответить
СообщениеЗдравствуйте. На работе столкнулась с проблемой.
Есть всего три обозначения буквенные которые вносятся в таблицу и необходимо посчитать среднее. Реально ли это вообще?
обозначения с (среднее), в (высокое), н (низкое)

Помогите пожалуйста.

Автор - Gajka02
Дата добавления - 17.09.2016 в 16:31
Nic70y Дата: Суббота, 17.09.2016, 16:34 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3492
Репутация: 723 ±
Замечаний: 0% ±

Excel 2013
нифига не понял.
покажите в файле, что есть и какой результат хотите получить.
так, что ли:
Код
=СЧЁТЕСЛИ(A1:A17;"с")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенифига не понял.
покажите в файле, что есть и какой результат хотите получить.
так, что ли:
Код
=СЧЁТЕСЛИ(A1:A17;"с")

Автор - Nic70y
Дата добавления - 17.09.2016 в 16:34
gge29 Дата: Суббота, 17.09.2016, 17:19 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 3 ±
Замечаний: 0% ±

как-то так
К сообщению приложен файл: 111.xlsx(11Kb)
 
Ответить
Сообщениекак-то так

Автор - gge29
Дата добавления - 17.09.2016 в 17:19
Gajka02 Дата: Понедельник, 19.09.2016, 06:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
в таблицу мы заносим уровень развития по определенным критериям, и нам надо посчитать средний. данные заносятся буквенные
К сообщению приложен файл: 11111.xlsx(8Kb)
 
Ответить
Сообщениев таблицу мы заносим уровень развития по определенным критериям, и нам надо посчитать средний. данные заносятся буквенные

Автор - Gajka02
Дата добавления - 19.09.2016 в 06:21
Pelena Дата: Понедельник, 19.09.2016, 07:08 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Вы бы пояснили критерий, по которому из различных сочетаниях букв должен получиться результат. В примере бы вручную написали, а то как-то всё расплывчато.
Так, например, не подойдёт?
Код
=ВЫБОР(ОКРУГЛ(СУММ(СЧЁТЕСЛИ(B3:F3;"в")*3;СЧЁТЕСЛИ(B3:F3;"с")*2;СЧЁТЕСЛИ(B3:F3;"н"))/5;0);"н";"с";"в")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВы бы пояснили критерий, по которому из различных сочетаниях букв должен получиться результат. В примере бы вручную написали, а то как-то всё расплывчато.
Так, например, не подойдёт?
Код
=ВЫБОР(ОКРУГЛ(СУММ(СЧЁТЕСЛИ(B3:F3;"в")*3;СЧЁТЕСЛИ(B3:F3;"с")*2;СЧЁТЕСЛИ(B3:F3;"н"))/5;0);"н";"с";"в")

Автор - Pelena
Дата добавления - 19.09.2016 в 07:08
AlexM Дата: Понедельник, 19.09.2016, 09:13 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Укороченная формула Елены (Pelena)
Код
=ВЫБОР(ОКРУГЛ(СУММ(СЧЁТЕСЛИ(B3:H3;{"в":"с":"н"})*{3:2:1})/5;0);"н";"с";"в")
PS. почему то не получилось вставить формулу без 0 в функции ОКРУГЛ(). Точка с запятой без пробела между знаками дают смайл.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 19.09.2016, 09:21
 
Ответить
СообщениеУкороченная формула Елены (Pelena)
Код
=ВЫБОР(ОКРУГЛ(СУММ(СЧЁТЕСЛИ(B3:H3;{"в":"с":"н"})*{3:2:1})/5;0);"н";"с";"в")
PS. почему то не получилось вставить формулу без 0 в функции ОКРУГЛ(). Точка с запятой без пробела между знаками дают смайл.

Автор - AlexM
Дата добавления - 19.09.2016 в 09:13
_Boroda_ Дата: Понедельник, 19.09.2016, 09:20 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не очень понятно, что же Вам в итоге нужно.
Возможно, что-то из этого подойдет
Код
=ИНДЕКС({"н";"с";"в"};МОДА(ПОИСКПОЗ(B3:F3;{"н";"с";"в"};)))

Код
=ИНДЕКС({"н";"с";"в"};СРЗНАЧ(ПОИСКПОЗ(B3:F3;{"н";"с";"в"};)))

Код
=ИНДЕКС({"н";"с";"в"};МЕДИАНА(ПОИСКПОЗ(B3:F3;{"н";"с";"в"};)))

Две последние - формулы массива, вводятся одновременным нажатием Контрл Шифт Ентер

И еще вариант формулы Елены
Код
=ИНДЕКС({"н";"с";"в"};СУММ(СЧЁТЕСЛИ(B3:F3;{"в":"с":"н"})*{3:2:1})/5+0,5)
К сообщению приложен файл: 11111-1-1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе очень понятно, что же Вам в итоге нужно.
Возможно, что-то из этого подойдет
Код
=ИНДЕКС({"н";"с";"в"};МОДА(ПОИСКПОЗ(B3:F3;{"н";"с";"в"};)))

Код
=ИНДЕКС({"н";"с";"в"};СРЗНАЧ(ПОИСКПОЗ(B3:F3;{"н";"с";"в"};)))

Код
=ИНДЕКС({"н";"с";"в"};МЕДИАНА(ПОИСКПОЗ(B3:F3;{"н";"с";"в"};)))

Две последние - формулы массива, вводятся одновременным нажатием Контрл Шифт Ентер

И еще вариант формулы Елены
Код
=ИНДЕКС({"н";"с";"в"};СУММ(СЧЁТЕСЛИ(B3:F3;{"в":"с":"н"})*{3:2:1})/5+0,5)

Автор - _Boroda_
Дата добавления - 19.09.2016 в 09:20
Gajka02 Дата: Понедельник, 19.09.2016, 14:08 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В итоге мне надо что бы по каждому человеку считался средний уровень его развития, обозначения с (среднее), в (высокое), н (низкое). У меня несколько таблиц по разным направлением развития и в каждой таблице от 5 до 10 критерий в которых мы выставляем одно из обозначений, а потом считаем среднее развитие

Мне очень помогли ваши ответы, спасибо ОГРОМНОЕ
 
Ответить
СообщениеВ итоге мне надо что бы по каждому человеку считался средний уровень его развития, обозначения с (среднее), в (высокое), н (низкое). У меня несколько таблиц по разным направлением развития и в каждой таблице от 5 до 10 критерий в которых мы выставляем одно из обозначений, а потом считаем среднее развитие

Мне очень помогли ваши ответы, спасибо ОГРОМНОЕ

Автор - Gajka02
Дата добавления - 19.09.2016 в 14:08
pers_ona Дата: Пятница, 09.12.2016, 16:44 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! тоже есть такая проблема, только надо посчитать среднее буквенное значение в определенных ячейках.
помогите пож-та.
К сообщению приложен файл: 5723666.xlsx(14Kb)


Сообщение отредактировал pers_ona - Пятница, 09.12.2016, 16:44
 
Ответить
СообщениеЗдравствуйте! тоже есть такая проблема, только надо посчитать среднее буквенное значение в определенных ячейках.
помогите пож-та.

Автор - pers_ona
Дата добавления - 09.12.2016 в 16:44
Pelena Дата: Пятница, 09.12.2016, 18:32 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Прочитайте Правила форума и создайте свою тему. Эта тема закрыта


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПрочитайте Правила форума и создайте свою тему. Эта тема закрыта

Автор - Pelena
Дата добавления - 09.12.2016 в 18:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее буквенное значение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!