Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММИРОВАНИЕ ПО НЕСКОЛЬКИМ КРИТЕРИЯМ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММИРОВАНИЕ ПО НЕСКОЛЬКИМ КРИТЕРИЯМ (Формулы/Formulas)
СУММИРОВАНИЕ ПО НЕСКОЛЬКИМ КРИТЕРИЯМ
vermut Дата: Понедельник, 19.09.2016, 13:30 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Ребята привет, пробую использовать суммеслимн, не получается надо из исходной таблицы получить отчет по контрагентам в разрезе складов.И отчет по складам с привязкой к месяцам. Файлик приложила
К сообщению приложен файл: EEE.xls(62Kb)
 
Ответить
СообщениеРебята привет, пробую использовать суммеслимн, не получается надо из исходной таблицы получить отчет по контрагентам в разрезе складов.И отчет по складам с привязкой к месяцам. Файлик приложила

Автор - vermut
Дата добавления - 19.09.2016 в 13:30
buchlotnik Дата: Понедельник, 19.09.2016, 13:38 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Сводная устроит?

[p.s.] а в SUMIFS() баксы не проставили
Код
=SUMIFS($E:$E;$F:$F;$H11;$B:$B;L$7)
К сообщению приложен файл: 2063884.xls(36Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 19.09.2016, 13:43
 
Ответить
СообщениеСводная устроит?

[p.s.] а в SUMIFS() баксы не проставили
Код
=SUMIFS($E:$E;$F:$F;$H11;$B:$B;L$7)

Автор - buchlotnik
Дата добавления - 19.09.2016 в 13:38
Szekerfehesvar Дата: Понедельник, 19.09.2016, 13:39 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 6 ±
Замечаний: 20% ±

Excel 2013
для таблицы с контрагентами
Код
=СУММЕСЛИМН($E:$E;$F:$F;I$1;$C:$C;$H2)

для таблицы по месяцам
Код
=СУММЕСЛИМН($E:$E;$F:$F;$H9;$B:$B;I$7)

во вложении ваш файл с протянутой данной формулой.

п.с. данные формулы ставятся в левый верхний угол каждой таблицы и протягиваются вправо и вниз.

вторая формула кстати - из Вашего же файла, но с проставленными значками $, которые не дают смещаться диапазонам при протягивании формулы.
К сообщению приложен файл: 9412480.xlsx(10Kb)


Сообщение отредактировал Szekerfehesvar - Понедельник, 19.09.2016, 13:43
 
Ответить
Сообщениедля таблицы с контрагентами
Код
=СУММЕСЛИМН($E:$E;$F:$F;I$1;$C:$C;$H2)

для таблицы по месяцам
Код
=СУММЕСЛИМН($E:$E;$F:$F;$H9;$B:$B;I$7)

во вложении ваш файл с протянутой данной формулой.

п.с. данные формулы ставятся в левый верхний угол каждой таблицы и протягиваются вправо и вниз.

вторая формула кстати - из Вашего же файла, но с проставленными значками $, которые не дают смещаться диапазонам при протягивании формулы.

Автор - Szekerfehesvar
Дата добавления - 19.09.2016 в 13:39
TimSha Дата: Понедельник, 19.09.2016, 13:43 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 457
Репутация: 74 ±
Замечаний: 0% ±

Excel 2013 Pro +
пробую использовать суммеслимн

Осваиваем относительныне и абсолютные ссылки - A1, $A$1, $A1, A$1, читаем справку по функции, не надо задавать столбы целиком... ;)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
пробую использовать суммеслимн

Осваиваем относительныне и абсолютные ссылки - A1, $A$1, $A1, A$1, читаем справку по функции, не надо задавать столбы целиком... ;)

Автор - TimSha
Дата добавления - 19.09.2016 в 13:43
Manyasha Дата: Понедельник, 19.09.2016, 13:50 | Сообщение № 5
Группа: Модераторы
Ранг: Старожил
Сообщений: 1587
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
vermut, здравствуйте. Вариант через суммпроизв:
Код
=СУММПРОИЗВ(($F$2:$F$12=$H9)*($B$2:$B$12=I$7)*$E$2:$E$12)
К сообщению приложен файл: EEE-1.xls(64Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеvermut, здравствуйте. Вариант через суммпроизв:
Код
=СУММПРОИЗВ(($F$2:$F$12=$H9)*($B$2:$B$12=I$7)*$E$2:$E$12)

Автор - Manyasha
Дата добавления - 19.09.2016 в 13:50
китин Дата: Понедельник, 19.09.2016, 13:59 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну или так:массивная
Код
=СУММ(ЕСЛИ(($F$2:$F$12=$H9)*($B$2:$B$12=I$7);$E$2:$E$12))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену или так:массивная
Код
=СУММ(ЕСЛИ(($F$2:$F$12=$H9)*($B$2:$B$12=I$7);$E$2:$E$12))

Автор - китин
Дата добавления - 19.09.2016 в 13:59
_Boroda_ Дата: Понедельник, 19.09.2016, 14:06 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вариант без допстолбца "Месяц" (стер его) и с автоматическими датами за тот год, который в ячейке А2 (зеленые)
Код
=СУММПРОИЗВ($E$2:$E$99*($F$2:$F$99=$H9)*(--$A$2:$A$99>=I$8)*(--$A$2:$A$99<=ДАТАМЕС(I$8;1)))
К сообщению приложен файл: EEE_1.xls(32Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВариант без допстолбца "Месяц" (стер его) и с автоматическими датами за тот год, который в ячейке А2 (зеленые)
Код
=СУММПРОИЗВ($E$2:$E$99*($F$2:$F$99=$H9)*(--$A$2:$A$99>=I$8)*(--$A$2:$A$99<=ДАТАМЕС(I$8;1)))

Автор - _Boroda_
Дата добавления - 19.09.2016 в 14:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММИРОВАНИЕ ПО НЕСКОЛЬКИМ КРИТЕРИЯМ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!