Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отсев данных по формуле: Столбец 3 = Столбец 1 - Столбец 2. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсев данных по формуле: Столбец 3 = Столбец 1 - Столбец 2. (Формулы/Formulas)
Отсев данных по формуле: Столбец 3 = Столбец 1 - Столбец 2.
Svetissa Дата: Четверг, 22.09.2016, 12:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уважаемые умные мужчины и не только 

Подскажите девушке, а то никак не могу разобраться с клиентской базой. Директор наседает…, а он толсты и тяжёлый.

Столбец 1 содержит электронную почту клиентов в количество 5 тысяч.

Столбец 2 содержит тоже электронную почту клиентов в количестве 1 тысячи ИЗ СТОЛБЦА 1

Надо: чтобы столбце 3 появилась список электронной почты клиентов из столбца 1 за минусом клиентов из столбца 2.

Казалось бы все просто, а ничего не выходит.

В приложении файл с примером
К сообщению приложен файл: 0061792.xlsx(9Kb)


художник

Сообщение отредактировал Svetissa - Четверг, 22.09.2016, 12:40
 
Ответить
СообщениеУважаемые умные мужчины и не только 

Подскажите девушке, а то никак не могу разобраться с клиентской базой. Директор наседает…, а он толсты и тяжёлый.

Столбец 1 содержит электронную почту клиентов в количество 5 тысяч.

Столбец 2 содержит тоже электронную почту клиентов в количестве 1 тысячи ИЗ СТОЛБЦА 1

Надо: чтобы столбце 3 появилась список электронной почты клиентов из столбца 1 за минусом клиентов из столбца 2.

Казалось бы все просто, а ничего не выходит.

В приложении файл с примером

Автор - Svetissa
Дата добавления - 22.09.2016 в 12:17
_Boroda_ Дата: Четверг, 22.09.2016, 12:40 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Проще всего с допстолбцом.
Без него тоже можно, но зависнет всё на 5000 записей
К сообщению приложен файл: 0061792_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПроще всего с допстолбцом.
Без него тоже можно, но зависнет всё на 5000 записей

Автор - _Boroda_
Дата добавления - 22.09.2016 в 12:40
Ёжж Дата: Четверг, 22.09.2016, 13:39 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
А если так? Сортируем столбец С. Искомое в столбце А
К сообщению приложен файл: 0061792-2.xlsx(10Kb)
 
Ответить
СообщениеА если так? Сортируем столбец С. Искомое в столбце А

Автор - Ёжж
Дата добавления - 22.09.2016 в 13:39
китин Дата: Четверг, 22.09.2016, 13:48 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3723
Репутация: 587 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну или вот такая формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$26;НАИМЕНЬШИЙ(ЕСЛИ(($A$2:$A$26<>$B$2:$B$26)*($B$2:$B$26<>"");СТРОКА($A$2:$A$26)-1);СТРОКА(A1)));"")
но как сказано выше затормозит на
5000 записей
К сообщению приложен файл: 333111.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену или вот такая формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$26;НАИМЕНЬШИЙ(ЕСЛИ(($A$2:$A$26<>$B$2:$B$26)*($B$2:$B$26<>"");СТРОКА($A$2:$A$26)-1);СТРОКА(A1)));"")
но как сказано выше затормозит на
5000 записей

Автор - китин
Дата добавления - 22.09.2016 в 13:48
TimSha Дата: Четверг, 22.09.2016, 16:47 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 490
Репутация: 76 ±
Замечаний: 0% ±

Excel 2013 Pro +
При всем изложенном (в дополнение и 2 кроссам - планета и кибер) можно, как вариант, попробовать решение выборки через расширенный фильтр (правда, с довольно замысловатым расположением условий отбора - в горизонте).


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
СообщениеПри всем изложенном (в дополнение и 2 кроссам - планета и кибер) можно, как вариант, попробовать решение выборки через расширенный фильтр (правда, с довольно замысловатым расположением условий отбора - в горизонте).

Автор - TimSha
Дата добавления - 22.09.2016 в 16:47
krosav4ig Дата: Четверг, 22.09.2016, 17:19 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1421
Репутация: 585 ±
Замечаний: 0% ±

Excel 2007, 2013
с довольно замысловатым расположением условий отбора - в горизонте
зачем? (или я чего-то не догнал...)
данные>сортировка и фильтр>дополнительно
К сообщению приложен файл: 4439293.png(12Kb) · 2865630.xlsx(11Kb)


(_)Õvõ(_)
 
Ответить
Сообщение
с довольно замысловатым расположением условий отбора - в горизонте
зачем? (или я чего-то не догнал...)
данные>сортировка и фильтр>дополнительно

Автор - krosav4ig
Дата добавления - 22.09.2016 в 17:19
Svetissa Дата: Четверг, 22.09.2016, 22:07 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
К сообщению приложен файл: 333111.xlsx(10Kb)


С выше 5 000 не делает. Да. А мне 20000 нужно :(


художник
 
Ответить
Сообщение
К сообщению приложен файл: 333111.xlsx(10Kb)


С выше 5 000 не делает. Да. А мне 20000 нужно :(

Автор - Svetissa
Дата добавления - 22.09.2016 в 22:07
TimSha Дата: Пятница, 23.09.2016, 12:18 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 490
Репутация: 76 ±
Замечаний: 0% ±

Excel 2013 Pro +
А мне 20000 нужно

Пора вязать XL с Access'om - запрос записи без подчиненных. Как вариант, однако... ;)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
А мне 20000 нужно

Пора вязать XL с Access'om - запрос записи без подчиненных. Как вариант, однако... ;)

Автор - TimSha
Дата добавления - 23.09.2016 в 12:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсев данных по формуле: Столбец 3 = Столбец 1 - Столбец 2. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!