Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет ячеек со сбитой формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек со сбитой формулой (Формулы/Formulas)
Подсчет ячеек со сбитой формулой
Leprotto Дата: Четверг, 29.09.2016, 15:45 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем привет!
В таблице прописана формула автонумерации и применено условное форматирование на случай удаления формулы.
Но данное правило работает не на всех компьютерах, да и визуального контроля уже не хватает в большом документе.
Помогите, пожалуйста, подсчитать кол-во ячеек со сбитой формулой.
К сообщению приложен файл: formula_sbita.xlsx(13Kb)
 
Ответить
СообщениеВсем привет!
В таблице прописана формула автонумерации и применено условное форматирование на случай удаления формулы.
Но данное правило работает не на всех компьютерах, да и визуального контроля уже не хватает в большом документе.
Помогите, пожалуйста, подсчитать кол-во ячеек со сбитой формулой.

Автор - Leprotto
Дата добавления - 29.09.2016 в 15:45
buchlotnik Дата: Четверг, 29.09.2016, 16:01 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ROWS(Таблица1[№ п/п])-SUMPRODUCT(--ISFORMULA(Таблица1[№ п/п]))
К сообщению приложен файл: 6797280.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ROWS(Таблица1[№ п/п])-SUMPRODUCT(--ISFORMULA(Таблица1[№ п/п]))

Автор - buchlotnik
Дата добавления - 29.09.2016 в 16:01
Leprotto Дата: Четверг, 29.09.2016, 16:35 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik,
Код
=ЕФОРМУЛА
не работает в Excel 2010 :(
 
Ответить
Сообщениеbuchlotnik,
Код
=ЕФОРМУЛА
не работает в Excel 2010 :(

Автор - Leprotto
Дата добавления - 29.09.2016 в 16:35
buchlotnik Дата: Четверг, 29.09.2016, 16:44 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Leprotto, конечно, не работает - а у вас в профиле что указано?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеLeprotto, конечно, не работает - а у вас в профиле что указано?

Автор - buchlotnik
Дата добавления - 29.09.2016 в 16:44
Nic70y Дата: Четверг, 29.09.2016, 16:50 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
намахлевал:
Код
=ЕСЛИ(И(B3<>""; C3<>"");МАКС(A$2:A2)+1+СТРОКА()/1000000;"")
К сообщению приложен файл: 5171088.xlsx(14Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенамахлевал:
Код
=ЕСЛИ(И(B3<>""; C3<>"");МАКС(A$2:A2)+1+СТРОКА()/1000000;"")

Автор - Nic70y
Дата добавления - 29.09.2016 в 16:50
buchlotnik Дата: Четверг, 29.09.2016, 17:00 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
намахлевал
а я наUDF-ил B) [vba]
Код
Function is_formula(a As Range) As Variant()
    Dim ans(), i%, j%
    j = a.Count
    ReDim ans(1 To j)
        For i = 1 To j
            ans(i) = a(i).HasFormula
        Next
    is_formula = ans
End Function
[/vba]
К сообщению приложен файл: 6797280.xlsm(18Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 29.09.2016, 17:01
 
Ответить
Сообщение
Цитата
намахлевал
а я наUDF-ил B) [vba]
Код
Function is_formula(a As Range) As Variant()
    Dim ans(), i%, j%
    j = a.Count
    ReDim ans(1 To j)
        For i = 1 To j
            ans(i) = a(i).HasFormula
        Next
    is_formula = ans
End Function
[/vba]

Автор - buchlotnik
Дата добавления - 29.09.2016 в 17:00
Leprotto Дата: Четверг, 29.09.2016, 17:22 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik,
Цитата
а у вас в профиле что указано?

У меня 2013 и все работает, а у конечного пользователя зачастую 2010 ((
buchlotnik,
Цитата
а я наUDF-ил

Это работает в 2010 hands
Спасибо огромное!!!
 
Ответить
Сообщениеbuchlotnik,
Цитата
а у вас в профиле что указано?

У меня 2013 и все работает, а у конечного пользователя зачастую 2010 ((
buchlotnik,
Цитата
а я наUDF-ил

Это работает в 2010 hands
Спасибо огромное!!!

Автор - Leprotto
Дата добавления - 29.09.2016 в 17:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет ячеек со сбитой формулой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!