Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск количества знаков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск количества знаков (Формулы/Formulas)
Поиск количества знаков
n0leg68 Дата: Воскресенье, 02.10.2016, 08:23 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
Всем привет.
В желтой вводим название фирмы и напротив в зеленой должен выдаваться результат.
Например в желтой я пишу SUPRA, идет поиск этого слова в столбцах А2:А6, формула находит это слово и берет ячейки В3:F3 в которых требуется найти количество восклицательных знаков (!), после найденное количество умножается на ячейку В8 и выдается результат.
Т.е. при фирме SUPRA должен выйти результат - 2:08
К сообщению приложен файл: 3442803.xlsx(11Kb)
 
Ответить
СообщениеВсем привет.
В желтой вводим название фирмы и напротив в зеленой должен выдаваться результат.
Например в желтой я пишу SUPRA, идет поиск этого слова в столбцах А2:А6, формула находит это слово и берет ячейки В3:F3 в которых требуется найти количество восклицательных знаков (!), после найденное количество умножается на ячейку В8 и выдается результат.
Т.е. при фирме SUPRA должен выйти результат - 2:08

Автор - n0leg68
Дата добавления - 02.10.2016 в 08:23
Pelena Дата: Воскресенье, 02.10.2016, 08:34 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9862
Репутация: 2255 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Если в ячейке бывает только один восклицательный знак (как в примере), то формула массива
Код
=$B$8*СЧЁТ(ПОИСК("!";ИНДЕКС($B$2:$F$6;ПОИСКПОЗ(J5;$A$2:$A$6;0);0)))
К сообщению приложен файл: 4444056.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если в ячейке бывает только один восклицательный знак (как в примере), то формула массива
Код
=$B$8*СЧЁТ(ПОИСК("!";ИНДЕКС($B$2:$F$6;ПОИСКПОЗ(J5;$A$2:$A$6;0);0)))

Автор - Pelena
Дата добавления - 02.10.2016 в 08:34
Karataev Дата: Воскресенье, 02.10.2016, 08:48 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 642
Репутация: 226 ±
Замечаний: 0% ±

Excel
Вариант, если в ячейке может быть несколько восклицательных знаков. Формула массива (вводится Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА((СУММ(ДЛСТР(ИНДЕКС(B:F;ПОИСКПОЗ(J2;A:A;0);0)))-СУММ(ДЛСТР(ПОДСТАВИТЬ(ИНДЕКС(B:F;ПОИСКПОЗ(J2;A:A;0);0);"!";""))))*$B$8;"")
К сообщению приложен файл: 4780397.xlsx(10Kb)


 
Ответить
СообщениеВариант, если в ячейке может быть несколько восклицательных знаков. Формула массива (вводится Ctrl+Shift+Enter):
Код
=ЕСЛИОШИБКА((СУММ(ДЛСТР(ИНДЕКС(B:F;ПОИСКПОЗ(J2;A:A;0);0)))-СУММ(ДЛСТР(ПОДСТАВИТЬ(ИНДЕКС(B:F;ПОИСКПОЗ(J2;A:A;0);0);"!";""))))*$B$8;"")

Автор - Karataev
Дата добавления - 02.10.2016 в 08:48
n0leg68 Дата: Воскресенье, 02.10.2016, 08:52 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
Ну по практике пока встречается только по одному, а что будет дальше не известно... СПАСИБО
 
Ответить
СообщениеНу по практике пока встречается только по одному, а что будет дальше не известно... СПАСИБО

Автор - n0leg68
Дата добавления - 02.10.2016 в 08:52
AlexM Дата: Воскресенье, 02.10.2016, 10:00 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Формулы массива. Если столбцов с шифром не много
"!" в ячейке только один раз
Код
=B$8*СЧЁТ(ПОИСК("!";ВПР(J5;A$2:F$6;{2;3;4;5;6};)))
"!" в ячейке много раз
Код
=B$8*СУММ(ДЛСТР(ПОДСТАВИТЬ(ВПР(J5;A$2:F$6;{2;3;4;5;6};);{"":"!"};""))*{1:-1})


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 02.10.2016, 10:39
 
Ответить
СообщениеФормулы массива. Если столбцов с шифром не много
"!" в ячейке только один раз
Код
=B$8*СЧЁТ(ПОИСК("!";ВПР(J5;A$2:F$6;{2;3;4;5;6};)))
"!" в ячейке много раз
Код
=B$8*СУММ(ДЛСТР(ПОДСТАВИТЬ(ВПР(J5;A$2:F$6;{2;3;4;5;6};);{"":"!"};""))*{1:-1})

Автор - AlexM
Дата добавления - 02.10.2016 в 10:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск количества знаков (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!