Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать кол-во по определенному работнику с n-ой даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать кол-во по определенному работнику с n-ой даты (Формулы/Formulas)
Посчитать кол-во по определенному работнику с n-ой даты
IKart Дата: Воскресенье, 09.10.2016, 20:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток :)
Вопрос в следующем: есть массив с именами работников и их сменами по датам, известно дата их n-ой (спасибо Вам, что подсказали как это сделать), так же есть массив с разбивкой на работников, даты и и кол-во, как посчитать сумму по столбцу кол-во с даты n-ой смены по каждому работнику, дата n-ой смены у каждого своя
На самом деле я уже нашел способ, может кому будет полезно :)
1. ВПР по имени работника дату n-ой смены во второй массив
2. Сцепка по имени работника и Если(дата n-ой смены=>дате текущей смене;дата n-й смены;0)
3. В исходном массиве сцепка по имени работника и дате n-ой смены
4. Сумма если по сцепке из пункта 3
И если кто знает способ проще, поделитесь пжл, мой уровень знания эксель позволяет только таким образом решить подобную задачу :)
К сообщению приложен файл: 1418568.xlsx(11Kb)
 
Ответить
СообщениеДоброго времени суток :)
Вопрос в следующем: есть массив с именами работников и их сменами по датам, известно дата их n-ой (спасибо Вам, что подсказали как это сделать), так же есть массив с разбивкой на работников, даты и и кол-во, как посчитать сумму по столбцу кол-во с даты n-ой смены по каждому работнику, дата n-ой смены у каждого своя
На самом деле я уже нашел способ, может кому будет полезно :)
1. ВПР по имени работника дату n-ой смены во второй массив
2. Сцепка по имени работника и Если(дата n-ой смены=>дате текущей смене;дата n-й смены;0)
3. В исходном массиве сцепка по имени работника и дате n-ой смены
4. Сумма если по сцепке из пункта 3
И если кто знает способ проще, поделитесь пжл, мой уровень знания эксель позволяет только таким образом решить подобную задачу :)

Автор - IKart
Дата добавления - 09.10.2016 в 20:04
Pelena Дата: Воскресенье, 09.10.2016, 20:18 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9889
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Код
=СЧЁТЕСЛИМН(C2:AG2;">0";$C$1:$AG$1;">"&AI2)
К сообщению приложен файл: 2432455.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СЧЁТЕСЛИМН(C2:AG2;">0";$C$1:$AG$1;">"&AI2)

Автор - Pelena
Дата добавления - 09.10.2016 в 20:18
IKart Дата: Воскресенье, 09.10.2016, 21:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Я наверно немного неправильно объяснил что нужно :) страница массив 2, с даты n-смены на страницу один по работнику подтянуть сумму по столбцу кол-во
Моё верное решение, проверенное вручную, выделил синим :)
К сообщению приложен файл: 6965222.xlsx(11Kb)
 
Ответить
СообщениеЯ наверно немного неправильно объяснил что нужно :) страница массив 2, с даты n-смены на страницу один по работнику подтянуть сумму по столбцу кол-во
Моё верное решение, проверенное вручную, выделил синим :)

Автор - IKart
Дата добавления - 09.10.2016 в 21:00
Pelena Дата: Воскресенье, 09.10.2016, 21:15 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9889
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Без доп. столбцов
Код
=СУММЕСЛИМН('Массив 2'!$F$2:$F$24;'Массив 2'!$D$2:$D$24;A2;'Массив 2'!$E$2:$E$24;">="&AG2)
К сообщению приложен файл: 6690920.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеБез доп. столбцов
Код
=СУММЕСЛИМН('Массив 2'!$F$2:$F$24;'Массив 2'!$D$2:$D$24;A2;'Массив 2'!$E$2:$E$24;">="&AG2)

Автор - Pelena
Дата добавления - 09.10.2016 в 21:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать кол-во по определенному работнику с n-ой даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!