Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма, если, впр - как суммировать по условию с поиском - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма, если, впр - как суммировать по условию с поиском (Формулы/Formulas)
Сумма, если, впр - как суммировать по условию с поиском
Pioneer Дата: Воскресенье, 16.10.2016, 12:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые знатоки, подскажите пожалуйста
Суть задачи
Сумировать количество товара проданого на протяжении месяца.

Есть таблица заказов, лист "заказы", и есть лист "всего".
В таблице на листе "всего", нужно сделать поиск товара, и сумму его в каждом месяце.
К сообщению приложен файл: 7202259.xlsx(11Kb)
 
Ответить
СообщениеУважаемые знатоки, подскажите пожалуйста
Суть задачи
Сумировать количество товара проданого на протяжении месяца.

Есть таблица заказов, лист "заказы", и есть лист "всего".
В таблице на листе "всего", нужно сделать поиск товара, и сумму его в каждом месяце.

Автор - Pioneer
Дата добавления - 16.10.2016 в 12:20
gling Дата: Воскресенье, 16.10.2016, 12:31 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Избавьтесь от объединенных ячеек в столбце А Заказов, вставьте в каждую дату, ваша задача решится сводной таблицей без проблем.
К сообщению приложен файл: 7259135.xlsx(16Kb)
 
Ответить
СообщениеИзбавьтесь от объединенных ячеек в столбце А Заказов, вставьте в каждую дату, ваша задача решится сводной таблицей без проблем.

Автор - gling
Дата добавления - 16.10.2016 в 12:31
Pioneer Дата: Воскресенье, 16.10.2016, 12:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
на жаль, это не возможно. (
На самом деле, таблица с заказами намного больше (за 3 года, количество товаров х100, и количество заказов тоже по несколько в день).
 
Ответить
Сообщениена жаль, это не возможно. (
На самом деле, таблица с заказами намного больше (за 3 года, количество товаров х100, и количество заказов тоже по несколько в день).

Автор - Pioneer
Дата добавления - 16.10.2016 в 12:48
Karataev Дата: Воскресенье, 16.10.2016, 12:53 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 643
Репутация: 227 ±
Замечаний: 0% ±

Excel
Вариант с допстолбцом "E" на листе Заказы. Формула для допстолбца, для "E3" (для "E2" своя отдельная формула):
Код
=ЕСЛИ(A3<>"";МЕСЯЦ(A3)&ГОД(A3);E2)

Формула для листа "всего" для "B3":
Код
=СУММЕСЛИМН(заказы!$D:$D;заказы!$E:$E;МЕСЯЦ(B$2)&ГОД(B$2);заказы!$C:$C;всего!$A3)
К сообщению приложен файл: 1102516.xlsx(13Kb)




Сообщение отредактировал Karataev - Воскресенье, 16.10.2016, 12:55
 
Ответить
СообщениеВариант с допстолбцом "E" на листе Заказы. Формула для допстолбца, для "E3" (для "E2" своя отдельная формула):
Код
=ЕСЛИ(A3<>"";МЕСЯЦ(A3)&ГОД(A3);E2)

Формула для листа "всего" для "B3":
Код
=СУММЕСЛИМН(заказы!$D:$D;заказы!$E:$E;МЕСЯЦ(B$2)&ГОД(B$2);заказы!$C:$C;всего!$A3)

Автор - Karataev
Дата добавления - 16.10.2016 в 12:53
jakim Дата: Воскресенье, 16.10.2016, 13:27 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Тоже самое формулой.

Код
=SUMPRODUCT((YEAR(заказы!$A$2:$A$300)=YEAR(B$2))*(MONTH(заказы!$A$2:$A$300)=MONTH(B$2))*(заказы!$C$2:$C$300=$A3)*заказы!$D$2:$D$300)
К сообщению приложен файл: 7967295.xlsx(13Kb)
 
Ответить
Сообщение
Тоже самое формулой.

Код
=SUMPRODUCT((YEAR(заказы!$A$2:$A$300)=YEAR(B$2))*(MONTH(заказы!$A$2:$A$300)=MONTH(B$2))*(заказы!$C$2:$C$300=$A3)*заказы!$D$2:$D$300)

Автор - jakim
Дата добавления - 16.10.2016 в 13:27
krosav4ig Дата: Воскресенье, 16.10.2016, 13:49 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
еще вариант
Код
=СУММПРОИЗВ(($A3&ТЕКСТ(B$2;"МГ")=заказы!$C$2:$C$30&ТЕКСТ(Ч(СМЕЩ(заказы!$A$1;ПРОСМОТР(СТРОКА(заказы!$A$2:$A$30);СТРОКА(заказы!$A$2:$A$30)/заказы!$A$2:$A$30^0)-1;));"МГ"))*заказы!$D$2:$D$30)
К сообщению приложен файл: 7773850.xlsx(13Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Воскресенье, 16.10.2016, 13:50
 
Ответить
Сообщениееще вариант
Код
=СУММПРОИЗВ(($A3&ТЕКСТ(B$2;"МГ")=заказы!$C$2:$C$30&ТЕКСТ(Ч(СМЕЩ(заказы!$A$1;ПРОСМОТР(СТРОКА(заказы!$A$2:$A$30);СТРОКА(заказы!$A$2:$A$30)/заказы!$A$2:$A$30^0)-1;));"МГ"))*заказы!$D$2:$D$30)

Автор - krosav4ig
Дата добавления - 16.10.2016 в 13:49
gling Дата: Воскресенье, 16.10.2016, 15:47 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
это не возможно.
Сомневаюсь. Посмотрите
 
Ответить
Сообщение
это не возможно.
Сомневаюсь. Посмотрите

Автор - gling
Дата добавления - 16.10.2016 в 15:47
Pioneer Дата: Понедельник, 17.10.2016, 00:19 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем спасибо. Все способы работают ! beer
 
Ответить
СообщениеВсем спасибо. Все способы работают ! beer

Автор - Pioneer
Дата добавления - 17.10.2016 в 00:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма, если, впр - как суммировать по условию с поиском (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!