Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Синхронизация параметров по времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Синхронизация параметров по времени (Формулы/Formulas)
Синхронизация параметров по времени
paai87 Дата: Пятница, 21.10.2016, 14:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте, уважаемые коллеги!

Прошу помочь с организацией работ по обработке данных.

Задача: есть два массива данных, каждый в своем временном диапазоне:
1. Есть среднее значение Температуры 1 в период с 6:00 до 6:03 (ЧЧ:ММ)
2. Есть мгновенные значения Температуры 2, взятые из другого источника: 6:03:18, 6:04:20 и т.д. (ЧЧ:ММ:СС)

Необходимо, чтобы данные Температуры 2 автоматически вносились напротив соответствующей строки в нужный временной диапазон Массива данных 1.

Прошу подсказать, есть ли такие механизмы в Excel?

Если нет, то можно пойти по-упрощенной схеме:
Необходимо отбирать каждый четвертый Показатель Температуры 2 и по порядку формировать его в строки массива 1 .
К сообщению приложен файл: _..xls(35Kb)


Сообщение отредактировал paai87 - Пятница, 21.10.2016, 14:55
 
Ответить
СообщениеЗдравствуйте, уважаемые коллеги!

Прошу помочь с организацией работ по обработке данных.

Задача: есть два массива данных, каждый в своем временном диапазоне:
1. Есть среднее значение Температуры 1 в период с 6:00 до 6:03 (ЧЧ:ММ)
2. Есть мгновенные значения Температуры 2, взятые из другого источника: 6:03:18, 6:04:20 и т.д. (ЧЧ:ММ:СС)

Необходимо, чтобы данные Температуры 2 автоматически вносились напротив соответствующей строки в нужный временной диапазон Массива данных 1.

Прошу подсказать, есть ли такие механизмы в Excel?

Если нет, то можно пойти по-упрощенной схеме:
Необходимо отбирать каждый четвертый Показатель Температуры 2 и по порядку формировать его в строки массива 1 .

Автор - paai87
Дата добавления - 21.10.2016 в 14:36
buchlotnik Дата: Пятница, 21.10.2016, 15:09 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ПРОСМОТР(--ПРАВСИМВ(A8;5);$A$23:$A$44;$C$23:$C$44)
К сообщению приложен файл: -1-.xls(36Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ПРОСМОТР(--ПРАВСИМВ(A8;5);$A$23:$A$44;$C$23:$C$44)

Автор - buchlotnik
Дата добавления - 21.10.2016 в 15:09
pabchek Дата: Пятница, 21.10.2016, 16:04 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Мой вариант
Код
=ИНДЕКС($C$23:$C$44;ПОИСКПОЗ(--ПРАВБ(A8;5);$A$23:$A$44))

если без ошибок
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$23:$C$44;ПОИСКПОЗ(--ПРАВБ(A8;5);$A$23:$A$44));"")


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 21.10.2016, 16:05
 
Ответить
СообщениеМой вариант
Код
=ИНДЕКС($C$23:$C$44;ПОИСКПОЗ(--ПРАВБ(A8;5);$A$23:$A$44))

если без ошибок
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$23:$C$44;ПОИСКПОЗ(--ПРАВБ(A8;5);$A$23:$A$44));"")

Автор - pabchek
Дата добавления - 21.10.2016 в 16:04
_Boroda_ Дата: Пятница, 21.10.2016, 16:13 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А может, правильнее было бы среднее мгновенных значений взять?
Для 2003 Excel
Код
=СУММПРОИЗВ(C$23:C$44*(A$23:A$44>=--ЛЕВБ(A8;5))*(A$23:A$44<--ПРАВБ(A8;5)))/СУММПРОИЗВ((A$23:A$44>=--ЛЕВБ(A8;5))*(A$23:A$44<--ПРАВБ(A8;5)))

Для 2007 и больше
Код
=СРЗНАЧЕСЛИМН(C$23:C$44;A$23:A$44;">="&ЛЕВБ(A8;5);A$23:A$44;"<"&ПРАВБ(A8;5))
К сообщению приложен файл: -1.xls(36Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА может, правильнее было бы среднее мгновенных значений взять?
Для 2003 Excel
Код
=СУММПРОИЗВ(C$23:C$44*(A$23:A$44>=--ЛЕВБ(A8;5))*(A$23:A$44<--ПРАВБ(A8;5)))/СУММПРОИЗВ((A$23:A$44>=--ЛЕВБ(A8;5))*(A$23:A$44<--ПРАВБ(A8;5)))

Для 2007 и больше
Код
=СРЗНАЧЕСЛИМН(C$23:C$44;A$23:A$44;">="&ЛЕВБ(A8;5);A$23:A$44;"<"&ПРАВБ(A8;5))

Автор - _Boroda_
Дата добавления - 21.10.2016 в 16:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Синхронизация параметров по времени (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!