Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка нехватающего значения в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка нехватающего значения в столбце (Формулы/Formulas)
Подстановка нехватающего значения в столбце
Excel-рулит Дата: Понедельник, 24.10.2016, 13:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем добрый день!
Загвоздка вот в чем. Есть 4 магазина. В файле обозначены "К;Т;М;С" на каждом магазине присутствует менеджер. 5-ый менеджер сменный. Нужно чтобы в его графике работы автоматом выставлялась недостающая точка. Менеджеры могут быть перекинуты с точки на точку.
Спасибо за участие
К сообщению приложен файл: 4314566.xlsx(18Kb)
 
Ответить
СообщениеВсем добрый день!
Загвоздка вот в чем. Есть 4 магазина. В файле обозначены "К;Т;М;С" на каждом магазине присутствует менеджер. 5-ый менеджер сменный. Нужно чтобы в его графике работы автоматом выставлялась недостающая точка. Менеджеры могут быть перекинуты с точки на точку.
Спасибо за участие

Автор - Excel-рулит
Дата добавления - 24.10.2016 в 13:29
Excel-рулит Дата: Понедельник, 24.10.2016, 13:48 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Сам задал вопрос, сам на него ответил.
Если есть варианты формулы короче буду благодарен
Код
=ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"к")=0;"к";ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"С")=0;"с";ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"м")=0;"м";ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"т")=0;"т";""))))
 
Ответить
СообщениеСам задал вопрос, сам на него ответил.
Если есть варианты формулы короче буду благодарен
Код
=ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"к")=0;"к";ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"С")=0;"с";ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"м")=0;"м";ЕСЛИ(СЧЁТЕСЛИ(B27:B34;"т")=0;"т";""))))

Автор - Excel-рулит
Дата добавления - 24.10.2016 в 13:48
Karataev Дата: Понедельник, 24.10.2016, 14:03 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Формула массива (вводится Ctrl+Shift+Enter) для "B36". Формула основана на поиске пустой ячейки:
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСКПОЗ(0;ДЛСТР(B27:B34);0)/2;"к";"с";"м";"т");"")
К сообщению приложен файл: 2795392.xlsx(26Kb)




Сообщение отредактировал Karataev - Понедельник, 24.10.2016, 16:33
 
Ответить
СообщениеФормула массива (вводится Ctrl+Shift+Enter) для "B36". Формула основана на поиске пустой ячейки:
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСКПОЗ(0;ДЛСТР(B27:B34);0)/2;"к";"с";"м";"т");"")

Автор - Karataev
Дата добавления - 24.10.2016 в 14:03
_Boroda_ Дата: Понедельник, 24.10.2016, 14:09 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Обычная формула
Код
=ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ({1:"к":"т":"м":"с"};B27:B34;));{"":"к":"т":"м":"с"})
К сообщению приложен файл: 4314566_1.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОбычная формула
Код
=ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ({1:"к":"т":"м":"с"};B27:B34;));{"":"к":"т":"м":"с"})

Автор - _Boroda_
Дата добавления - 24.10.2016 в 14:09
AlexM Дата: Понедельник, 24.10.2016, 15:49 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Еще обычная
Код
=ВПР(;ЕСЛИ({1;0};СЧЁТЕСЛИ(F27:F34;{"к":"т":"м":"с":1});{"к":"т":"м":"с":""});2;)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 24.10.2016, 15:50
 
Ответить
СообщениеЕще обычная
Код
=ВПР(;ЕСЛИ({1;0};СЧЁТЕСЛИ(F27:F34;{"к":"т":"м":"с":1});{"к":"т":"м":"с":""});2;)

Автор - AlexM
Дата добавления - 24.10.2016 в 15:49
Karataev Дата: Понедельник, 24.10.2016, 16:32 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Еще два варианта. Основаны на поиске буквы "в".
1. Формула (немассивная) для "B36":
Код
=ЕСЛИОШИБКА(ВПР(ПОИСКПОЗ("в";B27:B34;0);{1;"к":3;"с":5;"м":7;"т"};2;0);"")

2. Вариант с допстолбцом "AJ". Формула (немассивная) для "B36":
Код
=ЕСЛИОШИБКА(ИНДЕКС($AJ$27:$AJ$34;ПОИСКПОЗ("в";B27:B34;0);1);"")
К сообщению приложен файл: 0062170.xlsx(27Kb)


 
Ответить
СообщениеЕще два варианта. Основаны на поиске буквы "в".
1. Формула (немассивная) для "B36":
Код
=ЕСЛИОШИБКА(ВПР(ПОИСКПОЗ("в";B27:B34;0);{1;"к":3;"с":5;"м":7;"т"};2;0);"")

2. Вариант с допстолбцом "AJ". Формула (немассивная) для "B36":
Код
=ЕСЛИОШИБКА(ИНДЕКС($AJ$27:$AJ$34;ПОИСКПОЗ("в";B27:B34;0);1);"")

Автор - Karataev
Дата добавления - 24.10.2016 в 16:32
sboy Дата: Понедельник, 24.10.2016, 17:11 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 48 ±
Замечаний: 0% ±

Excel 2007
Вариант с допстолбцом "AJ".

эту формулу можно без доп.столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(C27:C35;ПОИСКПОЗ("в";B27:B35;0)+1);"")

за исключением последнего столбца, там диапазон для ИНДЕКС поменять надо на AD27:AD35

AlexM, Ваша формула разрыв шаблона. Не затруднит объяснить как она работает? Поэтапное вычисление к прозрению не привело) В формулах пока новичок
 
Ответить
Сообщение
Вариант с допстолбцом "AJ".

эту формулу можно без доп.столбца
Код
=ЕСЛИОШИБКА(ИНДЕКС(C27:C35;ПОИСКПОЗ("в";B27:B35;0)+1);"")

за исключением последнего столбца, там диапазон для ИНДЕКС поменять надо на AD27:AD35

AlexM, Ваша формула разрыв шаблона. Не затруднит объяснить как она работает? Поэтапное вычисление к прозрению не привело) В формулах пока новичок

Автор - sboy
Дата добавления - 24.10.2016 в 17:11
AlexM Дата: Понедельник, 24.10.2016, 17:19 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

Еще не массивная формула
Код
=ВЫБОР(ПОИСКПОЗ("в";B26:B35;)/2;"к";"с";"м";"т";"")
Не затруднит объяснить как она работает?
ЕСЛИ({1;0};.... Создает виртуальную таблицу из двух столбцов. В первом 0 и 1, а во втором буквы. Попробуйте выделить функцию ЕСЛИ() с аргументами и нажать F9, увидите созданный массив.
ВПР() ищет 0 в первом столбце этого массива и возвращает букву из второго столбца.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще не массивная формула
Код
=ВЫБОР(ПОИСКПОЗ("в";B26:B35;)/2;"к";"с";"м";"т";"")
Не затруднит объяснить как она работает?
ЕСЛИ({1;0};.... Создает виртуальную таблицу из двух столбцов. В первом 0 и 1, а во втором буквы. Попробуйте выделить функцию ЕСЛИ() с аргументами и нажать F9, увидите созданный массив.
ВПР() ищет 0 в первом столбце этого массива и возвращает букву из второго столбца.

Автор - AlexM
Дата добавления - 24.10.2016 в 17:19
sboy Дата: Понедельник, 24.10.2016, 17:33 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 48 ±
Замечаний: 0% ±

Excel 2007
AlexM, спасибо за разъяснение, для понимания больше помогло F9 на Счетесли, увидел, как формируется виртуальная таблица. Очень интересное свойство функции ЕСЛИ!
 
Ответить
СообщениеAlexM, спасибо за разъяснение, для понимания больше помогло F9 на Счетесли, увидел, как формируется виртуальная таблица. Очень интересное свойство функции ЕСЛИ!

Автор - sboy
Дата добавления - 24.10.2016 в 17:33
AlexM Дата: Понедельник, 24.10.2016, 17:36 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3048
Репутация: 739 ±
Замечаний: 0% ±

sboy, посмотрите тему ВПР не по первому столбцу


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеsboy, посмотрите тему ВПР не по первому столбцу

Автор - AlexM
Дата добавления - 24.10.2016 в 17:36
Excel-рулит Дата: Пятница, 28.10.2016, 07:51 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Друзья спасибо всем за решения. Удачной пятницы.
 
Ответить
СообщениеДрузья спасибо всем за решения. Удачной пятницы.

Автор - Excel-рулит
Дата добавления - 28.10.2016 в 07:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка нехватающего значения в столбце (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!