Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как убрать ограничение вложенности 64? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать ограничение вложенности 64? (Формулы/Formulas)
Как убрать ограничение вложенности 64?
Wappo Дата: Воскресенье, 30.10.2016, 15:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, хотел создать формулу, но видимо она получилась большая можно обойти ограничение в 64 вложения или все же придется разбивать на части?


Сообщение отредактировал Wappo - Воскресенье, 30.10.2016, 16:13
 
Ответить
СообщениеДобрый день, хотел создать формулу, но видимо она получилась большая можно обойти ограничение в 64 вложения или все же придется разбивать на части?

Автор - Wappo
Дата добавления - 30.10.2016 в 15:17
gling Дата: Воскресенье, 30.10.2016, 15:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Здравствуйте. А может Вашу формулу можно заменить на более простую, без вложений? Опишите, что вы хотите получить и вложите файл, в соответствии с правилами. Тему придется переименовать, тоже в соответствии с правилами.


Сообщение отредактировал gling - Воскресенье, 30.10.2016, 15:29
 
Ответить
СообщениеЗдравствуйте. А может Вашу формулу можно заменить на более простую, без вложений? Опишите, что вы хотите получить и вложите файл, в соответствии с правилами. Тему придется переименовать, тоже в соответствии с правилами.

Автор - gling
Дата добавления - 30.10.2016 в 15:22
Wappo Дата: Воскресенье, 30.10.2016, 15:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
правило прочитал, и это показалось нормальное название, а так вот 1/10 часть формулы
Код
ЕСЛИ(И(A2=I1;B2=I2);J2;ЕСЛИ(И(A2=I1;B2=I3);J3;ЕСЛИ(И(A2=I1;B2=I4);J4;ЕСЛИ(И(A2=I1;B2=I5);J5;ЕСЛИ(И(A2=I1;B2=I6);J6;ЕСЛИ(И(A2=I1;B2=I7);J7;ЕСЛИ(И(A2=I1;B2=I8);J8;ЕСЛИ(И(A2=I1;B2=I9);J9;ЕСЛИ(И(A2=I1;B2=I10);J10;ЕСЛИ(И(A2=I1;B2=I11);J11;ЕСЛИ(И(A2=I1;B2=I12);J12;ЕСЛИ(И(A2=I1;B2=I13)
, меняются некоторые значения
Код
ЕСЛИ(И(A2=L1;B2=L2);M2;ЕСЛИ(И(A2=L1;B2=L3);M3;ЕСЛИ(И(A2=L1;B2=L4);M4;ЕСЛИ(И(A2=L1;B2=L5);M5;ЕСЛИ(И(A2=L1;B2=L6);M6;ЕСЛИ(И(A2=L1;B2=L7);M7;ЕСЛИ(И(A2=L1;B2=L8);M8;ЕСЛИ(И(A2=L1;B2=L9);M9;ЕСЛИ(И(A2=L1;B2=L10);M10;ЕСЛИ(И(A2=L1;B2=L11);M11;ЕСЛИ(И(A2=L1;B2=L12);M12;ЕСЛИ(И(A2=L1;B2=L13)
вот 2 часть, можно как то обойти ограничение или заменить чем нибудь?
К сообщению приложен файл: 2162311.xls(32Kb)


Сообщение отредактировал Manyasha - Воскресенье, 30.10.2016, 17:38
 
Ответить
Сообщениеправило прочитал, и это показалось нормальное название, а так вот 1/10 часть формулы
Код
ЕСЛИ(И(A2=I1;B2=I2);J2;ЕСЛИ(И(A2=I1;B2=I3);J3;ЕСЛИ(И(A2=I1;B2=I4);J4;ЕСЛИ(И(A2=I1;B2=I5);J5;ЕСЛИ(И(A2=I1;B2=I6);J6;ЕСЛИ(И(A2=I1;B2=I7);J7;ЕСЛИ(И(A2=I1;B2=I8);J8;ЕСЛИ(И(A2=I1;B2=I9);J9;ЕСЛИ(И(A2=I1;B2=I10);J10;ЕСЛИ(И(A2=I1;B2=I11);J11;ЕСЛИ(И(A2=I1;B2=I12);J12;ЕСЛИ(И(A2=I1;B2=I13)
, меняются некоторые значения
Код
ЕСЛИ(И(A2=L1;B2=L2);M2;ЕСЛИ(И(A2=L1;B2=L3);M3;ЕСЛИ(И(A2=L1;B2=L4);M4;ЕСЛИ(И(A2=L1;B2=L5);M5;ЕСЛИ(И(A2=L1;B2=L6);M6;ЕСЛИ(И(A2=L1;B2=L7);M7;ЕСЛИ(И(A2=L1;B2=L8);M8;ЕСЛИ(И(A2=L1;B2=L9);M9;ЕСЛИ(И(A2=L1;B2=L10);M10;ЕСЛИ(И(A2=L1;B2=L11);M11;ЕСЛИ(И(A2=L1;B2=L12);M12;ЕСЛИ(И(A2=L1;B2=L13)
вот 2 часть, можно как то обойти ограничение или заменить чем нибудь?

Автор - Wappo
Дата добавления - 30.10.2016 в 15:58
Nic70y Дата: Воскресенье, 30.10.2016, 16:20 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
возможно Вам нужно это
Код
=ИНДЕКС(I$2:AL$13;B2;ПОИСКПОЗ(A$2;I$1:AL$1;)+1)
К сообщению приложен файл: 9848768.xls(32Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевозможно Вам нужно это
Код
=ИНДЕКС(I$2:AL$13;B2;ПОИСКПОЗ(A$2;I$1:AL$1;)+1)

Автор - Nic70y
Дата добавления - 30.10.2016 в 16:20
Wappo Дата: Воскресенье, 30.10.2016, 16:26 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y спс, блин а как все оказалось просто)), я тока умею работать с функциями и, или, если)), сейчас буду доделывать табличку по вашему примеру
 
Ответить
СообщениеNic70y спс, блин а как все оказалось просто)), я тока умею работать с функциями и, или, если)), сейчас буду доделывать табличку по вашему примеру

Автор - Wappo
Дата добавления - 30.10.2016 в 16:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать ограничение вложенности 64? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!