Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в массиве по искомым текстовому и цифровому значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в массиве по искомым текстовому и цифровому значениям (Формулы/Formulas)
Поиск в массиве по искомым текстовому и цифровому значениям
GP75 Дата: Среда, 16.11.2016, 00:57 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Доброго времени суток. Появилась проблема в поиске искомого значения в массиве с применением команд ИНДЕКС и ПОИСКПОЗ по двум условиям. Возможно влияет, что одно из искомых значений -текст в выпадающем списке (проверки данных)? Прошу уважаемых специалистов пояснить, что я сделал не так. Пример прилагаю. Заранее признателен.
К сообщению приложен файл: primer.xls(81Kb)
 
Ответить
СообщениеДоброго времени суток. Появилась проблема в поиске искомого значения в массиве с применением команд ИНДЕКС и ПОИСКПОЗ по двум условиям. Возможно влияет, что одно из искомых значений -текст в выпадающем списке (проверки данных)? Прошу уважаемых специалистов пояснить, что я сделал не так. Пример прилагаю. Заранее признателен.

Автор - GP75
Дата добавления - 16.11.2016 в 00:57
_Boroda_ Дата: Среда, 16.11.2016, 01:24 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(B3:BD13;ПОИСКПОЗ(AI21;B4:B13;0);ПОИСКПОЗ(AN20;H3:BD3;0))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(B3:BD13;ПОИСКПОЗ(AI21;B4:B13;0);ПОИСКПОЗ(AN20;H3:BD3;0))

Автор - _Boroda_
Дата добавления - 16.11.2016 в 01:24
GP75 Дата: Среда, 16.11.2016, 01:30 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Да, спасибо. Но при смене значениий например - "морковь" и "5,0" - не работает снова
Пример прикрепил
К сообщению приложен файл: primer1.xls(78Kb)


Сообщение отредактировал GP75 - Среда, 16.11.2016, 01:30
 
Ответить
СообщениеДа, спасибо. Но при смене значениий например - "морковь" и "5,0" - не работает снова
Пример прикрепил

Автор - GP75
Дата добавления - 16.11.2016 в 01:30
GP75 Дата: Среда, 16.11.2016, 01:32 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
И результат по вашей формуле 0,74 не соответствует перекрестью "петрушка"-"2,0" почему-то - показывает 0,74 (столбец R)?, а не 0,7 (столбец Х)


Сообщение отредактировал GP75 - Среда, 16.11.2016, 01:35
 
Ответить
СообщениеИ результат по вашей формуле 0,74 не соответствует перекрестью "петрушка"-"2,0" почему-то - показывает 0,74 (столбец R)?, а не 0,7 (столбец Х)

Автор - GP75
Дата добавления - 16.11.2016 в 01:32
_Boroda_ Дата: Среда, 16.11.2016, 01:47 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, диапазоны должны быть одинаковыми
Код
=ИНДЕКС(H4:BD13;ПОИСКПОЗ(AI21;B4:B13;0);ПОИСКПОЗ(AN20;H3:BD3;0))

И перепишите формулу в сиреневых ячейках так, как я Вам написал. Excel иногда неверно округляет

Или вот так, тогда все работает и с Вашими формулами желтыми
Код
=СУММПРОИЗВ(H4:BD13*(B4:B13=AI21)*(H3:BD3=AN20))
К сообщению приложен файл: primer1_1.xls(56Kb) · primer1_2.xls(56Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, диапазоны должны быть одинаковыми
Код
=ИНДЕКС(H4:BD13;ПОИСКПОЗ(AI21;B4:B13;0);ПОИСКПОЗ(AN20;H3:BD3;0))

И перепишите формулу в сиреневых ячейках так, как я Вам написал. Excel иногда неверно округляет

Или вот так, тогда все работает и с Вашими формулами желтыми
Код
=СУММПРОИЗВ(H4:BD13*(B4:B13=AI21)*(H3:BD3=AN20))

Автор - _Boroda_
Дата добавления - 16.11.2016 в 01:47
GP75 Дата: Среда, 16.11.2016, 10:16 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо добр человек. Поюзал примеры, действительно всё работает. Спасибо. Про округление учту - не знал. что бывает глючок в округлении, ранее такое не наблюдал вроде.
 
Ответить
СообщениеСпасибо добр человек. Поюзал примеры, действительно всё работает. Спасибо. Про округление учту - не знал. что бывает глючок в округлении, ранее такое не наблюдал вроде.

Автор - GP75
Дата добавления - 16.11.2016 в 10:16
_Boroda_ Дата: Среда, 16.11.2016, 10:20 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
не знал. что бывает глючок в округлении,
почитайте Майкрософта https://support.microsoft.com/ru-ru/kb/78113

ранее такое не наблюдал вроде
Посмотрите в файле
К сообщению приложен файл: 48167889.xls(26Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
не знал. что бывает глючок в округлении,
почитайте Майкрософта https://support.microsoft.com/ru-ru/kb/78113

ранее такое не наблюдал вроде
Посмотрите в файле

Автор - _Boroda_
Дата добавления - 16.11.2016 в 10:20
GP75 Дата: Среда, 16.11.2016, 10:37 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Ещё раз спасибо. Ранее несколько программок сделал для удобства в работе - сегодня займусь проверкой вычисления по малым значениям.
 
Ответить
СообщениеЕщё раз спасибо. Ранее несколько программок сделал для удобства в работе - сегодня займусь проверкой вычисления по малым значениям.

Автор - GP75
Дата добавления - 16.11.2016 в 10:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в массиве по искомым текстовому и цифровому значениям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!