Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Календарь из БД - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Календарь из БД (ак сделать так чтобы на листе "календарь" напротив каждого с)
Календарь из БД
gavrichi Дата: Четверг, 17.11.2016, 18:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Ребята, привет!
Нужна помощь - как сделать так чтобы на листе "календарь" напротив каждого события получалась единица. Чтобы в итоге получился тайминг, как диаграмма ганта, только с повторяющимися событиями. У меня получилось сделать для одной строки, но по вертикали не получается, как мне кажется тут должна быть какая-то другая формула с присвоением уникальной переменной для каждой строки...
Помогите плиз, может у кого-нить есть готовый вариант.
Заранее спасибо!
К сообщению приложен файл: 6247144.xlsx(13Kb)
 
Ответить
СообщениеРебята, привет!
Нужна помощь - как сделать так чтобы на листе "календарь" напротив каждого события получалась единица. Чтобы в итоге получился тайминг, как диаграмма ганта, только с повторяющимися событиями. У меня получилось сделать для одной строки, но по вертикали не получается, как мне кажется тут должна быть какая-то другая формула с присвоением уникальной переменной для каждой строки...
Помогите плиз, может у кого-нить есть готовый вариант.
Заранее спасибо!

Автор - gavrichi
Дата добавления - 17.11.2016 в 18:39
Karataev Дата: Четверг, 17.11.2016, 18:50 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Я не понял логики, поэтому может быть неправильно. Формула для "B2":
Код
=ЕСЛИ(СЧЁТЕСЛИМН(дата!$A:$A;$A2;дата!$B:$B;B$1);1;"")
К сообщению приложен файл: 7693033.xlsx(16Kb)


 
Ответить
СообщениеЯ не понял логики, поэтому может быть неправильно. Формула для "B2":
Код
=ЕСЛИ(СЧЁТЕСЛИМН(дата!$A:$A;$A2;дата!$B:$B;B$1);1;"")

Автор - Karataev
Дата добавления - 17.11.2016 в 18:50
gavrichi Дата: Четверг, 17.11.2016, 19:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Я не понял логики, поэтому может быть неправильно. Формула для "B2":

=ЕСЛИ(СЧЁТЕСЛИМН(дата!$A:$A;$A2;дата!$B:$B;B$1);1;"")


О Боги! Это то что нужно, спасибо огромное! Так просто оказалось hands
 
Ответить
Сообщение
Я не понял логики, поэтому может быть неправильно. Формула для "B2":

=ЕСЛИ(СЧЁТЕСЛИМН(дата!$A:$A;$A2;дата!$B:$B;B$1);1;"")


О Боги! Это то что нужно, спасибо огромное! Так просто оказалось hands

Автор - gavrichi
Дата добавления - 17.11.2016 в 19:28
Karataev Дата: Четверг, 17.11.2016, 19:36 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Можно упростить формулу, но для этого нужно отключить отображение нулей: Файл - Параметры - Дополнительно - Параметры отображения листа - снимите флажок "Показывать нули в ячейках, которые содержат нулевые значения".
Код
=СЧЁТЕСЛИМН(дата!$A:$A;$A2;дата!$B:$B;B$1)

PS. Не цитируйте полностью пост (об этом сказано в правилах форума), цитировать нужно фрагмент поста. Если хотите к кому-то обратиться, то просто пишите ник.




Сообщение отредактировал Karataev - Четверг, 17.11.2016, 19:38
 
Ответить
СообщениеМожно упростить формулу, но для этого нужно отключить отображение нулей: Файл - Параметры - Дополнительно - Параметры отображения листа - снимите флажок "Показывать нули в ячейках, которые содержат нулевые значения".
Код
=СЧЁТЕСЛИМН(дата!$A:$A;$A2;дата!$B:$B;B$1)

PS. Не цитируйте полностью пост (об этом сказано в правилах форума), цитировать нужно фрагмент поста. Если хотите к кому-то обратиться, то просто пишите ник.

Автор - Karataev
Дата добавления - 17.11.2016 в 19:36
gavrichi Дата: Пятница, 18.11.2016, 10:56 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо! :)
 
Ответить
СообщениеСпасибо! :)

Автор - gavrichi
Дата добавления - 18.11.2016 в 10:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Календарь из БД (ак сделать так чтобы на листе "календарь" напротив каждого с)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!