Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отбор артикулов по макрогрупам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отбор артикулов по макрогрупам (Формулы/Formulas)
Отбор артикулов по макрогрупам
axxy Дата: Четверг, 24.11.2016, 19:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго времени суток. Простите если подобный вопрос уже был, я его пока не нашел.
Суть проблемы заключается в том что: на почту приходит переоценка на товары отсортирована по возрастанию артикулов, но макрогрупы не сортированы.
Есть отобранные макрогрупы по отделам и типа печати ценника.
Нужно на 3 вкладку отсортировать артикула по отделам согласно макрогрупам.
Помогите пожалуйста
К сообщению приложен файл: 9659816.xlsx(98Kb)
 
Ответить
СообщениеДоброго времени суток. Простите если подобный вопрос уже был, я его пока не нашел.
Суть проблемы заключается в том что: на почту приходит переоценка на товары отсортирована по возрастанию артикулов, но макрогрупы не сортированы.
Есть отобранные макрогрупы по отделам и типа печати ценника.
Нужно на 3 вкладку отсортировать артикула по отделам согласно макрогрупам.
Помогите пожалуйста

Автор - axxy
Дата добавления - 24.11.2016 в 19:15
AVI Дата: Четверг, 24.11.2016, 19:25 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
Так?
Код
=ИНДЕКС(макро!$A$5:$A$18;ПОИСКПОЗ(результат!A1;макро!$C$5:$C$18;))
К сообщению приложен файл: 3873257.xlsx(99Kb)


Сообщение отредактировал AVI - Четверг, 24.11.2016, 19:26
 
Ответить
СообщениеТак?
Код
=ИНДЕКС(макро!$A$5:$A$18;ПОИСКПОЗ(результат!A1;макро!$C$5:$C$18;))

Автор - AVI
Дата добавления - 24.11.2016 в 19:25
axxy Дата: Четверг, 24.11.2016, 20:22 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Нет. Смотрите в 2-м листе есть макрогрупы которые относятся к определенным отделам. На 1 листе есть артикула, название, макрогрупы и т.д..
Нужно на 3 лист под каждый отдел отобрать артикула согласно макрогруп.
То бишь к отделу бакалея относиться макрогрупы 2,3,9,22,76,94,106. Нужно по этим данным исходя из переоценки с 1-го лист (почта) отобрать артикула которые относятся к этой макрогрупе и перенести на 3-й лист (результат) к соответствующему отделу.
 
Ответить
СообщениеНет. Смотрите в 2-м листе есть макрогрупы которые относятся к определенным отделам. На 1 листе есть артикула, название, макрогрупы и т.д..
Нужно на 3 лист под каждый отдел отобрать артикула согласно макрогруп.
То бишь к отделу бакалея относиться макрогрупы 2,3,9,22,76,94,106. Нужно по этим данным исходя из переоценки с 1-го лист (почта) отобрать артикула которые относятся к этой макрогрупе и перенести на 3-й лист (результат) к соответствующему отделу.

Автор - axxy
Дата добавления - 24.11.2016 в 20:22
gling Дата: Четверг, 24.11.2016, 20:29 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Еще вариант. Тормозит правда из - за СУММПРОИЗВ. И проверить нужно, правильно ли выводит. На листе Макро названия отделов привел в соответствии с листом Результат. Группа 76 в трех отделах, поэтому может считать не правильно.
К сообщению приложен файл: 4136394.xlsx(31Kb)


Сообщение отредактировал gling - Четверг, 24.11.2016, 20:29
 
Ответить
СообщениеЕще вариант. Тормозит правда из - за СУММПРОИЗВ. И проверить нужно, правильно ли выводит. На листе Макро названия отделов привел в соответствии с листом Результат. Группа 76 в трех отделах, поэтому может считать не правильно.

Автор - gling
Дата добавления - 24.11.2016 в 20:29
axxy Дата: Четверг, 24.11.2016, 20:34 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling,
Да похоже на то. Спасибо большое.
Завтра проверю


Сообщение отредактировал axxy - Четверг, 24.11.2016, 20:36
 
Ответить
Сообщениеgling,
Да похоже на то. Спасибо большое.
Завтра проверю

Автор - axxy
Дата добавления - 24.11.2016 в 20:34
Nic70y Дата: Четверг, 24.11.2016, 20:51 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
№83 в листе макро не обнаружен.
К сообщению приложен файл: 5890079.xlsx(67Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 24.11.2016, 21:05
 
Ответить
Сообщение№83 в листе макро не обнаружен.

Автор - Nic70y
Дата добавления - 24.11.2016 в 20:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отбор артикулов по макрогрупам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!