Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция ВПР в объединенных ячейках не находит данные. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР в объединенных ячейках не находит данные. (Формулы/Formulas)
Функция ВПР в объединенных ячейках не находит данные.
olegus Дата: Четверг, 01.12.2016, 12:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, форумчане!
Прошу помощи. Не могу понять в чем дело, но ВПР в ячейках A6 и B6 листа "Новый_механизм" почему-то не отображает данные.
Файл с примером прилагаю. В оригинале лист "Данные" заполняется через ссылки из других книг.
Заранее спасибо!
К сообщению приложен файл: 5865543.xlsx(13Kb)
 
Ответить
СообщениеДобрый день, форумчане!
Прошу помощи. Не могу понять в чем дело, но ВПР в ячейках A6 и B6 листа "Новый_механизм" почему-то не отображает данные.
Файл с примером прилагаю. В оригинале лист "Данные" заполняется через ссылки из других книг.
Заранее спасибо!

Автор - olegus
Дата добавления - 01.12.2016 в 12:26
buchlotnik Дата: Четверг, 01.12.2016, 12:45 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Здравствуйте.

Объединённые ячейки, конечно, зло, но они не виноваты - ВПР ищет только по ПЕРВОМУ столбцу, отсюда и косяк. Попробуйте
Код
=ИНДЕКС(данные!$A$5:$A$10;ПОИСКПОЗ(B6;данные!$B$5:$B$10;0))
К сообщению приложен файл: _5865543.xlsx(14Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеЗдравствуйте.

Объединённые ячейки, конечно, зло, но они не виноваты - ВПР ищет только по ПЕРВОМУ столбцу, отсюда и косяк. Попробуйте
Код
=ИНДЕКС(данные!$A$5:$A$10;ПОИСКПОЗ(B6;данные!$B$5:$B$10;0))

Автор - buchlotnik
Дата добавления - 01.12.2016 в 12:45
krosav4ig Дата: Четверг, 01.12.2016, 12:48 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1336
Репутация: 533 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте
Для A6 формула
Код
=ВПР(C6;ЕСЛИ({1;0};данные!$C$5:$C$10;данные!$A$5:$A$10);2;)
К сообщению приложен файл: 5865543-1.xlsx(14Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Четверг, 01.12.2016, 12:49
 
Ответить
СообщениеЗдравствуйте
Для A6 формула
Код
=ВПР(C6;ЕСЛИ({1;0};данные!$C$5:$C$10;данные!$A$5:$A$10);2;)

Автор - krosav4ig
Дата добавления - 01.12.2016 в 12:48
olegus Дата: Четверг, 01.12.2016, 13:02 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik и krosav4iq большое спасибо.
 
Ответить
Сообщениеbuchlotnik и krosav4iq большое спасибо.

Автор - olegus
Дата добавления - 01.12.2016 в 13:02
olegus Дата: Четверг, 01.12.2016, 16:35 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik не могу понять. Я копирую и вставляю формулы в другие объединенные ячейки по столбцам и она ничего не находит. и можно ли выложить формулу для столбца D?
 
Ответить
Сообщениеbuchlotnik не могу понять. Я копирую и вставляю формулы в другие объединенные ячейки по столбцам и она ничего не находит. и можно ли выложить формулу для столбца D?

Автор - olegus
Дата добавления - 01.12.2016 в 16:35
krosav4ig Дата: Четверг, 01.12.2016, 16:44 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1336
Репутация: 533 ±
Замечаний: 0% ±

Excel 2007, 2013
можно ли выложить формулу для столбца D

я же ужо прописал формулу в файле
К сообщению приложен файл: 5865543-1.xlsx(14Kb)

[vba]
Код
=ВПР(C6;данные!$C$5:$D$10;2;)
[/vba]


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Четверг, 01.12.2016, 16:45
 
Ответить
Сообщение
можно ли выложить формулу для столбца D

я же ужо прописал формулу в файле
К сообщению приложен файл: 5865543-1.xlsx(14Kb)

[vba]
Код
=ВПР(C6;данные!$C$5:$D$10;2;)
[/vba]

Автор - krosav4ig
Дата добавления - 01.12.2016 в 16:44
olegus Дата: Четверг, 01.12.2016, 16:48 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
С формулой для столбца D разобрался. Возник вопрос. В некоторых объединенных ячейках не находит данные (Книга 1). В источнике данных (книга 2) стоит общий формат. Когда я в книге 2 просто перенабираю руками в ячейке № лицевого счета данные в книге 1 подставляются. Данные для книги 2 берутся из программы. И менять руками каждый раз не вариант. Как это можно вылечить?
 
Ответить
СообщениеС формулой для столбца D разобрался. Возник вопрос. В некоторых объединенных ячейках не находит данные (Книга 1). В источнике данных (книга 2) стоит общий формат. Когда я в книге 2 просто перенабираю руками в ячейке № лицевого счета данные в книге 1 подставляются. Данные для книги 2 берутся из программы. И менять руками каждый раз не вариант. Как это можно вылечить?

Автор - olegus
Дата добавления - 01.12.2016 в 16:48
buchlotnik Дата: Четверг, 01.12.2016, 16:48 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Я копирую и вставляю формулы в другие объединенные ячейки
покажите в файле
Цитата
можно ли выложить формулу для столбца D?
дык по аналогии
Код
=ИНДЕКС(данные!$D$5:$D$10;ПОИСКПОЗ(C6;данные!$C$5:$C$10;0))
К сообщению приложен файл: 0648015.xlsx(14Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Я копирую и вставляю формулы в другие объединенные ячейки
покажите в файле
Цитата
можно ли выложить формулу для столбца D?
дык по аналогии
Код
=ИНДЕКС(данные!$D$5:$D$10;ПОИСКПОЗ(C6;данные!$C$5:$C$10;0))

Автор - buchlotnik
Дата добавления - 01.12.2016 в 16:48
olegus Дата: Четверг, 01.12.2016, 17:03 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
покажите в файле

оригинальный файл ДСП и выложить я его не могу
 
Ответить
Сообщение
покажите в файле

оригинальный файл ДСП и выложить я его не могу

Автор - olegus
Дата добавления - 01.12.2016 в 17:03
buchlotnik Дата: Четверг, 01.12.2016, 17:10 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
выложить я его не могу
тогда попробуем потелепатить:
Цитата
просто перенабираю руками
а в столбце с номерами пробелы лишние случаем не затесались?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
выложить я его не могу
тогда попробуем потелепатить:
Цитата
просто перенабираю руками
а в столбце с номерами пробелы лишние случаем не затесались?

Автор - buchlotnik
Дата добавления - 01.12.2016 в 17:10
olegus Дата: Пятница, 02.12.2016, 08:16 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Нет. проверил ДЛСТР. количество знаков совпадает.
 
Ответить
СообщениеНет. проверил ДЛСТР. количество знаков совпадает.

Автор - olegus
Дата добавления - 02.12.2016 в 08:16
olegus Дата: Пятница, 02.12.2016, 08:23 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Похоже программа выводит данные в таблице доноре в текстовом формате. Есть ли вариант без макроса в таблице рецепиенте через ссылку на ячейку вставлять данные в числовом формате?
 
Ответить
СообщениеПохоже программа выводит данные в таблице доноре в текстовом формате. Есть ли вариант без макроса в таблице рецепиенте через ссылку на ячейку вставлять данные в числовом формате?

Автор - olegus
Дата добавления - 02.12.2016 в 08:23
olegus Дата: Пятница, 02.12.2016, 08:30 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Через ЗНАЧЕН и ссылку преобразовал в число.
buchlotnik спасибо.
 
Ответить
СообщениеЧерез ЗНАЧЕН и ссылку преобразовал в число.
buchlotnik спасибо.

Автор - olegus
Дата добавления - 02.12.2016 в 08:30
_Boroda_ Дата: Пятница, 02.12.2016, 15:55 | Сообщение № 14
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Через ЗНАЧЕН и ссылку преобразовал в число.

Можно просто два минуса поставить если текст ищем в числах
Код
=ИНДЕКС(данные!A$5:A$99;ПОИСКПОЗ(--$C6;данные!$C$5:$C$99;))

или наоборот, две кавычки прилепить, если число ищем в текстах
Код
=ИНДЕКС(данные!A$5:A$99;ПОИСКПОЗ($C6&"";данные!$C$5:$C$99;))
К сообщению приложен файл: 5865543_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Через ЗНАЧЕН и ссылку преобразовал в число.

Можно просто два минуса поставить если текст ищем в числах
Код
=ИНДЕКС(данные!A$5:A$99;ПОИСКПОЗ(--$C6;данные!$C$5:$C$99;))

или наоборот, две кавычки прилепить, если число ищем в текстах
Код
=ИНДЕКС(данные!A$5:A$99;ПОИСКПОЗ($C6&"";данные!$C$5:$C$99;))

Автор - _Boroda_
Дата добавления - 02.12.2016 в 15:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР в объединенных ячейках не находит данные. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!