Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет баллов по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет баллов по условию (Формулы/Formulas)
Подсчет баллов по условию
ASM_0408 Дата: Четверг, 01.12.2016, 14:21 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 0 ±
Замечаний: 20% ±

2016
Добрый день! Уважаемые форумчане, подскажите пожалуйста решение какую формулу использовать для подсчета баллов в ячейке DX4 по условию что в ячейках по строке 4 после ячеек с номером вопроса стоит какой-либо символ, производилось суммирование в соответствии с таблицей расположенной на листе2. Пример: если в ячейке Z4 находится какой либо символ, то в ячейку DX4 прибавляется число с Лист2 из ячейки E2. И так далее по всем 18 ячейкам. Благодарю за помощь.
К сообщению приложен файл: 7583720.xlsx(12Kb)
 
Ответить
СообщениеДобрый день! Уважаемые форумчане, подскажите пожалуйста решение какую формулу использовать для подсчета баллов в ячейке DX4 по условию что в ячейках по строке 4 после ячеек с номером вопроса стоит какой-либо символ, производилось суммирование в соответствии с таблицей расположенной на листе2. Пример: если в ячейке Z4 находится какой либо символ, то в ячейку DX4 прибавляется число с Лист2 из ячейки E2. И так далее по всем 18 ячейкам. Благодарю за помощь.

Автор - ASM_0408
Дата добавления - 01.12.2016 в 14:21
Nic70y Дата: Четверг, 01.12.2016, 14:45 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ОСТАТ(СТОЛБЕЦ(A1);6)=4;ЕСЛИОШИБКА(--(ВПР(T4;Лист2!$A$2:$E$19;5;)&"");"");ОКРУГЛВВЕРХ(СТОЛБЕЦ(A1)/6;))
исправил, пропустил ()
К сообщению приложен файл: 1414627.xlsx(13Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 01.12.2016, 14:49
 
Ответить
Сообщение
Код
=ЕСЛИ(ОСТАТ(СТОЛБЕЦ(A1);6)=4;ЕСЛИОШИБКА(--(ВПР(T4;Лист2!$A$2:$E$19;5;)&"");"");ОКРУГЛВВЕРХ(СТОЛБЕЦ(A1)/6;))
исправил, пропустил ()

Автор - Nic70y
Дата добавления - 01.12.2016 в 14:45
ASM_0408 Дата: Четверг, 01.12.2016, 15:05 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 0 ±
Замечаний: 20% ±

2016
Nic70y, Видимо я не понятно объяснил. Сейчас попробую по другому: если в ячейке Z4 ставим "+" (ну или любой другой символ), то в ячейке ЕА 4 появляется число 3 из ячейки Е2 Лист2. Ячейки из строки с цифрами обозначают номер вопроса с Лист2. Вот и по количеству заполненных ячеек после ячеек с номером вопроса в строке 4 необходимо сложить баллы с Лист2 из столбца Е с соответствующим номером вопроса.
 
Ответить
СообщениеNic70y, Видимо я не понятно объяснил. Сейчас попробую по другому: если в ячейке Z4 ставим "+" (ну или любой другой символ), то в ячейке ЕА 4 появляется число 3 из ячейки Е2 Лист2. Ячейки из строки с цифрами обозначают номер вопроса с Лист2. Вот и по количеству заполненных ячеек после ячеек с номером вопроса в строке 4 необходимо сложить баллы с Лист2 из столбца Е с соответствующим номером вопроса.

Автор - ASM_0408
Дата добавления - 01.12.2016 в 15:05
krosav4ig Дата: Четверг, 01.12.2016, 15:13 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
а я так понял (формула массива)
Код
=СУММ((Лист2!A2:A19=ЕСЛИ((ДЛСТР(Z4:DZ4)>0)*(ОСТАТ(СТОЛБЕЦ(F4:DF4);6)=0);W4:DW4))*Лист2!E2:E19)
К сообщению приложен файл: 7583720-1.xlsx(13Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Четверг, 01.12.2016, 15:13
 
Ответить
Сообщениеа я так понял (формула массива)
Код
=СУММ((Лист2!A2:A19=ЕСЛИ((ДЛСТР(Z4:DZ4)>0)*(ОСТАТ(СТОЛБЕЦ(F4:DF4);6)=0);W4:DW4))*Лист2!E2:E19)

Автор - krosav4ig
Дата добавления - 01.12.2016 в 15:13
AlexM Дата: Четверг, 01.12.2016, 15:21 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Ну и как я понял
Код
=ЕСЛИ(ИНДЕКС(4:4;20+СТОЛБЕЦ(A1)*6)="+";ВПР(ИНДЕКС(4:4;17+СТОЛБЕЦ(A1)*6);Лист2!$A$2:$E$19;5;);0)
К сообщению приложен файл: 7583720.xls(36Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНу и как я понял
Код
=ЕСЛИ(ИНДЕКС(4:4;20+СТОЛБЕЦ(A1)*6)="+";ВПР(ИНДЕКС(4:4;17+СТОЛБЕЦ(A1)*6);Лист2!$A$2:$E$19;5;);0)

Автор - AlexM
Дата добавления - 01.12.2016 в 15:21
ASM_0408 Дата: Четверг, 01.12.2016, 15:38 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 0 ±
Замечаний: 20% ±

2016
Ну и как я понял

Это самый горячий вариант. Можно ли знак плюс заменить обозначением любого символа если в эксэль такое возможно, и заключить результат вычислений в ячейку ЕА4 хотя это возможно решить скрытием столбцов и копированием результата в ячеку ЕА4.
 
Ответить
Сообщение
Ну и как я понял

Это самый горячий вариант. Можно ли знак плюс заменить обозначением любого символа если в эксэль такое возможно, и заключить результат вычислений в ячейку ЕА4 хотя это возможно решить скрытием столбцов и копированием результата в ячеку ЕА4.

Автор - ASM_0408
Дата добавления - 01.12.2016 в 15:38
AlexM Дата: Четверг, 01.12.2016, 16:56 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Можно ли знак плюс заменить обозначением любого символа
Замените в формуле ="+" на <>""
К сообщению приложен файл: 7583720_01.xls(36Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 01.12.2016, 17:00
 
Ответить
Сообщение
Можно ли знак плюс заменить обозначением любого символа
Замените в формуле ="+" на <>""

Автор - AlexM
Дата добавления - 01.12.2016 в 16:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет баллов по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!