Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Получить данные из нескольких файлов по критеририям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить данные из нескольких файлов по критеририям (Формулы/Formulas)
Получить данные из нескольких файлов по критеририям
svetonosniy Дата: Пятница, 02.12.2016, 08:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Доброго времени суток! Несколько дней искал ответ на свой вопрос, мучал справочнике, но результат не радует. Задача следующая: есть несколько файлов с отчетами, каждый месяц файл с отчетом создается новый, а старый кладется в папочку "Архив". Нужно создать такую формулу (скорее даже совокупность формул), которая будет искать необходимые данные в необходимых файлах по определенным критериям. А именно: найти все строки, в которых ячейка совпадает с искомым значением, при том в этих строках должен стоять знак "+" (работа выполнена) в одной ячейке, и определенный знак в соседней (индикатор типа работы). Сложно объяснить, поэтому не ругайте меня, если что то непонятно. Прикрепляю файл - первый лист это пример отчета, второй лист это то, что требуется получить. Поиск происходит по отчетам из нескольких файлов сотрудников. Вроде как то так, надеюсь на вашу помощь
К сообщению приложен файл: 8595887.xls(19Kb)
 
Ответить
СообщениеДоброго времени суток! Несколько дней искал ответ на свой вопрос, мучал справочнике, но результат не радует. Задача следующая: есть несколько файлов с отчетами, каждый месяц файл с отчетом создается новый, а старый кладется в папочку "Архив". Нужно создать такую формулу (скорее даже совокупность формул), которая будет искать необходимые данные в необходимых файлах по определенным критериям. А именно: найти все строки, в которых ячейка совпадает с искомым значением, при том в этих строках должен стоять знак "+" (работа выполнена) в одной ячейке, и определенный знак в соседней (индикатор типа работы). Сложно объяснить, поэтому не ругайте меня, если что то непонятно. Прикрепляю файл - первый лист это пример отчета, второй лист это то, что требуется получить. Поиск происходит по отчетам из нескольких файлов сотрудников. Вроде как то так, надеюсь на вашу помощь

Автор - svetonosniy
Дата добавления - 02.12.2016 в 08:54
svetonosniy Дата: Понедельник, 05.12.2016, 09:56 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Нашел вот такую формулу на просторах Интернета
=ИНДЕКС($B$2:$B$16;НАИМЕНЬШИЙ(ЕСЛИ($E$2=A2:A16;СТРОКА(B2:B16)-1;"");СТРОКА()-5))
ссылки на ячейки из примера, прикрепленного к сообщению)
но с ней сложно работать, так как она выбирает значения по одному критерию, доработать не удается, ошибки, ошибки...
Файл с примером создан не мной
Народ, есть идеи как все таки решить мою проблему?
К сообщению приложен файл: bd67bcbfc335060.xls(24Kb)
 
Ответить
СообщениеНашел вот такую формулу на просторах Интернета
=ИНДЕКС($B$2:$B$16;НАИМЕНЬШИЙ(ЕСЛИ($E$2=A2:A16;СТРОКА(B2:B16)-1;"");СТРОКА()-5))
ссылки на ячейки из примера, прикрепленного к сообщению)
но с ней сложно работать, так как она выбирает значения по одному критерию, доработать не удается, ошибки, ошибки...
Файл с примером создан не мной
Народ, есть идеи как все таки решить мою проблему?

Автор - svetonosniy
Дата добавления - 05.12.2016 в 09:56
китин Дата: Понедельник, 05.12.2016, 10:52 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
смотрите Так? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"));СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0));"")
К сообщению приложен файл: 5662918.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениесмотрите Так? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"));СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0));"")

Автор - китин
Дата добавления - 05.12.2016 в 10:52
svetonosniy Дата: Понедельник, 05.12.2016, 11:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
смотрите Так? формула массива

вообще что то похожее, но в 2003 ошибка #ИМЯ?
 
Ответить
Сообщение
смотрите Так? формула массива

вообще что то похожее, но в 2003 ошибка #ИМЯ?

Автор - svetonosniy
Дата добавления - 05.12.2016 в 11:23
китин Дата: Понедельник, 05.12.2016, 11:27 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
для 2003 чуть подлиннее тогда
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"));СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0)));"";ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"));СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0)))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениедля 2003 чуть подлиннее тогда
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"));СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0)));"";ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"));СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0)))

Автор - китин
Дата добавления - 05.12.2016 в 11:27
svetonosniy Дата: Понедельник, 05.12.2016, 13:01 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
для 2003 чуть подлиннее тогда

да, вот так действительно работает, все отлично, но могли бы пояснить как это работает?))) ссылки на ячейку с доменом в формуле нет, и при смене домена в ячейке ничего не происходит, отображаются данные только по домену site.ru
 
Ответить
Сообщение
для 2003 чуть подлиннее тогда

да, вот так действительно работает, все отлично, но могли бы пояснить как это работает?))) ссылки на ячейку с доменом в формуле нет, и при смене домена в ячейке ничего не происходит, отображаются данные только по домену site.ru

Автор - svetonosniy
Дата добавления - 05.12.2016 в 13:01
китин Дата: Понедельник, 05.12.2016, 13:14 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну тада исчо длиннее
Код
=ЕСЛИ(ЕОШИБКА((ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"))*($B$1=Отчет!$B$2:$B$8);СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0))));"";ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"))*($B$1=Отчет!$B$2:$B$8);СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0)))
К сообщению приложен файл: 111111_222.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену тада исчо длиннее
Код
=ЕСЛИ(ЕОШИБКА((ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"))*($B$1=Отчет!$B$2:$B$8);СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0))));"";ИНДЕКС(Отчет!$A$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ(((Отчет!$A$2:$A$8="+")+(Отчет!$A$2:$A$8="~"))*($B$1=Отчет!$B$2:$B$8);СТРОКА(Отчет!$A$2:$A$8)-1);СТРОКА(A1));ПОИСКПОЗ(A$6;Отчет!$A$1:$F$1;0)))

Автор - китин
Дата добавления - 05.12.2016 в 13:14
svetonosniy Дата: Понедельник, 05.12.2016, 14:20 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
спасибо, вроде получается, сцеплять файлы только проблемно...
 
Ответить
Сообщениеспасибо, вроде получается, сцеплять файлы только проблемно...

Автор - svetonosniy
Дата добавления - 05.12.2016 в 14:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить данные из нескольких файлов по критеририям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!