Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/создание списка по критерию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создание списка по критерию (Формулы/Formulas)
создание списка по критерию
zaak88 Дата: Пятница, 03.02.2017, 09:20 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Коллеги, прошу помочь вывести список брендов исходя из принадлежности к компании. Спасибо! То что требуется на листе 2 выделил жёлтым, исходные данные оранжевым на листе 1.
К сообщению приложен файл: 6670648.xlsx(9.3 Kb)
 
Ответить
СообщениеКоллеги, прошу помочь вывести список брендов исходя из принадлежности к компании. Спасибо! То что требуется на листе 2 выделил жёлтым, исходные данные оранжевым на листе 1.

Автор - zaak88
Дата добавления - 03.02.2017 в 09:20
AlexM Дата: Пятница, 03.02.2017, 09:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2003
Формула массива
Код
=ИНДЕКС(Лист1!F$2:F$98;НАИМЕНЬШИЙ(ЕСЛИ((Лист1!E$2:E$98=A2)*(Лист1!F$2:F$98<>Лист1!F$3:F$99);СТРОКА(E$1:E$97));СЧЁТЕСЛИ(A$2:A2;A2)))
Чтобы скрыть ошибку используйте функцию ЕСЛИОШИБКА()
К сообщению приложен файл: 6670648_01.xlsx(9.8 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 03.02.2017, 09:45
 
Ответить
СообщениеФормула массива
Код
=ИНДЕКС(Лист1!F$2:F$98;НАИМЕНЬШИЙ(ЕСЛИ((Лист1!E$2:E$98=A2)*(Лист1!F$2:F$98<>Лист1!F$3:F$99);СТРОКА(E$1:E$97));СЧЁТЕСЛИ(A$2:A2;A2)))
Чтобы скрыть ошибку используйте функцию ЕСЛИОШИБКА()

Автор - AlexM
Дата добавления - 03.02.2017 в 09:44
zaak88 Дата: Пятница, 03.02.2017, 09:52 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
AlexM, спасибо огромное!
 
Ответить
СообщениеAlexM, спасибо огромное!

Автор - zaak88
Дата добавления - 03.02.2017 в 09:52
jakim Дата: Пятница, 03.02.2017, 13:56 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1125
Репутация: 298 ±
Замечаний: 0% ±

Excel 2010
Для Вас подойдёт вариант формулы без массивного ввода

Код
=IFERROR(INDEX(Лист1!F$2:F$250;AGGREGATE(15;6;ROW($1:$25)/(Лист1!E$2:E$250=A2)/(COUNTIF(B$1:B1;Лист1!F$2:F$25)=0);1));"")
К сообщению приложен файл: 2456227.xlsx(10.3 Kb)
 
Ответить
Сообщение
Для Вас подойдёт вариант формулы без массивного ввода

Код
=IFERROR(INDEX(Лист1!F$2:F$250;AGGREGATE(15;6;ROW($1:$25)/(Лист1!E$2:E$250=A2)/(COUNTIF(B$1:B1;Лист1!F$2:F$25)=0);1));"")

Автор - jakim
Дата добавления - 03.02.2017 в 13:56
Fire13man Дата: Четверг, 05.03.2020, 12:52 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Нужна помощь, есть таблица с данными, необходимо сформировать на новом листе список по исполнителю, пример во вложении. Зеленым цветом отмечены исходные данные, желтым переменная, синим результат. Пробовал через ВПР и ИНДЕКС, ПОИСКПОЗ не вышло, выводит только первое значение из списка.
К сообщению приложен файл: 1992304.xlsx(13.0 Kb)
 
Ответить
СообщениеДобрый день!
Нужна помощь, есть таблица с данными, необходимо сформировать на новом листе список по исполнителю, пример во вложении. Зеленым цветом отмечены исходные данные, желтым переменная, синим результат. Пробовал через ВПР и ИНДЕКС, ПОИСКПОЗ не вышло, выводит только первое значение из списка.

Автор - Fire13man
Дата добавления - 05.03.2020 в 12:52
Pelena Дата: Четверг, 05.03.2020, 13:08 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 18605
Репутация: 4216 ±
Замечаний: ±

Excel 2016 & Mac Excel
Fire13man, Ваш вопрос не относится к данной теме, задача совершенно другая.
Прочитайте Правила форума и создайте свою тему


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеFire13man, Ваш вопрос не относится к данной теме, задача совершенно другая.
Прочитайте Правила форума и создайте свою тему

Автор - Pelena
Дата добавления - 05.03.2020 в 13:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » создание списка по критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!