Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сделать отдельную кнопку для сортировки разных столбцов - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 2 из 2«12
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сделать отдельную кнопку для сортировки разных столбцов (Формулы/Formulas)
сделать отдельную кнопку для сортировки разных столбцов
maslenkin Дата: Вторник, 21.02.2017, 23:34 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Wasilich, вот моя книга, и попытка внедрить ваш макрос :(
К сообщению приложен файл: _new.xlsm(87Kb)
 
Ответить
СообщениеWasilich, вот моя книга, и попытка внедрить ваш макрос :(

Автор - maslenkin
Дата добавления - 21.02.2017 в 23:34
Wasilich Дата: Среда, 22.02.2017, 13:41 | Сообщение № 22
Группа: Друзья
Ранг: Старожил
Сообщений: 1195
Репутация: 316 ±
Замечаний: 0% ±

2003
вот моя книга
Смотрите.
К сообщению приложен файл: 5089114.rar(33Kb)
 
Ответить
Сообщение
вот моя книга
Смотрите.

Автор - Wasilich
Дата добавления - 22.02.2017 в 13:41
maslenkin Дата: Суббота, 25.02.2017, 00:06 | Сообщение № 23
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Смотрите.

не могу разобраться, почему столбец G с данными участника оказывает влияние на сортировку, а именно не участвует в ней 6-я строка. Как только в G пусто - то нормально. Вношу личные данные - не сортирует с учетом строки 6.
В вашем примере вы писали про исправленную формулу, если правильно понял, это в столбце М. Там при вводе от 59.1 до 59.9 выскакивает н/д - поэтому и сделал ее такую,
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(L6;ОСН!$D$1:$D$100;-1);ПОИСКПОЗ("0:"&L6;ОСН!$D$1:$D$100;-1))

а не более правильную как в вашем варианте
Код
=ЕСЛИ(L6=0;0;ПОИСКПОЗ(L6;ОСН_М3!$C$1:$C$100;-1))
К сообщению приложен файл: 2899051.xlsm(73Kb)


Сообщение отредактировал maslenkin - Суббота, 25.02.2017, 00:11
 
Ответить
Сообщение
Смотрите.

не могу разобраться, почему столбец G с данными участника оказывает влияние на сортировку, а именно не участвует в ней 6-я строка. Как только в G пусто - то нормально. Вношу личные данные - не сортирует с учетом строки 6.
В вашем примере вы писали про исправленную формулу, если правильно понял, это в столбце М. Там при вводе от 59.1 до 59.9 выскакивает н/д - поэтому и сделал ее такую,
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(L6;ОСН!$D$1:$D$100;-1);ПОИСКПОЗ("0:"&L6;ОСН!$D$1:$D$100;-1))

а не более правильную как в вашем варианте
Код
=ЕСЛИ(L6=0;0;ПОИСКПОЗ(L6;ОСН_М3!$C$1:$C$100;-1))

Автор - maslenkin
Дата добавления - 25.02.2017 в 00:06
maslenkin Дата: Вторник, 28.02.2017, 11:34 | Сообщение № 24
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Wasilich, уважаемый профи, не могли бы вы посмотреть мой последний файл 2899051.xlsm, с вашим макросом - совсем не понять, почему данные из столбца G и H влияют на строку 6 сортировки. Как только удаляю в одном из этих столбцов данные, то 6-я строка начинает участвовать в сортировке ВИД.
Спасибо.
З/Ы вопрос снят Header:=xlNo, _


Сообщение отредактировал maslenkin - Вторник, 28.02.2017, 12:01
 
Ответить
СообщениеWasilich, уважаемый профи, не могли бы вы посмотреть мой последний файл 2899051.xlsm, с вашим макросом - совсем не понять, почему данные из столбца G и H влияют на строку 6 сортировки. Как только удаляю в одном из этих столбцов данные, то 6-я строка начинает участвовать в сортировке ВИД.
Спасибо.
З/Ы вопрос снят Header:=xlNo, _

Автор - maslenkin
Дата добавления - 28.02.2017 в 11:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сделать отдельную кнопку для сортировки разных столбцов (Формулы/Formulas)
Страница 2 из 2«12
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!