Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как отсортировать по дате автоматически? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как отсортировать по дате автоматически? (Формулы/Formulas)
Как отсортировать по дате автоматически?
Nik57 Дата: Четверг, 27.04.2017, 21:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, подскажите, как отсортировать диапазон, чтоб он обновлялся автоматически?
Есть диапазон А1:В20. Как в виде формул прописать точно такой же диапазон, к примеру, Е1:F20, по дате и во времени (если дата повторяется) в порядке от более раннего к более позднему поступлению товара? Так как таблица будет большая и она будет периодически меняться, необходимо чтоб этот диапазон обновлялся в автоматическом режиме, при изменении начального диапазона А1:В20??
К сообщению приложен файл: 5674952.xlsx(10Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите, как отсортировать диапазон, чтоб он обновлялся автоматически?
Есть диапазон А1:В20. Как в виде формул прописать точно такой же диапазон, к примеру, Е1:F20, по дате и во времени (если дата повторяется) в порядке от более раннего к более позднему поступлению товара? Так как таблица будет большая и она будет периодически меняться, необходимо чтоб этот диапазон обновлялся в автоматическом режиме, при изменении начального диапазона А1:В20??

Автор - Nik57
Дата добавления - 27.04.2017 в 21:45
sboy Дата: Четверг, 27.04.2017, 22:32 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 997
Репутация: 253 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Так как у Вас дата и время прописаны не в каждой строке(либо время, либо дата), то с помощью доп.столбца. Если привести дату/время в единый формат - будет проще.
на примере данных, такой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$C$20;ПОИСКПОЗ(НАИМЕНЬШИЙ($C$1:$C$20;СТРОКА());$C$1:$C$20;);СТОЛБЕЦ($C$1)-СТОЛБЕЦ(A1));"")

в столбце С доп.расчет
К сообщению приложен файл: 5593218.xlsx(12Kb)
 
Ответить
СообщениеДобрый день.
Так как у Вас дата и время прописаны не в каждой строке(либо время, либо дата), то с помощью доп.столбца. Если привести дату/время в единый формат - будет проще.
на примере данных, такой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$C$20;ПОИСКПОЗ(НАИМЕНЬШИЙ($C$1:$C$20;СТРОКА());$C$1:$C$20;);СТОЛБЕЦ($C$1)-СТОЛБЕЦ(A1));"")

в столбце С доп.расчет

Автор - sboy
Дата добавления - 27.04.2017 в 22:32
Nik57 Дата: Четверг, 27.04.2017, 22:41 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, в том все и дело. что в одной партии поставки приходит по 2 разных товара. возможно как то можно объединить дату и время в одну ячейку, но как я не знаю. Ваш вариант не очень подходит
 
Ответить
Сообщениеsboy, в том все и дело. что в одной партии поставки приходит по 2 разных товара. возможно как то можно объединить дату и время в одну ячейку, но как я не знаю. Ваш вариант не очень подходит

Автор - Nik57
Дата добавления - 27.04.2017 в 22:41
Nic70y Дата: Четверг, 27.04.2017, 22:47 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4113
Репутация: 879 ±
Замечаний: 0% ±

Excel 2013
формула массива, протягивать сразу две ячейки E2:E3
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A2);2);НАИМЕНЬШИЙ(A$1:A$20;СЧЁТЕСЛИ(A$1:A$20;"<1")+СТРОКА(A3)/2);НАИМЕНЬШИЙ(ЕСЛИ(A$1:A$19=E1;A$2:A$20);СЧЁТЕСЛИ(E$1:E1;E1)))

пожалуй с доп.столбцом лучше (файл 89...)
К сообщению приложен файл: 4451512.xlsx(12Kb) · 8982388.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 27.04.2017, 23:11
 
Ответить
Сообщениеформула массива, протягивать сразу две ячейки E2:E3
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A2);2);НАИМЕНЬШИЙ(A$1:A$20;СЧЁТЕСЛИ(A$1:A$20;"<1")+СТРОКА(A3)/2);НАИМЕНЬШИЙ(ЕСЛИ(A$1:A$19=E1;A$2:A$20);СЧЁТЕСЛИ(E$1:E1;E1)))

пожалуй с доп.столбцом лучше (файл 89...)

Автор - Nic70y
Дата добавления - 27.04.2017 в 22:47
Pelena Дата: Пятница, 28.04.2017, 08:37 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11597
Репутация: 2572 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Почему в названии темы написано про ФОРМАТИРОВАНИЕ по дате? Может, всё же СОРТИРОВКА? Или я чего-то не уловила?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПочему в названии темы написано про ФОРМАТИРОВАНИЕ по дате? Может, всё же СОРТИРОВКА? Или я чего-то не уловила?

Автор - Pelena
Дата добавления - 28.04.2017 в 08:37
Nik57 Дата: Вторник, 02.05.2017, 17:48 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, спасибо!
А как быть если в некоторых ячейках повторяются события по времени и дате, тогда просто дублируются позиции?
Зеленым выделены ячейки, должны быть позиции 9,10 и 11,12. А появляется 9,10 и 9,10
К сообщению приложен файл: 4513702.xlsx(12Kb)


Сообщение отредактировал Nik57 - Вторник, 02.05.2017, 17:48
 
Ответить
СообщениеNic70y, спасибо!
А как быть если в некоторых ячейках повторяются события по времени и дате, тогда просто дублируются позиции?
Зеленым выделены ячейки, должны быть позиции 9,10 и 11,12. А появляется 9,10 и 9,10

Автор - Nik57
Дата добавления - 02.05.2017 в 17:48
Nik57 Дата: Вторник, 02.05.2017, 17:55 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, а как ее поменять?)))
[moder]Изменила[/moder]


Сообщение отредактировал Pelena - Вторник, 02.05.2017, 18:58
 
Ответить
СообщениеPelena, а как ее поменять?)))
[moder]Изменила[/moder]

Автор - Nik57
Дата добавления - 02.05.2017 в 17:55
Nic70y Дата: Вторник, 02.05.2017, 19:53 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4113
Репутация: 879 ±
Замечаний: 0% ±

Excel 2013
Зеленым
не обнаружил
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);2);A1+A2+СТРОКА()/10000000;"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Зеленым
не обнаружил
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);2);A1+A2+СТРОКА()/10000000;"")

Автор - Nic70y
Дата добавления - 02.05.2017 в 19:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как отсортировать по дате автоматически? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!