Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перераспределение строк в соответствии с другой таблицей - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перераспределение строк в соответствии с другой таблицей (Иное/Other)
Перераспределение строк в соответствии с другой таблицей
giperpetr Дата: Четверг, 11.05.2017, 16:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть две таблицы с товарами магазина. Артикулы товаров одинаковые, остальные данные различаются. И строки в таблицах в разном порядке. Необходимо расставить строки в таблице 1 в том же порядке, в каком они стоят в таблице два. Подскажите, где посмотреть или дайте совет, если на подобный вопрос ответа никто не давал.
 
Ответить
СообщениеЕсть две таблицы с товарами магазина. Артикулы товаров одинаковые, остальные данные различаются. И строки в таблицах в разном порядке. Необходимо расставить строки в таблице 1 в том же порядке, в каком они стоят в таблице два. Подскажите, где посмотреть или дайте совет, если на подобный вопрос ответа никто не давал.

Автор - giperpetr
Дата добавления - 11.05.2017 в 16:47
Pelena Дата: Четверг, 11.05.2017, 16:50 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10999
Репутация: 2456 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Без файла только общий ответ. Читайте про функцию ВПР()


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеБез файла только общий ответ. Читайте про функцию ВПР()

Автор - Pelena
Дата добавления - 11.05.2017 в 16:50
giperpetr Дата: Четверг, 11.05.2017, 18:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Без файла только общий ответ

Прикладываю файлы. Мне кажется, функция ВПР мне не очень подходит
К сообщению приложен файл: _1.xls(90Kb) · 8072723.xls(50Kb)
 
Ответить
Сообщение
Без файла только общий ответ

Прикладываю файлы. Мне кажется, функция ВПР мне не очень подходит

Автор - giperpetr
Дата добавления - 11.05.2017 в 18:06
ZORRO2005 Дата: Четверг, 11.05.2017, 20:49 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 359
Репутация: 138 ±
Замечаний: 0% ±

Excel2010
Я вижу решение в несколько этапов.
1. Копируем из таблицы 2(я так понял, что это файл 8072723.xls) столбец с артикулами в столбец A таблицы1.
2. Добавляем столбец B c формулой:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(C2;$A$1:$A$45;);МИН(ЕСЛИ(НЕ(СЧЁТЕСЛИ($B$1:B1;СТРОКА($B$2:B2)));СТРОКА($B$2:B2))))

протягиваем формулу вниз и получаем диапазон нужных строк.
3. Превращаем столбец B в значения и сортируем по возрастанию
К сообщению приложен файл: 2017_05_11.xlsx(41Kb)


Сообщение отредактировал ZORRO2005 - Четверг, 11.05.2017, 20:55
 
Ответить
СообщениеЯ вижу решение в несколько этапов.
1. Копируем из таблицы 2(я так понял, что это файл 8072723.xls) столбец с артикулами в столбец A таблицы1.
2. Добавляем столбец B c формулой:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(C2;$A$1:$A$45;);МИН(ЕСЛИ(НЕ(СЧЁТЕСЛИ($B$1:B1;СТРОКА($B$2:B2)));СТРОКА($B$2:B2))))

протягиваем формулу вниз и получаем диапазон нужных строк.
3. Превращаем столбец B в значения и сортируем по возрастанию

Автор - ZORRO2005
Дата добавления - 11.05.2017 в 20:49
giperpetr Дата: Понедельник, 15.05.2017, 17:12 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Я вижу решение в несколько этапов.
1. Копируем из таблицы 2(я так понял, что это файл 8072723.xls) столбец с артикулами в столбец A таблицы1.
2. Добавляем столбец B c формулой:

Благодарю за ответ. Очень помогло.
 
Ответить
Сообщение
Я вижу решение в несколько этапов.
1. Копируем из таблицы 2(я так понял, что это файл 8072723.xls) столбец с артикулами в столбец A таблицы1.
2. Добавляем столбец B c формулой:

Благодарю за ответ. Очень помогло.

Автор - giperpetr
Дата добавления - 15.05.2017 в 17:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перераспределение строк в соответствии с другой таблицей (Иное/Other)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!