Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор меньшего значения из массива по нескольким критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор меньшего значения из массива по нескольким критериям (Формулы/Formulas)
Выбор меньшего значения из массива по нескольким критериям
DSA Дата: Суббота, 13.05.2017, 09:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день ! Есть формула которая переносит выбранное значение в ячейку
Код
=ИНДЕКС($I4:$N4;ПОИСКПОЗ("да";ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0);)))
, на данный момент необходимо выбрать минимальное значение по нескольким выбранным критериям подскажите пожалуйста, как решить данную проблему,
файл во вложении. Спасибо.
К сообщению приложен файл: _DSA.xlsx(11Kb)


Сообщение отредактировал DSA - Суббота, 13.05.2017, 09:03
 
Ответить
СообщениеДобрый день ! Есть формула которая переносит выбранное значение в ячейку
Код
=ИНДЕКС($I4:$N4;ПОИСКПОЗ("да";ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0);)))
, на данный момент необходимо выбрать минимальное значение по нескольким выбранным критериям подскажите пожалуйста, как решить данную проблему,
файл во вложении. Спасибо.

Автор - DSA
Дата добавления - 13.05.2017 в 09:01
китин Дата: Суббота, 13.05.2017, 09:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4180
Репутация: 657 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как то так
Код
=ИНДЕКС($I4:$N4;;ПОИСКПОЗ(ИНДЕКС($B$3:$G$3;;ПОИСКПОЗ("да";ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0););0));$I$3:$N$3;0))
К сообщению приложен файл: DSA_otvet.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Суббота, 13.05.2017, 09:11
 
Ответить
Сообщениекак то так
Код
=ИНДЕКС($I4:$N4;;ПОИСКПОЗ(ИНДЕКС($B$3:$G$3;;ПОИСКПОЗ("да";ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0););0));$I$3:$N$3;0))

Автор - китин
Дата добавления - 13.05.2017 в 09:10
vikttur Дата: Суббота, 13.05.2017, 09:11 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

DSA, найдите отличие :)
Код
=ИНДЕКС($I4:$N4;ПОИСКПОЗ("да";ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0););))

Если цены не сортированы - формула массива:
Код
=МИН(ЕСЛИ($A$4:$A$6=O4;ЕСЛИ($B$4:$G$6="да";I4:N4)))


Сообщение отредактировал vikttur - Суббота, 13.05.2017, 09:23
 
Ответить
СообщениеDSA, найдите отличие :)
Код
=ИНДЕКС($I4:$N4;ПОИСКПОЗ("да";ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0););))

Если цены не сортированы - формула массива:
Код
=МИН(ЕСЛИ($A$4:$A$6=O4;ЕСЛИ($B$4:$G$6="да";I4:N4)))

Автор - vikttur
Дата добавления - 13.05.2017 в 09:11
Pelena Дата: Суббота, 13.05.2017, 09:15 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11161
Репутация: 2486 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
До кучи
Формула массива
Код
=МИН(ЕСЛИ("да"=ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0););$I4:$N4))

обычная формула
Код
=АГРЕГАТ(15;6;I4:N4/("да"=ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0);));1)
К сообщению приложен файл: 6187387.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДо кучи
Формула массива
Код
=МИН(ЕСЛИ("да"=ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0););$I4:$N4))

обычная формула
Код
=АГРЕГАТ(15;6;I4:N4/("да"=ИНДЕКС($B$4:$G$6;ПОИСКПОЗ($O4;$A$4:$A$6;0);));1)

Автор - Pelena
Дата добавления - 13.05.2017 в 09:15
DSA Дата: Суббота, 13.05.2017, 09:33 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большущее формулы Pelena самые универсальные!!!
 
Ответить
СообщениеСпасибо большущее формулы Pelena самые универсальные!!!

Автор - DSA
Дата добавления - 13.05.2017 в 09:33
vikttur Дата: Суббота, 13.05.2017, 10:01 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2199
Репутация: 382 ±
Замечаний: 0% ±

del


Сообщение отредактировал vikttur - Суббота, 13.05.2017, 10:02
 
Ответить
Сообщениеdel

Автор - vikttur
Дата добавления - 13.05.2017 в 10:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор меньшего значения из массива по нескольким критериям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!