Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Необходимо выделить формулой два первых слова из ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо выделить формулой два первых слова из ячейки (Формулы/Formulas)
Необходимо выделить формулой два первых слова из ячейки
Ghosy Дата: Понедельник, 05.06.2017, 12:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Необходимо выделить формулой два первых слова из ячейки "купить рацию по выгодной цене" в виде "купить-рацию", но не более 19 символов длиной, не разрывая слова.
К сообщению приложен файл: 1150772.xlsx(21Kb)


Сообщение отредактировал Ghosy - Понедельник, 05.06.2017, 12:36
 
Ответить
СообщениеНеобходимо выделить формулой два первых слова из ячейки "купить рацию по выгодной цене" в виде "купить-рацию", но не более 19 символов длиной, не разрывая слова.

Автор - Ghosy
Дата добавления - 05.06.2017 в 12:32
Nic70y Дата: Понедельник, 05.06.2017, 12:45 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4075
Репутация: 870 ±
Замечаний: 0% ±

Excel 2013
Код
=ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(A1;" ";"                   ";20-ДЛСТР(ПОДСТАВИТЬ(ЛЕВБ(A1&" ";20);" ";)));19));" ";"-")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(A1;" ";"                   ";20-ДЛСТР(ПОДСТАВИТЬ(ЛЕВБ(A1&" ";20);" ";)));19));" ";"-")

Автор - Nic70y
Дата добавления - 05.06.2017 в 12:45
Ghosy Дата: Понедельник, 05.06.2017, 13:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Nic70y, огромное спасибо!
 
Ответить
СообщениеNic70y, огромное спасибо!

Автор - Ghosy
Дата добавления - 05.06.2017 в 13:08
Ghosy Дата: Понедельник, 05.06.2017, 13:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Nic70y, а как сделать что бы огрызками слова в конце не ставилось?
у меня получается по этой формуле из "сколько стоит антенна на рацию" в сколько-стоит-антен
 
Ответить
СообщениеNic70y, а как сделать что бы огрызками слова в конце не ставилось?
у меня получается по этой формуле из "сколько стоит антенна на рацию" в сколько-стоит-антен

Автор - Ghosy
Дата добавления - 05.06.2017 в 13:12
AlexM Дата: Понедельник, 05.06.2017, 13:30 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Код
=ЛЕВБ(ПОДСТАВИТЬ(A1;" ";"-");ПРОСМОТР(19;ПОИСК("? ";A1&" ";СТРОКА($1:$19))))
К сообщению приложен файл: 1150772_01.xlsx(8Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ЛЕВБ(ПОДСТАВИТЬ(A1;" ";"-");ПРОСМОТР(19;ПОИСК("? ";A1&" ";СТРОКА($1:$19))))

Автор - AlexM
Дата добавления - 05.06.2017 в 13:30
buchlotnik Дата: Понедельник, 05.06.2017, 13:31 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2985
Репутация: 836 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
намудрил
Код
=ЕСЛИ(ПОИСК(" ";A1;ПОИСК(" ";A1)+1)>19;ЛЕВБ(A1;ПОИСК(" ";A1)-1);ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));200));" ";"-"))
К сообщению приложен файл: 4725552_01-1-.xlsx(10Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 05.06.2017, 13:48
 
Ответить
Сообщениенамудрил
Код
=ЕСЛИ(ПОИСК(" ";A1;ПОИСК(" ";A1)+1)>19;ЛЕВБ(A1;ПОИСК(" ";A1)-1);ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));200));" ";"-"))

Автор - buchlotnik
Дата добавления - 05.06.2017 в 13:31
AlexM Дата: Понедельник, 05.06.2017, 13:39 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Михаил, в файле сравнение работы двух формул
В В2 строка с ненужным пробелом.
В В5 не хватает еще одного слова.
К сообщению приложен файл: 4725552_01.xlsx(10Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеМихаил, в файле сравнение работы двух формул
В В2 строка с ненужным пробелом.
В В5 не хватает еще одного слова.

Автор - AlexM
Дата добавления - 05.06.2017 в 13:39
buchlotnik Дата: Понедельник, 05.06.2017, 13:47 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2985
Репутация: 836 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Алексей, так ведь заявлено "два первых слова", а с пробелом да - лоханулся, поправил


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
СообщениеАлексей, так ведь заявлено "два первых слова", а с пробелом да - лоханулся, поправил

Автор - buchlotnik
Дата добавления - 05.06.2017 в 13:47
AlexM Дата: Понедельник, 05.06.2017, 13:49 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
два первых слова
Ой... и я лоханулся. :(
Монстр выходит
Код
=СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;" ";"-";1);" ";ПОВТОР(" ";99));ПРОСМОТР(19;ПОИСК("? ";A1&" ";СТРОКА($1:$19)))))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 05.06.2017, 14:20
 
Ответить
Сообщение
два первых слова
Ой... и я лоханулся. :(
Монстр выходит
Код
=СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;" ";"-";1);" ";ПОВТОР(" ";99));ПРОСМОТР(19;ПОИСК("? ";A1&" ";СТРОКА($1:$19)))))

Автор - AlexM
Дата добавления - 05.06.2017 в 13:49
Ghosy Дата: Понедельник, 05.06.2017, 16:04 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Спасибо большое! Все работает
 
Ответить
СообщениеСпасибо большое! Все работает

Автор - Ghosy
Дата добавления - 05.06.2017 в 16:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо выделить формулой два первых слова из ячейки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!