Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Номер договора содержащий не более трех цифр - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номер договора содержащий не более трех цифр (Формулы/Formulas)
Номер договора содержащий не более трех цифр
Digital Дата: Пятница, 09.06.2017, 14:42 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день Уважаемые Форумчане!
Имеется список где с помощью формул из первого столбца берется значение "№ договора", а из второго столбца берется значение "дата договора" и объединяется все в третий столбец. Хотелось бы чтобы номер договора не превышал трех цифр, в связи с этим, подскажите пожалуйста можно ли как-то изменить формулу так чтобы когда начинался 10-ый договор, один ноль убирался и результат был бы такой 010. А когда начинался бы 100-ый договор, то убирался бы и второй ноль, а результат был бы такой 100.
Общее количество у меня договоров обычно не превышает 500.
К сообщению приложен файл: 5121344.xls(25Kb)
 
Ответить
СообщениеДобрый день Уважаемые Форумчане!
Имеется список где с помощью формул из первого столбца берется значение "№ договора", а из второго столбца берется значение "дата договора" и объединяется все в третий столбец. Хотелось бы чтобы номер договора не превышал трех цифр, в связи с этим, подскажите пожалуйста можно ли как-то изменить формулу так чтобы когда начинался 10-ый договор, один ноль убирался и результат был бы такой 010. А когда начинался бы 100-ый договор, то убирался бы и второй ноль, а результат был бы такой 100.
Общее количество у меня договоров обычно не превышает 500.

Автор - Digital
Дата добавления - 09.06.2017 в 14:42
Sancho Дата: Пятница, 09.06.2017, 14:45 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 10 ±
Замечаний: 0% ±

2007, 2010, 2013
Digital, формат ячеек, число, все форматы, в поле тип вбить три нуля 000
пардон не посмотрел пример

вот решение
Код
="№ "&ТЕКСТ(A1;"000")&" T/17 от "&ТЕКСТ(B1;"ДД.ММ.ГГГГ")
К сообщению приложен файл: _5121344.xls(26Kb)


Сообщение отредактировал Sancho - Пятница, 09.06.2017, 14:54
 
Ответить
СообщениеDigital, формат ячеек, число, все форматы, в поле тип вбить три нуля 000
пардон не посмотрел пример

вот решение
Код
="№ "&ТЕКСТ(A1;"000")&" T/17 от "&ТЕКСТ(B1;"ДД.ММ.ГГГГ")

Автор - Sancho
Дата добавления - 09.06.2017 в 14:45
_Boroda_ Дата: Пятница, 09.06.2017, 14:56 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11702
Репутация: 4839 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ТЕКСТ(A9;"№ 000")&" Т/17 от "&ТЕКСТ(B9;"ДД.ММ.ГГГ")

Код
=ТЕКСТ(A9;"№ 000\ Т\/")&ТЕКСТ(B9;"\1\7 от ДД.ММ.ГГГ")
К сообщению приложен файл: 5121344_1.xls(30Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ТЕКСТ(A9;"№ 000")&" Т/17 от "&ТЕКСТ(B9;"ДД.ММ.ГГГ")

Код
=ТЕКСТ(A9;"№ 000\ Т\/")&ТЕКСТ(B9;"\1\7 от ДД.ММ.ГГГ")

Автор - _Boroda_
Дата добавления - 09.06.2017 в 14:56
Digital Дата: Пятница, 09.06.2017, 15:36 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день Sancho!
Большое спасибо, работает. Буду разбирать hands .
 
Ответить
СообщениеДобрый день Sancho!
Большое спасибо, работает. Буду разбирать hands .

Автор - Digital
Дата добавления - 09.06.2017 в 15:36
Digital Дата: Пятница, 09.06.2017, 15:42 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день Boroda!
Большое спасибо за вариант. Работает как нужно. Буду учить и разбирать yes
 
Ответить
СообщениеДобрый день Boroda!
Большое спасибо за вариант. Работает как нужно. Буду учить и разбирать yes

Автор - Digital
Дата добавления - 09.06.2017 в 15:42
zs Дата: Суббота, 10.06.2017, 00:07 | Сообщение № 6
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
=СЦЕПИТЬ("№";" ";ЕСЛИ(ДЛСТР(A1)=1;"00";ЕСЛИ(ДЛСТР(A1)=2;"0";""));A1;" ";"Т/17 от";" ";ТЕКСТ(B1;"ДД.ММ.ГГГГ"))
 
Ответить
Сообщение=СЦЕПИТЬ("№";" ";ЕСЛИ(ДЛСТР(A1)=1;"00";ЕСЛИ(ДЛСТР(A1)=2;"0";""));A1;" ";"Т/17 от";" ";ТЕКСТ(B1;"ДД.ММ.ГГГГ"))

Автор - zs
Дата добавления - 10.06.2017 в 00:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номер договора содержащий не более трех цифр (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!