Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение таблицы из таблицы на другом листе по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение таблицы из таблицы на другом листе по условию (Формулы/Formulas)
Заполнение таблицы из таблицы на другом листе по условию
Inertecs Дата: Понедельник, 12.06.2017, 20:40 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет. Перейду сразу к вопросу. Есть книга с двумя листами. На одном ФИО|шифр|Наблюдающий№1|Наблюдающий№2|Наблюдающий№3
На втором листе шифр|Наблюдающий№1|Наблюдающий№2|Наблюдающий №3. Наблюдающие привязаны к шифру. Нужно автоматически подставлять наблюдающих к каждому человеку из списка. При этом Наблюдающие могут меняться. Хотелось бы, чтобы они автоматически менялись и в первой таблице.
Всем заранее спасибо)
К сообщению приложен файл: 4949638.xlsx(9Kb)
 
Ответить
СообщениеВсем привет. Перейду сразу к вопросу. Есть книга с двумя листами. На одном ФИО|шифр|Наблюдающий№1|Наблюдающий№2|Наблюдающий№3
На втором листе шифр|Наблюдающий№1|Наблюдающий№2|Наблюдающий №3. Наблюдающие привязаны к шифру. Нужно автоматически подставлять наблюдающих к каждому человеку из списка. При этом Наблюдающие могут меняться. Хотелось бы, чтобы они автоматически менялись и в первой таблице.
Всем заранее спасибо)

Автор - Inertecs
Дата добавления - 12.06.2017 в 20:40
Che79 Дата: Понедельник, 12.06.2017, 20:52 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 381
Репутация: 55 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
Inertecs, здравствуйте. Так нужно?
Код
=ВПР($B2;Лист2!$A$2:$G$3;СТОЛБЕЦ(B$1);)
(файл_1) или
Код
=ИНДЕКС(Лист2!$A$2:$G$3;ПОИСКПОЗ($B2;Лист2!$A$2:$A$3;);СТОЛБЕЦ(B$1))
(файл_2)
К сообщению приложен файл: 4949638_1.xlsx(10Kb) · 4949638_2.xlsx(10Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 12.06.2017, 21:59
 
Ответить
СообщениеInertecs, здравствуйте. Так нужно?
Код
=ВПР($B2;Лист2!$A$2:$G$3;СТОЛБЕЦ(B$1);)
(файл_1) или
Код
=ИНДЕКС(Лист2!$A$2:$G$3;ПОИСКПОЗ($B2;Лист2!$A$2:$A$3;);СТОЛБЕЦ(B$1))
(файл_2)

Автор - Che79
Дата добавления - 12.06.2017 в 20:52
Inertecs Дата: Понедельник, 12.06.2017, 21:06 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да, то что нужно)
Большое спасибо. А не могли бы объяснить сам алгоритм написания данной формулы?
Буду очень благодарен
 
Ответить
СообщениеДа, то что нужно)
Большое спасибо. А не могли бы объяснить сам алгоритм написания данной формулы?
Буду очень благодарен

Автор - Inertecs
Дата добавления - 12.06.2017 в 21:06
Che79 Дата: Понедельник, 12.06.2017, 21:18 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 381
Репутация: 55 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
Inertecs, объясняльщик из меня сегодня слабый %) , поэтому почитайте лучше тут
про ВПР
Файл в своем первом сообщении перевложил, устранена ошибка в выпадающем списке шифров


Делай нормально и будет нормально!
 
Ответить
СообщениеInertecs, объясняльщик из меня сегодня слабый %) , поэтому почитайте лучше тут
про ВПР
Файл в своем первом сообщении перевложил, устранена ошибка в выпадающем списке шифров

Автор - Che79
Дата добавления - 12.06.2017 в 21:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение таблицы из таблицы на другом листе по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!