Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Получить сумму диапазона согласно таблице соответствия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить сумму диапазона согласно таблице соответствия (Формулы/Formulas)
Получить сумму диапазона согласно таблице соответствия
skais Дата: Вторник, 13.06.2017, 08:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Прошу помочь при написании формулы для получения суммы диапазона согласно таблице соответствия.
То есть - есть таблица где есть буквенные обозначения с цифрами или только буквенные, согласно которой нужно подставить значения из таблицы соответствия и получить их сумму.
К сообщению приложен файл: Book1.xlsx(11Kb)
 
Ответить
СообщениеПрошу помочь при написании формулы для получения суммы диапазона согласно таблице соответствия.
То есть - есть таблица где есть буквенные обозначения с цифрами или только буквенные, согласно которой нужно подставить значения из таблицы соответствия и получить их сумму.

Автор - skais
Дата добавления - 13.06.2017 в 08:49
AlexM Дата: Вторник, 13.06.2017, 09:05 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
обычная формула
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2:F2;B$7:B$12)*C$7:C$12)
формула массива
Код
=СУММ(--ВПР(Т(ИНДЕКС(0&B2:F2;));0&B$6:C$12;2;))
К сообщению приложен файл: Book1_01.xlsx(9Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеобычная формула
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2:F2;B$7:B$12)*C$7:C$12)
формула массива
Код
=СУММ(--ВПР(Т(ИНДЕКС(0&B2:F2;));0&B$6:C$12;2;))

Автор - AlexM
Дата добавления - 13.06.2017 в 09:05
skais Дата: Вторник, 13.06.2017, 09:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - skais
Дата добавления - 13.06.2017 в 09:18
zs Дата: Вторник, 13.06.2017, 09:30 | Сообщение № 4
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Код
=ЕСЛИ(B2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(B2=0;0;ПОДСТАВИТЬ(B2;ПРАВСИМВ(B2;1);"")))+ЕСЛИ(C2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(C2=0;0;ПОДСТАВИТЬ(C2;ПРАВСИМВ(C2;1);""))+ЕСЛИ(D2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(D2=0;0;ПОДСТАВИТЬ(D2;ПРАВСИМВ(D2;1);"")))+ЕСЛИ(E2="отп";ЗАМЕНИТЬ(E2;1;3;0);ЕСЛИ(E2=0;0;ПОДСТАВИТЬ(E2;ПРАВСИМВ(E2;1);0))+ЕСЛИ(F2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(F2=0;0;ПОДСТАВИТЬ(F2;ПРАВСИМВ(F2;1);"")))))
 
Ответить
Сообщение
Код
=ЕСЛИ(B2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(B2=0;0;ПОДСТАВИТЬ(B2;ПРАВСИМВ(B2;1);"")))+ЕСЛИ(C2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(C2=0;0;ПОДСТАВИТЬ(C2;ПРАВСИМВ(C2;1);""))+ЕСЛИ(D2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(D2=0;0;ПОДСТАВИТЬ(D2;ПРАВСИМВ(D2;1);"")))+ЕСЛИ(E2="отп";ЗАМЕНИТЬ(E2;1;3;0);ЕСЛИ(E2=0;0;ПОДСТАВИТЬ(E2;ПРАВСИМВ(E2;1);0))+ЕСЛИ(F2="отп";ЗАМЕНИТЬ("отп";1;3;0);ЕСЛИ(F2=0;0;ПОДСТАВИТЬ(F2;ПРАВСИМВ(F2;1);"")))))

Автор - zs
Дата добавления - 13.06.2017 в 09:30
AlexM Дата: Вторник, 13.06.2017, 09:35 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
zs, интересная формула :)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеzs, интересная формула :)

Автор - AlexM
Дата добавления - 13.06.2017 в 09:35
pabchek Дата: Вторник, 13.06.2017, 15:30 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 741
Репутация: 168 ±
Замечаний: 0% ±

Excel 2007
[offtop]
интересная формула

Я бы сказал, просто шикарная. Я даже потратил минут 15 чтобы въехать. Мне кажется, автору нужно дать специальную награду[/offtop]


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение[offtop]
интересная формула

Я бы сказал, просто шикарная. Я даже потратил минут 15 чтобы въехать. Мне кажется, автору нужно дать специальную награду[/offtop]

Автор - pabchek
Дата добавления - 13.06.2017 в 15:30
vikttur Дата: Вторник, 13.06.2017, 19:34 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2387
Репутация: 412 ±
Замечаний: 0% ±

Формула массива:
Код
=СУММ(ЕСЛИ($B$7:$B$12=B2:F2;$C$7:$C$12))
 
Ответить
СообщениеФормула массива:
Код
=СУММ(ЕСЛИ($B$7:$B$12=B2:F2;$C$7:$C$12))

Автор - vikttur
Дата добавления - 13.06.2017 в 19:34
skais Дата: Вторник, 13.06.2017, 20:54 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Код
=СЧЁТЕСЛИ(B2:F2;B$7:B$12)

Хотел в добавок посчитать количество ячеек, но что-то не считает?
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(B2:F2;B$7:B$12)

Хотел в добавок посчитать количество ячеек, но что-то не считает?

Автор - skais
Дата добавления - 13.06.2017 в 20:54
Pelena Дата: Вторник, 13.06.2017, 20:57 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11467
Репутация: 2546 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
А при чём вопрос про количество ячеек в теме про сумму?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА при чём вопрос про количество ячеек в теме про сумму?

Автор - Pelena
Дата добавления - 13.06.2017 в 20:57
AlexM Дата: Вторник, 13.06.2017, 20:58 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3584
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Может так
Код
=СЧЁТЕСЛИ(B2:F2;"<>")
или
Код
=СЧЁТЗ(B2:F2)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 13.06.2017, 20:59
 
Ответить
СообщениеМожет так
Код
=СЧЁТЕСЛИ(B2:F2;"<>")
или
Код
=СЧЁТЗ(B2:F2)

Автор - AlexM
Дата добавления - 13.06.2017 в 20:58
skais Дата: Вторник, 13.06.2017, 20:58 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
В дополнении, мне казалось это элементарно, но не получилось.
Вот так считает
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2:F2;B$7:B$12))


Сообщение отредактировал skais - Вторник, 13.06.2017, 21:02
 
Ответить
СообщениеВ дополнении, мне казалось это элементарно, но не получилось.
Вот так считает
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B2:F2;B$7:B$12))

Автор - skais
Дата добавления - 13.06.2017 в 20:58
skais Дата: Вторник, 13.06.2017, 21:03 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
AlexM мне нужно посчитать только ячейки из b2:F2 которые входят в диапазон B$7:B$12


Сообщение отредактировал skais - Вторник, 13.06.2017, 21:04
 
Ответить
СообщениеAlexM мне нужно посчитать только ячейки из b2:F2 которые входят в диапазон B$7:B$12

Автор - skais
Дата добавления - 13.06.2017 в 21:03
Pelena Дата: Вторник, 13.06.2017, 21:14 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11467
Репутация: 2546 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
skais, ещё раз: вопрос не по теме. Замечание Вам


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеskais, ещё раз: вопрос не по теме. Замечание Вам

Автор - Pelena
Дата добавления - 13.06.2017 в 21:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить сумму диапазона согласно таблице соответствия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!