Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание формулы для перемещения массива в один стоблец - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание формулы для перемещения массива в один стоблец (Формулы/Formulas)
Создание формулы для перемещения массива в один стоблец
DmitryWilma Дата: Среда, 14.06.2017, 16:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый День! Возникли трудности с переносом массива в 1 столбец. В прикрепленной файле, массив - то что есть, столбец - то что хотелось бы получить. При транспонировании и дальнейшем растяжении, эксель берет значение ниже на то число строк, сколько столбцов в массиве. С функцией смещение таже история. Прошу подсказать, помочь. Если что-то недостаточно расписал в проблеме, отвечу.
К сообщению приложен файл: 6067453.xlsx(8Kb)
 
Ответить
СообщениеДобрый День! Возникли трудности с переносом массива в 1 столбец. В прикрепленной файле, массив - то что есть, столбец - то что хотелось бы получить. При транспонировании и дальнейшем растяжении, эксель берет значение ниже на то число строк, сколько столбцов в массиве. С функцией смещение таже история. Прошу подсказать, помочь. Если что-то недостаточно расписал в проблеме, отвечу.

Автор - DmitryWilma
Дата добавления - 14.06.2017 в 16:00
_Boroda_ Дата: Среда, 14.06.2017, 16:22 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10829
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ИНДЕКС(B$7:G$10;(СЧЁТЗ(K$2:K2)-1)/ЧИСЛСТОЛБ(B$7:G$10)+1;ОСТАТ(СЧЁТЗ(K$2:K2)-1;ЧИСЛСТОЛБ(B$7:G$10))+1)
К сообщению приложен файл: 6067453_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ИНДЕКС(B$7:G$10;(СЧЁТЗ(K$2:K2)-1)/ЧИСЛСТОЛБ(B$7:G$10)+1;ОСТАТ(СЧЁТЗ(K$2:K2)-1;ЧИСЛСТОЛБ(B$7:G$10))+1)

Автор - _Boroda_
Дата добавления - 14.06.2017 в 16:22
DmitryWilma Дата: Среда, 14.06.2017, 17:03 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемый Борода, Спасибо большое! Репутацию повышу как доступ будет!
 
Ответить
СообщениеУважаемый Борода, Спасибо большое! Репутацию повышу как доступ будет!

Автор - DmitryWilma
Дата добавления - 14.06.2017 в 17:03
jakim Дата: Среда, 14.06.2017, 23:06 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 786
Репутация: 205 ±
Замечаний: 0% ±

Ещё одна формула

Код
=IFERROR(INDEX($B$7:$G$10;AGGREGATE(15;6;ROW($1:$20)/(B$7:G$10<>"");ROWS($3:3));MOD(ROWS($3:3)-1;6)+1);"")
К сообщению приложен файл: 7270858.xlsx(9Kb)
 
Ответить
Сообщение
Ещё одна формула

Код
=IFERROR(INDEX($B$7:$G$10;AGGREGATE(15;6;ROW($1:$20)/(B$7:G$10<>"");ROWS($3:3));MOD(ROWS($3:3)-1;6)+1);"")

Автор - jakim
Дата добавления - 14.06.2017 в 23:06
vikttur Дата: Четверг, 15.06.2017, 00:46 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2262
Репутация: 389 ±
Замечаний: 0% ±

Код
=ИНДЕКС($B$7:$G$10;(СТРОКА(A1)-1)/СЧЁТЗ($B$7:$G$7)+1;ОСТАТ(СТРОКА(A6);СЧЁТЗ($B$7:$G$7))+1)

Если в *$B$7:$G$7* возможны пустые ячейки, лучше считать столбцы.
 
Ответить
Сообщение
Код
=ИНДЕКС($B$7:$G$10;(СТРОКА(A1)-1)/СЧЁТЗ($B$7:$G$7)+1;ОСТАТ(СТРОКА(A6);СЧЁТЗ($B$7:$G$7))+1)

Если в *$B$7:$G$7* возможны пустые ячейки, лучше считать столбцы.

Автор - vikttur
Дата добавления - 15.06.2017 в 00:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание формулы для перемещения массива в один стоблец (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!