Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет ячеек содержащих текст - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет ячеек содержащих текст (Формулы/Formulas)
подсчет ячеек содержащих текст
AleksFin Дата: Понедельник, 26.06.2017, 11:15 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!

Помогите пжл с формулой. Требуется подсчитать в ячейке AD сумму, по количеству указанных в ячейках текста "ТО". Т.е.чтобы текст "ТО" считал за единицу.
К сообщению приложен файл: ____26.06.17..xlsx(21Kb)
 
Ответить
СообщениеЗдравствуйте!

Помогите пжл с формулой. Требуется подсчитать в ячейке AD сумму, по количеству указанных в ячейках текста "ТО". Т.е.чтобы текст "ТО" считал за единицу.

Автор - AleksFin
Дата добавления - 26.06.2017 в 11:15
китин Дата: Понедельник, 26.06.2017, 11:23 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4213
Репутация: 658 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=СЧЁТЕСЛИ($F8:$AC8;"ТО")

так?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 26.06.2017, 11:23
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ($F8:$AC8;"ТО")

так?

Автор - китин
Дата добавления - 26.06.2017 в 11:23
_Boroda_ Дата: Понедельник, 26.06.2017, 11:33 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10829
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Александр, переписал Вам в файле вообще почти все формулы и формат ячеек переделал на # ##0;;. Выделил зеленым
А для Вашего вопроса такой вариант (текстовые значения могут быть вообще любыми)
Код
=СЧЁТЗ(F8:AC8)-СЧЁТ(F8:AC8)
К сообщению приложен файл: _26.06.17-1.xlsx(22Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАлександр, переписал Вам в файле вообще почти все формулы и формат ячеек переделал на # ##0;;. Выделил зеленым
А для Вашего вопроса такой вариант (текстовые значения могут быть вообще любыми)
Код
=СЧЁТЗ(F8:AC8)-СЧЁТ(F8:AC8)

Автор - _Boroda_
Дата добавления - 26.06.2017 в 11:33
AleksFin Дата: Понедельник, 26.06.2017, 11:33 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, Да, спасибо, все верно.

Единственно, сразу не написал, у меня там два значения на выбор ТО и КР, что в формулу добавить чтобы при выборе любого из них проставлялась и суммировалась?
 
Ответить
Сообщениекитин, Да, спасибо, все верно.

Единственно, сразу не написал, у меня там два значения на выбор ТО и КР, что в формулу добавить чтобы при выборе любого из них проставлялась и суммировалась?

Автор - AleksFin
Дата добавления - 26.06.2017 в 11:33
китин Дата: Понедельник, 26.06.2017, 11:42 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4213
Репутация: 658 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
два значения на выбор ТО и КР

Код
=СЧЁТЕСЛИ($F8:$AC8;"ТО")+СЧЁТЕСЛИ($F8:$AC8;"КР")

не думая :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
два значения на выбор ТО и КР

Код
=СЧЁТЕСЛИ($F8:$AC8;"ТО")+СЧЁТЕСЛИ($F8:$AC8;"КР")

не думая :D

Автор - китин
Дата добавления - 26.06.2017 в 11:42
zs Дата: Понедельник, 26.06.2017, 18:51 | Сообщение № 6
Группа: Заблокированные
Ранг: Участник
Сообщений: 87
Репутация: -19 ±
Замечаний: 100% ±

Excel 2003
Формула массива:
Код
=СУММ(--СОВПАД(G2;F8:AC8))

где G2=ТО;
P.S. Можно в G2 выпадающий список: ТО; КР


Сообщение отредактировал zs - Вторник, 27.06.2017, 12:58
 
Ответить
СообщениеФормула массива:
Код
=СУММ(--СОВПАД(G2;F8:AC8))

где G2=ТО;
P.S. Можно в G2 выпадающий список: ТО; КР

Автор - zs
Дата добавления - 26.06.2017 в 18:51
AlexM Дата: Понедельник, 26.06.2017, 19:50 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3557
Репутация: 898 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММПРОИЗВ(Ч(F8:AC8={"ТО":"КР"}))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(Ч(F8:AC8={"ТО":"КР"}))

Автор - AlexM
Дата добавления - 26.06.2017 в 19:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет ячеек содержащих текст (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!