Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение Subtotal со значениями в группе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение Subtotal со значениями в группе (Формулы/Formulas)
Сравнение Subtotal со значениями в группе
mslobogan Дата: Четверг, 29.06.2017, 14:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, подскажите пож. как можно решить следующую задачу:

необходимо сравнить промежуточные(Avg) итоги по цене с ценами в соответственной группе для определения кто купил по большей или меньшей цене исходя из средней(Subtotal)? Пытался использовать ВПР, но что то не то.

Во вложении файл.

Заранее благодарен
К сообщению приложен файл: 3841235.xlsx(13Kb)
 
Ответить
СообщениеДобрый день, подскажите пож. как можно решить следующую задачу:

необходимо сравнить промежуточные(Avg) итоги по цене с ценами в соответственной группе для определения кто купил по большей или меньшей цене исходя из средней(Subtotal)? Пытался использовать ВПР, но что то не то.

Во вложении файл.

Заранее благодарен

Автор - mslobogan
Дата добавления - 29.06.2017 в 14:08
pabchek Дата: Четверг, 29.06.2017, 15:11 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 725
Репутация: 162 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Да, понятно плохо. Может так? (формула массива)
Код
=B6/ИНДЕКС(B6:B17;ПОИСКПОЗ(1;--ЕПУСТО(F6:F17);0))
К сообщению приложен файл: 0081903.xlsx(15Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте!
Да, понятно плохо. Может так? (формула массива)
Код
=B6/ИНДЕКС(B6:B17;ПОИСКПОЗ(1;--ЕПУСТО(F6:F17);0))

Автор - pabchek
Дата добавления - 29.06.2017 в 15:11
mslobogan Дата: Четверг, 29.06.2017, 15:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, во вложеном файле описал как должно быть.

Спасибо.
К сообщению приложен файл: 2030864.xlsx(13Kb)
 
Ответить
СообщениеДобрый день, во вложеном файле описал как должно быть.

Спасибо.

Автор - mslobogan
Дата добавления - 29.06.2017 в 15:30
mslobogan Дата: Четверг, 29.06.2017, 15:37 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Виктор извините за неточности, в файле описал как должно быть.
 
Ответить
СообщениеВиктор извините за неточности, в файле описал как должно быть.

Автор - mslobogan
Дата добавления - 29.06.2017 в 15:37
_Boroda_ Дата: Четверг, 29.06.2017, 15:46 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10829
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Среднее
Код
=ИНДЕКС(A6:A$92;ПОИСКПОЗ("*мг Average";B6:B$92;))

сравнение
Код
=ТЕКСТ(C6-A6;"""купил дешевле"";""купил дороже"";""""")
К сообщению приложен файл: 6425083.xlsx(16Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Среднее
Код
=ИНДЕКС(A6:A$92;ПОИСКПОЗ("*мг Average";B6:B$92;))

сравнение
Код
=ТЕКСТ(C6-A6;"""купил дешевле"";""купил дороже"";""""")

Автор - _Boroda_
Дата добавления - 29.06.2017 в 15:46
mslobogan Дата: Четверг, 29.06.2017, 16:14 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Александр спасибо, только если отфильтровать по 3 мг, то столбец "дороже/дешевле" пустой.
И еще скажите пож. если в таблице 140000 записей, в формулах просто изменить диапазон?

Спасибо, сколько я Вам должен?
 
Ответить
СообщениеАлександр спасибо, только если отфильтровать по 3 мг, то столбец "дороже/дешевле" пустой.
И еще скажите пож. если в таблице 140000 записей, в формулах просто изменить диапазон?

Спасибо, сколько я Вам должен?

Автор - mslobogan
Дата добавления - 29.06.2017 в 16:14
_Boroda_ Дата: Четверг, 29.06.2017, 16:30 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10829
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
если отфильтровать по 3 мг, то столбец "дороже/дешевле" пустой

Правильно. Вы описали результат для больше и для меньше, а для равно среднему получается ничего не пишем
Можно так
Код
=ЕСЛИ(ЕОШ(ПОИСК("Average";B6));ТЕКСТ(C6-A6;"""купил дешевле"";""купил дороже"";""средняя цена""");"")

На большой таблице прикиньте самый большой промежуток между средними (допустим, 200 записей), умножьте его на 2,5 (получим 500) и формулу для ячейки С6
Код
=ИНДЕКС(A6:A$92;ПОИСКПОЗ("*мг Average";B6:B$92;))

перепишите так
Код
=ИНДЕКС(A6:A505;ПОИСКПОЗ("*мг Average";B6:B505;))
и протяните вниз
Обратите внимание на отсутствие $ перед 505

Спасибо, сколько я Вам должен?
Это не ветка "фриланс", здесь работают за идею.
Но если Вы испытываете непреодолимое стремление к тому, чтобы я выпил за Ваше здоровье, то отказываться не буду - мои реквизиты в подписи, а объем на Ваше усмотрение
К сообщению приложен файл: 6425083_1.xlsx(16Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
если отфильтровать по 3 мг, то столбец "дороже/дешевле" пустой

Правильно. Вы описали результат для больше и для меньше, а для равно среднему получается ничего не пишем
Можно так
Код
=ЕСЛИ(ЕОШ(ПОИСК("Average";B6));ТЕКСТ(C6-A6;"""купил дешевле"";""купил дороже"";""средняя цена""");"")

На большой таблице прикиньте самый большой промежуток между средними (допустим, 200 записей), умножьте его на 2,5 (получим 500) и формулу для ячейки С6
Код
=ИНДЕКС(A6:A$92;ПОИСКПОЗ("*мг Average";B6:B$92;))

перепишите так
Код
=ИНДЕКС(A6:A505;ПОИСКПОЗ("*мг Average";B6:B505;))
и протяните вниз
Обратите внимание на отсутствие $ перед 505

Спасибо, сколько я Вам должен?
Это не ветка "фриланс", здесь работают за идею.
Но если Вы испытываете непреодолимое стремление к тому, чтобы я выпил за Ваше здоровье, то отказываться не буду - мои реквизиты в подписи, а объем на Ваше усмотрение

Автор - _Boroda_
Дата добавления - 29.06.2017 в 16:30
mslobogan Дата: Четверг, 29.06.2017, 16:51 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Александр, все равно, если отфильтровать например 3 мл, то получается значение - "средняя цена" а должно быть больше или меньше средней.
 
Ответить
СообщениеАлександр, все равно, если отфильтровать например 3 мл, то получается значение - "средняя цена" а должно быть больше или меньше средней.

Автор - mslobogan
Дата добавления - 29.06.2017 в 16:51
mslobogan Дата: Четверг, 29.06.2017, 17:30 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
да, вроде бы все верно, это группировка как то не так группирует.
 
Ответить
Сообщениеда, вроде бы все верно, это группировка как то не так группирует.

Автор - mslobogan
Дата добавления - 29.06.2017 в 17:30
_Boroda_ Дата: Четверг, 29.06.2017, 17:38 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10829
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы не забыли перед выводом итогов отсортировать таблицу по группируемому значению (столбцу В)?
Предположу, что Вам вот так нужно
К сообщению приложен файл: 6425083_2.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы не забыли перед выводом итогов отсортировать таблицу по группируемому значению (столбцу В)?
Предположу, что Вам вот так нужно

Автор - _Boroda_
Дата добавления - 29.06.2017 в 17:38
mslobogan Дата: Четверг, 29.06.2017, 18:15 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ок, Александр огромное спасибо, про кошелек помню:)
 
Ответить
Сообщениеок, Александр огромное спасибо, про кошелек помню:)

Автор - mslobogan
Дата добавления - 29.06.2017 в 18:15
mslobogan Дата: Четверг, 29.06.2017, 19:08 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Александр, скажите пож. если в общем файле есть не только "мг", а и "л", "мл", "г" и т д, как здесь быть? А в формуле указаны только "мг".
Я полный файл вышлю на Вашу почту.

Спасибо.
 
Ответить
СообщениеАлександр, скажите пож. если в общем файле есть не только "мг", а и "л", "мл", "г" и т д, как здесь быть? А в формуле указаны только "мг".
Я полный файл вышлю на Вашу почту.

Спасибо.

Автор - mslobogan
Дата добавления - 29.06.2017 в 19:08
mslobogan Дата: Четверг, 29.06.2017, 19:32 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
уже понял, извините:)))
 
Ответить
Сообщениеуже понял, извините:)))

Автор - mslobogan
Дата добавления - 29.06.2017 в 19:32
_Boroda_ Дата: Четверг, 29.06.2017, 19:32 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10829
Репутация: 4473 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
На почту нельзя - см. Правила форума.
Здесь все просто - сотрите "мг" в формуле
более того, если у Вас л, мл, г, мг от чисел пробелом не отделяются, то можно так, например
Код
=ИНДЕКС(A6:A505;ПОИСКПОЗ("* *";B6:B505;))

А если где-то может быть, то
Код
=ИНДЕКС(A6:A505;ПОИСКПОЗ("* Average";B6:B505;))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНа почту нельзя - см. Правила форума.
Здесь все просто - сотрите "мг" в формуле
более того, если у Вас л, мл, г, мг от чисел пробелом не отделяются, то можно так, например
Код
=ИНДЕКС(A6:A505;ПОИСКПОЗ("* *";B6:B505;))

А если где-то может быть, то
Код
=ИНДЕКС(A6:A505;ПОИСКПОЗ("* Average";B6:B505;))

Автор - _Boroda_
Дата добавления - 29.06.2017 в 19:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение Subtotal со значениями в группе (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!