Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт количества ячеек между повторяющимися значениями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества ячеек между повторяющимися значениями (Формулы/Formulas)
Подсчёт количества ячеек между повторяющимися значениями
Qualcomm Дата: Пятница, 07.07.2017, 03:28 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Необходимо в столбце D посчитать количество ячеек между повторяющимися значениями в столбцах B и C. Цветом выделены повторяющиеся значения, в столбце D значения которые необходимо что бы считала формула. Помогите, пожалуйста, совсем не силен в сложных формулах.
К сообщению приложен файл: 5354278.xlsx(9Kb)
 
Ответить
СообщениеНеобходимо в столбце D посчитать количество ячеек между повторяющимися значениями в столбцах B и C. Цветом выделены повторяющиеся значения, в столбце D значения которые необходимо что бы считала формула. Помогите, пожалуйста, совсем не силен в сложных формулах.

Автор - Qualcomm
Дата добавления - 07.07.2017 в 03:28
Pelena Дата: Пятница, 07.07.2017, 07:08 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11756
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
И Вам здравствуйте.
Код
=ЕСЛИ(B2=C2;СТРОКА()-ПРОСМОТР(;-1/($B1:B$1=$C1:C$1);СТРОКА(1:$1));"")
К сообщению приложен файл: 2360552.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Код
=ЕСЛИ(B2=C2;СТРОКА()-ПРОСМОТР(;-1/($B1:B$1=$C1:C$1);СТРОКА(1:$1));"")

Автор - Pelena
Дата добавления - 07.07.2017 в 07:08
Qualcomm Дата: Пятница, 07.07.2017, 07:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Pelena, огромное спасибо!! Вы просто профи specool А возможно ли например чтобы вместо значений считающих ячейки между повторяющимися значениями, подставлялись определенные суммы соответствующие каждому числу?
Например:
1 - 1000
2 - 1500
3 - 2000
4 - 2500
5 - 3000
и т.д.
Я так прикидываю, что можно просто создать соседний столбец и с помощью впр заполнить соседние ячейки. Но можно ли это всё вместить в одну формулу?
К сообщению приложен файл: 2361981.xlsx(11Kb)
 
Ответить
СообщениеPelena, огромное спасибо!! Вы просто профи specool А возможно ли например чтобы вместо значений считающих ячейки между повторяющимися значениями, подставлялись определенные суммы соответствующие каждому числу?
Например:
1 - 1000
2 - 1500
3 - 2000
4 - 2500
5 - 3000
и т.д.
Я так прикидываю, что можно просто создать соседний столбец и с помощью впр заполнить соседние ячейки. Но можно ли это всё вместить в одну формулу?

Автор - Qualcomm
Дата добавления - 07.07.2017 в 07:45
Pelena Дата: Пятница, 07.07.2017, 07:56 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11756
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Если числа идут через 500, как в примере, то
Код
=ЕСЛИ(B2=C2;(СТРОКА()-ПРОСМОТР(;-1/($B1:B$1=$C1:C$1);СТРОКА(1:$1)))*500+500;"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли числа идут через 500, как в примере, то
Код
=ЕСЛИ(B2=C2;(СТРОКА()-ПРОСМОТР(;-1/($B1:B$1=$C1:C$1);СТРОКА(1:$1)))*500+500;"")

Автор - Pelena
Дата добавления - 07.07.2017 в 07:56
Qualcomm Дата: Пятница, 07.07.2017, 08:49 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Pelena, числа могут быть произвольные, не всегда кратные. Их либо в формуле забить, либо из доп таблицы подтянуть. Ещё раз спасибо!
 
Ответить
СообщениеPelena, числа могут быть произвольные, не всегда кратные. Их либо в формуле забить, либо из доп таблицы подтянуть. Ещё раз спасибо!

Автор - Qualcomm
Дата добавления - 07.07.2017 в 08:49
_Boroda_ Дата: Пятница, 07.07.2017, 09:11 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11659
Репутация: 4831 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
С отдельной таблицей
Код
=ЕСЛИ(B2=C2;ВПР(A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1);H$2:I$99;2;);"")

Код
=ЕСЛИ(B2=C2;ИНДЕКС(I$2:I$99;A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1));"")

Без таблицы
Код
=ЕСЛИ(B2=C2;ВПР(A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1);{1;1000:2;1500:3;2000:4;2500:5;3000:6;3500:7;4000:8;4500:9;5000:10;5500:11;6000};2;);"")

Код
=ЕСЛИ(B2=C2;ИНДЕКС({1000:1500:2000:2500:3000:3500:4000:4500:5000:5500:6000};A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1));"")
К сообщению приложен файл: 5354278_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
С отдельной таблицей
Код
=ЕСЛИ(B2=C2;ВПР(A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1);H$2:I$99;2;);"")

Код
=ЕСЛИ(B2=C2;ИНДЕКС(I$2:I$99;A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1));"")

Без таблицы
Код
=ЕСЛИ(B2=C2;ВПР(A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1);{1;1000:2;1500:3;2000:4;2500:5;3000:6;3500:7;4000:8;4500:9;5000:10;5500:11;6000};2;);"")

Код
=ЕСЛИ(B2=C2;ИНДЕКС({1000:1500:2000:2500:3000:3500:4000:4500:5000:5500:6000};A2-ПРОСМОТР(;-1/(B$1:B1=C$1:C1);A$1:A1));"")

Автор - _Boroda_
Дата добавления - 07.07.2017 в 09:11
Qualcomm Дата: Пятница, 07.07.2017, 15:13 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, большое спасибо за помощь!!!
 
Ответить
Сообщение_Boroda_, большое спасибо за помощь!!!

Автор - Qualcomm
Дата добавления - 07.07.2017 в 15:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества ячеек между повторяющимися значениями (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!