Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Работа с массивом и исключением - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Работа с массивом и исключением (Формулы/Formulas)
Работа с массивом и исключением
anatoliusfl Дата: Пятница, 07.07.2017, 15:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Нужна такая помощь при проработке программы, ибо мои навыки в экселе на примитивном уровне.

Есть таблица, первый столбец (по сути массив) на 280 значений (в данной ситуации алфавитный указатель государств).
Во втором столбце пишутся наименования государства в произвольном порядке (но точно такое же наименование, как в первом столбце таблицы).
В третьем столбце нужно вывести список стран, который не был указан во втором столбце.

Возможно ли такое вообще осуществить, ибо через оператор "ЕСЛИ" слишком долго делать, и плюс ограничение на количество значений. Может есть какое-либо оптимальное решение.

Благодарю вас за ответ.
К сообщению приложен файл: 9542727.xlsx(16Kb)


Сообщение отредактировал anatoliusfl - Пятница, 07.07.2017, 15:06
 
Ответить
СообщениеЗдравствуйте. Нужна такая помощь при проработке программы, ибо мои навыки в экселе на примитивном уровне.

Есть таблица, первый столбец (по сути массив) на 280 значений (в данной ситуации алфавитный указатель государств).
Во втором столбце пишутся наименования государства в произвольном порядке (но точно такое же наименование, как в первом столбце таблицы).
В третьем столбце нужно вывести список стран, который не был указан во втором столбце.

Возможно ли такое вообще осуществить, ибо через оператор "ЕСЛИ" слишком долго делать, и плюс ограничение на количество значений. Может есть какое-либо оптимальное решение.

Благодарю вас за ответ.

Автор - anatoliusfl
Дата добавления - 07.07.2017 в 15:03
vikttur Дата: Пятница, 07.07.2017, 15:13 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

В первом столбце:
Код
=ЕСЛИ(СЧЁТЕСЛИ(D:D;C3)=0;МАКС($A$2:A2)+1)

Результат:
Код
=ЕСЛИОШИБКА(ВПР(СТРОКА(A1);$A$3:$C$244;3;);"")

Предварительно был удален первый знак в значениях столбца С ("как бы пробел" - символ 160)
К сообщению приложен файл: 555.xlsx(20Kb)


Сообщение отредактировал vikttur - Пятница, 07.07.2017, 15:15
 
Ответить
СообщениеВ первом столбце:
Код
=ЕСЛИ(СЧЁТЕСЛИ(D:D;C3)=0;МАКС($A$2:A2)+1)

Результат:
Код
=ЕСЛИОШИБКА(ВПР(СТРОКА(A1);$A$3:$C$244;3;);"")

Предварительно был удален первый знак в значениях столбца С ("как бы пробел" - символ 160)

Автор - vikttur
Дата добавления - 07.07.2017 в 15:13
anatoliusfl Дата: Пятница, 07.07.2017, 15:18 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное вам спасибо, это то, что нужно)
 
Ответить
СообщениеОгромное вам спасибо, это то, что нужно)

Автор - anatoliusfl
Дата добавления - 07.07.2017 в 15:18
pabchek Дата: Пятница, 07.07.2017, 15:19 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 779
Репутация: 173 ±
Замечаний: 0% ±

Excel 2007
Или можно сводной
К сообщению приложен файл: 5344997.xlsx(27Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеИли можно сводной

Автор - pabchek
Дата добавления - 07.07.2017 в 15:19
_Boroda_ Дата: Пятница, 07.07.2017, 15:28 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант без изменений на листе
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$3:C$244;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(D$3:D$244;ПОДСТАВИТЬ(C$3:C$244;" ";))=0;B$3:B$244);СТРОКА(E1)));"")

Задвоения в столбце D красятся красным
К сообщению приложен файл: 9542727_1.xlsx(23Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант без изменений на листе
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$3:C$244;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(D$3:D$244;ПОДСТАВИТЬ(C$3:C$244;" ";))=0;B$3:B$244);СТРОКА(E1)));"")

Задвоения в столбце D красятся красным

Автор - _Boroda_
Дата добавления - 07.07.2017 в 15:28
anatoliusfl Дата: Пятница, 07.07.2017, 15:35 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Задвоения сделаны через условное форматирование?
 
Ответить
СообщениеЗадвоения сделаны через условное форматирование?

Автор - anatoliusfl
Дата добавления - 07.07.2017 в 15:35
_Boroda_ Дата: Пятница, 07.07.2017, 15:44 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ага


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАга

Автор - _Boroda_
Дата добавления - 07.07.2017 в 15:44
anatoliusfl Дата: Пятница, 07.07.2017, 15:48 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное спасибо тем, кто отписался. Все замечательно работает.
 
Ответить
СообщениеОгромное спасибо тем, кто отписался. Все замечательно работает.

Автор - anatoliusfl
Дата добавления - 07.07.2017 в 15:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Работа с массивом и исключением (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!