Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух таблиц (Формулы/Formulas)
Сравнение двух таблиц
lenacia Дата: Вторник, 11.07.2017, 08:24 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 83
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Подскажите, пожалуйста, можно ли в экселе сделать сверку (подозреваю что можно, но я не могу понять как). Мне необходимо сравнить две таблицы, правую и левую.
Суть в том, что мне нужно знать:
1. все ли номера документов из таблицы справа есть в таблице слева
2. сверить даты актов
3. сверить грузополучателя.
В правой таблице каждый номер документа идет двумя строчками. В левой таблице каждый номер документа по одной строке. Вот у меня возникли трудности со сверкой. Подскажите мне как лучше сверить эти данные.
К сообщению приложен файл: 9208502.xls(37Kb)


Сообщение отредактировал lenacia - Вторник, 11.07.2017, 08:47
 
Ответить
СообщениеДобрый день. Подскажите, пожалуйста, можно ли в экселе сделать сверку (подозреваю что можно, но я не могу понять как). Мне необходимо сравнить две таблицы, правую и левую.
Суть в том, что мне нужно знать:
1. все ли номера документов из таблицы справа есть в таблице слева
2. сверить даты актов
3. сверить грузополучателя.
В правой таблице каждый номер документа идет двумя строчками. В левой таблице каждый номер документа по одной строке. Вот у меня возникли трудности со сверкой. Подскажите мне как лучше сверить эти данные.

Автор - lenacia
Дата добавления - 11.07.2017 в 08:24
pabchek Дата: Вторник, 11.07.2017, 09:29 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 745
Репутация: 168 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Так надо? Формула массива
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(B2&C2&F2;$I$2:$I$22&$J$2:$J$22&K2:K22;0));"нет совпадений";"есть совпадение")
К сообщению приложен файл: 0416533.xls(36Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте. Так надо? Формула массива
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(B2&C2&F2;$I$2:$I$22&$J$2:$J$22&K2:K22;0));"нет совпадений";"есть совпадение")

Автор - pabchek
Дата добавления - 11.07.2017 в 09:29
_Boroda_ Дата: Вторник, 11.07.2017, 09:29 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не совсем понял, так хотели?
Код
=СЧЁТЕСЛИМН(B$2:B$22;I2;C$2:C$22;J2;F$2:F$22;K2)
К сообщению приложен файл: 9208502_1.xls(46Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе совсем понял, так хотели?
Код
=СЧЁТЕСЛИМН(B$2:B$22;I2;C$2:C$22;J2;F$2:F$22;K2)

Автор - _Boroda_
Дата добавления - 11.07.2017 в 09:29
lenacia Дата: Вторник, 11.07.2017, 12:43 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 83
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо.
А подскажите пожалуйста, еще по этой таблице.
Есть такая формула, которая выделить номера заказов которых нет в таблице слева? + также мне нужно знать какие заказы не совпадают по датам.
К сообщению приложен файл: 5123304.xls(48Kb)
 
Ответить
СообщениеСпасибо.
А подскажите пожалуйста, еще по этой таблице.
Есть такая формула, которая выделить номера заказов которых нет в таблице слева? + также мне нужно знать какие заказы не совпадают по датам.

Автор - lenacia
Дата добавления - 11.07.2017 в 12:43
_Boroda_ Дата: Вторник, 11.07.2017, 13:02 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Смотрите Условное форматирование. Для каждого из диапазонов своя формула
К сообщению приложен файл: 5123304_1.xlsx(17Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСмотрите Условное форматирование. Для каждого из диапазонов своя формула

Автор - _Boroda_
Дата добавления - 11.07.2017 в 13:02
sboy Дата: Вторник, 11.07.2017, 13:25 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 917
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
Еще вариант формул в УФ
Код
=ЕНД(ПОИСКПОЗ(B2;$I$2:$I$22;))

Код
=ЕНД(ПОИСКПОЗ(B2&C2;$I$2:$I$22&$J$2:$J$22;))-ЕНД(ПОИСКПОЗ(B2;$I$2:$I$22;))
К сообщению приложен файл: 2415930.xls(50Kb)
 
Ответить
СообщениеЕще вариант формул в УФ
Код
=ЕНД(ПОИСКПОЗ(B2;$I$2:$I$22;))

Код
=ЕНД(ПОИСКПОЗ(B2&C2;$I$2:$I$22&$J$2:$J$22;))-ЕНД(ПОИСКПОЗ(B2;$I$2:$I$22;))

Автор - sboy
Дата добавления - 11.07.2017 в 13:25
lenacia Дата: Вторник, 11.07.2017, 16:50 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 83
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо! Буду пробовать!
 
Ответить
СообщениеСпасибо! Буду пробовать!

Автор - lenacia
Дата добавления - 11.07.2017 в 16:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух таблиц (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!