Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по 2 условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по 2 условиям (Формулы/Formulas)
Поиск значения по 2 условиям
heaven33rus Дата: Вторник, 11.07.2017, 13:24 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Приветствую!
Есть табличка в которой имеются столбец с перечнем работ и строка с кварталами и годами, соответственно на пересечении каждой строки и столбца таблица содержит некий индекс.
Нужно чтобы в оранжевой ячейке стояла формула которая сначала проверяет какой квартал указан в зеленой ячейке C16,потом какой тип работ указан в желтой ячейке A20 и подставляла нужный индекс.
К сообщению приложен файл: 5571908.xlsx(11Kb)


Сообщение отредактировал heaven33rus - Вторник, 11.07.2017, 14:39
 
Ответить
СообщениеПриветствую!
Есть табличка в которой имеются столбец с перечнем работ и строка с кварталами и годами, соответственно на пересечении каждой строки и столбца таблица содержит некий индекс.
Нужно чтобы в оранжевой ячейке стояла формула которая сначала проверяет какой квартал указан в зеленой ячейке C16,потом какой тип работ указан в желтой ячейке A20 и подставляла нужный индекс.

Автор - heaven33rus
Дата добавления - 11.07.2017 в 13:24
vikttur Дата: Вторник, 11.07.2017, 13:28 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2387
Репутация: 412 ±
Замечаний: 0% ±

подозреваю, что массива

А если ошибаетесь? Измените название темы, отразите там суть задачи, а не Ваше видение решения. Формула простая.
Код
=ВПР(A20;A4:N8;ПОИСКПОЗ(C16;A2:N2;);)


Сообщение отредактировал vikttur - Вторник, 11.07.2017, 15:27
 
Ответить
Сообщение
подозреваю, что массива

А если ошибаетесь? Измените название темы, отразите там суть задачи, а не Ваше видение решения. Формула простая.
Код
=ВПР(A20;A4:N8;ПОИСКПОЗ(C16;A2:N2;);)

Автор - vikttur
Дата добавления - 11.07.2017 в 13:28
sboy Дата: Вторник, 11.07.2017, 13:30 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 913
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
heaven33rus, Добрый день.
Исправьте замечание, решение есть не массивной формулой.
 
Ответить
Сообщениеheaven33rus, Добрый день.
Исправьте замечание, решение есть не массивной формулой.

Автор - sboy
Дата добавления - 11.07.2017 в 13:30
heaven33rus Дата: Вторник, 11.07.2017, 14:40 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
vikttur, sboy, Исправил.
 
Ответить
Сообщениеvikttur, sboy, Исправил.

Автор - heaven33rus
Дата добавления - 11.07.2017 в 14:40
sboy Дата: Вторник, 11.07.2017, 14:42 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 913
Репутация: 236 ±
Замечаний: 0% ±

Excel 2010
Проверяйте
Код
=ИНДЕКС(C4:N8;ПОИСКПОЗ(A20;A4:A8;);ПОИСКПОЗ(C16;C2:N2;))
К сообщению приложен файл: 3019891.xlsx(11Kb)
 
Ответить
СообщениеПроверяйте
Код
=ИНДЕКС(C4:N8;ПОИСКПОЗ(A20;A4:A8;);ПОИСКПОЗ(C16;C2:N2;))

Автор - sboy
Дата добавления - 11.07.2017 в 14:42
_Boroda_ Дата: Вторник, 11.07.2017, 14:47 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11269
Репутация: 4656 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ИНДЕКС(C4:N8;ПОИСКПОЗ(A20;A4:A8;);ПОИСКПОЗ(C16;C2:N2;))

Код
=ВПР(A20;A4:N8;ПОИСКПОЗ(C16;A2:N2;);)

Код
=ГПР(C16;A2:N8;ПОИСКПОЗ(A20;A2:A8;))

Код
=СУММПРОИЗВ(C4:N8*(A4:A8=A20)*(C2:N2=C16))

Код
=МУМНОЖ(МУМНОЖ(--ТРАНСП(A4:A8=A20);C4:N8);--ТРАНСП(C2:N2=C16))

Код
=БДСУММ(A2:N8;C16;A19:A20)

Последняя с некоторыми дополнениями на листе (выделено синим)
К сообщению приложен файл: 5571908_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ИНДЕКС(C4:N8;ПОИСКПОЗ(A20;A4:A8;);ПОИСКПОЗ(C16;C2:N2;))

Код
=ВПР(A20;A4:N8;ПОИСКПОЗ(C16;A2:N2;);)

Код
=ГПР(C16;A2:N8;ПОИСКПОЗ(A20;A2:A8;))

Код
=СУММПРОИЗВ(C4:N8*(A4:A8=A20)*(C2:N2=C16))

Код
=МУМНОЖ(МУМНОЖ(--ТРАНСП(A4:A8=A20);C4:N8);--ТРАНСП(C2:N2=C16))

Код
=БДСУММ(A2:N8;C16;A19:A20)

Последняя с некоторыми дополнениями на листе (выделено синим)

Автор - _Boroda_
Дата добавления - 11.07.2017 в 14:47
heaven33rus Дата: Вторник, 11.07.2017, 15:57 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
На любой вкус и цвет...
sboy, _Boroda_, Спасибо!!!!
 
Ответить
СообщениеНа любой вкус и цвет...
sboy, _Boroda_, Спасибо!!!!

Автор - heaven33rus
Дата добавления - 11.07.2017 в 15:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по 2 условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!