Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по блокам с учетом цвета ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по блокам с учетом цвета ячеек (Формулы/Formulas)
Суммирование по блокам с учетом цвета ячеек
Skittish Дата: Четверг, 13.07.2017, 11:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток. Не знаю возможно ли такое в экселе реализовать но спрошу.
Есть блоки данных которые разделены цветными строчками, есть ли какая то возможность выводить сумму только для этих блоков?
Описание канеш сумбурное, пример прилагаю.
И формулу если больше или равно 3 то 1, если меньше то 0.
Код
=ЕСЛИ(RC[1]>3;1;0)

Не знаю как поставить или равно=(
К сообщению приложен файл: 0239849.xlsx(12Kb)


Сообщение отредактировал Skittish - Четверг, 13.07.2017, 11:23
 
Ответить
СообщениеДоброго времени суток. Не знаю возможно ли такое в экселе реализовать но спрошу.
Есть блоки данных которые разделены цветными строчками, есть ли какая то возможность выводить сумму только для этих блоков?
Описание канеш сумбурное, пример прилагаю.
И формулу если больше или равно 3 то 1, если меньше то 0.
Код
=ЕСЛИ(RC[1]>3;1;0)

Не знаю как поставить или равно=(

Автор - Skittish
Дата добавления - 13.07.2017 в 11:19
_Boroda_ Дата: Четверг, 13.07.2017, 11:21 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Формулу нужно сувать в спецтеги - кнопочка Fx
Исправьте свой пост


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормулу нужно сувать в спецтеги - кнопочка Fx
Исправьте свой пост

Автор - _Boroda_
Дата добавления - 13.07.2017 в 11:21
Skittish Дата: Четверг, 13.07.2017, 11:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
прошу прощения. упустила этот момент
 
Ответить
Сообщениепрошу прощения. упустила этот момент

Автор - Skittish
Дата добавления - 13.07.2017 в 11:23
_Boroda_ Дата: Четверг, 13.07.2017, 11:26 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(C1;"";СУММ(C1:C99)-СУММ(D2:D99))

===
Вы про >= спрашиваете?
К сообщению приложен файл: 0239849_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(C1;"";СУММ(C1:C99)-СУММ(D2:D99))

===
Вы про >= спрашиваете?

Автор - _Boroda_
Дата добавления - 13.07.2017 в 11:26
Skittish Дата: Четверг, 13.07.2017, 11:32 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Вы про >= спрашиваете?

походу да, я просто думала может второе выражение писать надо или еще что, а все так просто)

а насчет таблички. а привязку к цвету никак сделать нельзя?
а то в той ячейке сумма и получается после выгрузки из программы.
просто нужно как раз чтоб она ее в соседнюю колонку выносила
 
Ответить
Сообщение
Вы про >= спрашиваете?

походу да, я просто думала может второе выражение писать надо или еще что, а все так просто)

а насчет таблички. а привязку к цвету никак сделать нельзя?
а то в той ячейке сумма и получается после выгрузки из программы.
просто нужно как раз чтоб она ее в соседнюю колонку выносила

Автор - Skittish
Дата добавления - 13.07.2017 в 11:32
_Boroda_ Дата: Четверг, 13.07.2017, 11:33 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
привязку к цвету никак сделать нельзя?

Льзя, но только макросом.
Приложите кусок реального файла. Это из 1С выгрузка?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
привязку к цвету никак сделать нельзя?

Льзя, но только макросом.
Приложите кусок реального файла. Это из 1С выгрузка?

Автор - _Boroda_
Дата добавления - 13.07.2017 в 11:33
Skittish Дата: Четверг, 13.07.2017, 11:43 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да 1С сырой..
Месяц вручную считала, но уже устала каждый день одно и тоже. массивы информации от 1,5 до 4,5к строк в конце месяца..
Вот решила удачи с экселем попытать
К сообщению приложен файл: _2.xls(36Kb)


Сообщение отредактировал Skittish - Четверг, 13.07.2017, 11:43
 
Ответить
СообщениеДа 1С сырой..
Месяц вручную считала, но уже устала каждый день одно и тоже. массивы информации от 1,5 до 4,5к строк в конце месяца..
Вот решила удачи с экселем попытать

Автор - Skittish
Дата добавления - 13.07.2017 в 11:43
_Boroda_ Дата: Четверг, 13.07.2017, 11:57 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Держите макросом
tsts_(что_проверяем;с_чем_сравниваем_цвет;что_пишем_если_не_совпадает)
[vba]
Код
Function tsts_(d1_ As Range, d2_ As Range, ne_)
    If d1_.Interior.Color = d2_.Interior.Color Then
        tsts_ = d1_.Value
    Else
        tsts_ = ne_
    End If
End Function
[/vba]
Почитайте еще здесь
http://www.excelworld.ru/publ/funcs/udf/udf/28-1-0-77
К сообщению приложен файл: _2-5-1.xls(53Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДержите макросом
tsts_(что_проверяем;с_чем_сравниваем_цвет;что_пишем_если_не_совпадает)
[vba]
Код
Function tsts_(d1_ As Range, d2_ As Range, ne_)
    If d1_.Interior.Color = d2_.Interior.Color Then
        tsts_ = d1_.Value
    Else
        tsts_ = ne_
    End If
End Function
[/vba]
Почитайте еще здесь
http://www.excelworld.ru/publ/funcs/udf/udf/28-1-0-77

Автор - _Boroda_
Дата добавления - 13.07.2017 в 11:57
Skittish Дата: Четверг, 13.07.2017, 12:01 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
а что нужно изменить чтоб он для суммы брал цифры из столбца G? в С оно и так посчитано

если что то в ф унции меняю возникает ошибка #ИМЯ?


Сообщение отредактировал Skittish - Четверг, 13.07.2017, 12:04
 
Ответить
Сообщениеа что нужно изменить чтоб он для суммы брал цифры из столбца G? в С оно и так посчитано

если что то в ф унции меняю возникает ошибка #ИМЯ?

Автор - Skittish
Дата добавления - 13.07.2017 в 12:01
Skittish Дата: Четверг, 13.07.2017, 12:07 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
и может еще подскажете где можно про основы макросов почитать для чайников? чтоб понимать что там написано, а то все эти иф и элсе.. темный лес
 
Ответить
Сообщениеи может еще подскажете где можно про основы макросов почитать для чайников? чтоб понимать что там написано, а то все эти иф и элсе.. темный лес

Автор - Skittish
Дата добавления - 13.07.2017 в 12:07
_Boroda_ Дата: Четверг, 13.07.2017, 12:08 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для G вполне достаточно формулы
Код
=ЕСЛИ(G3+G4;"";СУММ(G3:G99)-СУММ(H4:H99))
К сообщению приложен файл: _2-5-2.xls(48Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля G вполне достаточно формулы
Код
=ЕСЛИ(G3+G4;"";СУММ(G3:G99)-СУММ(H4:H99))

Автор - _Boroda_
Дата добавления - 13.07.2017 в 12:08
Skittish Дата: Четверг, 13.07.2017, 12:22 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
я вот сейчас как раз над этим думала там же в любом случае 2 пустых ячейки

по сути это если ж3+ж4 равно 0 то считается сумма ж3:ж99?
а вот суть Н не поняла=(

извините что внесла непонятки. просто сама сразу не смогла правильно понять и придумать как это оформить

спасибо большое вам
 
Ответить
Сообщениея вот сейчас как раз над этим думала там же в любом случае 2 пустых ячейки

по сути это если ж3+ж4 равно 0 то считается сумма ж3:ж99?
а вот суть Н не поняла=(

извините что внесла непонятки. просто сама сразу не смогла правильно понять и придумать как это оформить

спасибо большое вам

Автор - Skittish
Дата добавления - 13.07.2017 в 12:22
_Boroda_ Дата: Четверг, 13.07.2017, 12:25 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так что, получилось?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак что, получилось?

Автор - _Boroda_
Дата добавления - 13.07.2017 в 12:25
Skittish Дата: Четверг, 13.07.2017, 12:54 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
иногда минусовые числа выскакивают. почему так может быть?

я прост пробовала сразу на большой массив данных


Сообщение отредактировал Skittish - Четверг, 13.07.2017, 12:54
 
Ответить
Сообщениеиногда минусовые числа выскакивают. почему так может быть?

я прост пробовала сразу на большой массив данных

Автор - Skittish
Дата добавления - 13.07.2017 в 12:54
Skittish Дата: Четверг, 13.07.2017, 13:02 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
на большом количестве инфы сбивается почему то=( причем изначально дает не правильные суммы
а когда малые объемы то все хорошо
чертовщина какая то

если строк меньше 100 то все хорошо, а если хотя б 600 то уже все криво


Сообщение отредактировал Skittish - Четверг, 13.07.2017, 13:04
 
Ответить
Сообщениена большом количестве инфы сбивается почему то=( причем изначально дает не правильные суммы
а когда малые объемы то все хорошо
чертовщина какая то

если строк меньше 100 то все хорошо, а если хотя б 600 то уже все криво

Автор - Skittish
Дата добавления - 13.07.2017 в 13:02
and_evg Дата: Четверг, 13.07.2017, 13:13 | Сообщение № 16
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 34 ±
Замечаний: 0% ±

Excel 2007
Skittish, в формуле у _Boroda_, Диапазон G99 и H99 во внимание принимали? и изменяли на свои 6600 строк?
 
Ответить
СообщениеSkittish, в формуле у _Boroda_, Диапазон G99 и H99 во внимание принимали? и изменяли на свои 6600 строк?

Автор - and_evg
Дата добавления - 13.07.2017 в 13:13
Skittish Дата: Четверг, 13.07.2017, 13:15 | Сообщение № 17
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
когда растягиваю он автоматом увеличивает диапазон
Код
=ЕСЛИ(G649+G650;"";СУММ(G649:G745)-СУММ(H650:H745))


думала тоже в этом дело но посмотрела вроде все верно указано


Сообщение отредактировал Skittish - Четверг, 13.07.2017, 13:16
 
Ответить
Сообщениекогда растягиваю он автоматом увеличивает диапазон
Код
=ЕСЛИ(G649+G650;"";СУММ(G649:G745)-СУММ(H650:H745))


думала тоже в этом дело но посмотрела вроде все верно указано

Автор - Skittish
Дата добавления - 13.07.2017 в 13:15
and_evg Дата: Четверг, 13.07.2017, 13:22 | Сообщение № 18
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 34 ±
Замечаний: 0% ±

Excel 2007
Skittish, извиняюсь за предыдущий пост, не внимательно посмотрел формулу от _Boroda_,
 
Ответить
СообщениеSkittish, извиняюсь за предыдущий пост, не внимательно посмотрел формулу от _Boroda_,

Автор - and_evg
Дата добавления - 13.07.2017 в 13:22
_Boroda_ Дата: Четверг, 13.07.2017, 13:23 | Сообщение № 19
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Напишите так
Код
=ЕСЛИ(G3+G4;"";СУММ(G3:G$9999)-СУММ(H4:H$9999))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНапишите так
Код
=ЕСЛИ(G3+G4;"";СУММ(G3:G$9999)-СУММ(H4:H$9999))

Автор - _Boroda_
Дата добавления - 13.07.2017 в 13:23
Skittish Дата: Четверг, 13.07.2017, 13:27 | Сообщение № 20
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
да помогло) спасибочки
а если будет 3 пустых строки то это все собьет?
 
Ответить
Сообщениеда помогло) спасибочки
а если будет 3 пустых строки то это все собьет?

Автор - Skittish
Дата добавления - 13.07.2017 в 13:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по блокам с учетом цвета ячеек (Формулы/Formulas)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!