Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка по дате - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по дате (Формулы/Formulas)
Выборка по дате
forall Дата: Суббота, 09.09.2017, 01:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Ночи доброй! Подскажите как можно сделать выборку по дате из таблицы в приложении?

Нужно чтобы при вводе даты в желтое поле, в табличке справа отображалась выборка соответствующих значений заголовков из календаря по этой дате.. Какт так.. В примере вроде наглядно понятней)..
К сообщению приложен файл: 7193475.xlsx(9Kb)


Сообщение отредактировал forall - Суббота, 09.09.2017, 02:19
 
Ответить
СообщениеНочи доброй! Подскажите как можно сделать выборку по дате из таблицы в приложении?

Нужно чтобы при вводе даты в желтое поле, в табличке справа отображалась выборка соответствующих значений заголовков из календаря по этой дате.. Какт так.. В примере вроде наглядно понятней)..

Автор - forall
Дата добавления - 09.09.2017 в 01:40
vikttur Дата: Суббота, 09.09.2017, 01:53 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2521
Репутация: 452 ±
Замечаний: 0% ±

Для одного наряда может быть две одинаковые даты?

Без повторов - см. вариант с доп. строкой в файле
Код
=ЕСЛИ(СЧЁТЕСЛИ(B3:B7;$A$12);МАКС($A$1:A1)+1)

Код
=ЕСЛИ(B14="";"";ГПР(B14;$B$1:$E$7;2;))

Код
=ЕСЛИ(B13="";"";ИНДЕКС($A$3:$A$7;ПОИСКПОЗ($A$12;ИНДЕКС($B$3:$E$7;;ПОИСКПОЗ(C13;$B$2:$E$2;));)))
К сообщению приложен файл: 6127822.xlsx(10Kb)
 
Ответить
СообщениеДля одного наряда может быть две одинаковые даты?

Без повторов - см. вариант с доп. строкой в файле
Код
=ЕСЛИ(СЧЁТЕСЛИ(B3:B7;$A$12);МАКС($A$1:A1)+1)

Код
=ЕСЛИ(B14="";"";ГПР(B14;$B$1:$E$7;2;))

Код
=ЕСЛИ(B13="";"";ИНДЕКС($A$3:$A$7;ПОИСКПОЗ($A$12;ИНДЕКС($B$3:$E$7;;ПОИСКПОЗ(C13;$B$2:$E$2;));)))

Автор - vikttur
Дата добавления - 09.09.2017 в 01:53
forall Дата: Суббота, 09.09.2017, 02:08 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Не учел :(
Для одного наряда может быть одна дата с разными исполнителями..
 
Ответить
СообщениеНе учел :(
Для одного наряда может быть одна дата с разными исполнителями..

Автор - forall
Дата добавления - 09.09.2017 в 02:08
forall Дата: Суббота, 09.09.2017, 02:14 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
А вот больше одного наряда на исполнителя в одну дату не будет.. я ошибся в примере с Зозо.. исправил уже..


Сообщение отредактировал forall - Суббота, 09.09.2017, 02:16
 
Ответить
СообщениеА вот больше одного наряда на исполнителя в одну дату не будет.. я ошибся в примере с Зозо.. исправил уже..

Автор - forall
Дата добавления - 09.09.2017 в 02:14
forall Дата: Суббота, 09.09.2017, 02:38 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
У меня получилось сделать то, что надо через сводную таблицу, но необходимо защитить лист от нетуданажатия других людей, а данные в сводной не обновляются после блокировки..

Ну да, скрыть сводную на отдельном листе, а рабочий под защиту. Но все-равно, может у кого-то будут варианты на формулах, интересно прост как еще можно)..


Сообщение отредактировал forall - Суббота, 09.09.2017, 02:47
 
Ответить
СообщениеУ меня получилось сделать то, что надо через сводную таблицу, но необходимо защитить лист от нетуданажатия других людей, а данные в сводной не обновляются после блокировки..

Ну да, скрыть сводную на отдельном листе, а рабочий под защиту. Но все-равно, может у кого-то будут варианты на формулах, интересно прост как еще можно)..

Автор - forall
Дата добавления - 09.09.2017 в 02:38
gling Дата: Суббота, 09.09.2017, 14:09 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1657
Репутация: 404 ±
Замечаний: 0% ±

2010
варианты на формулах
К сообщению приложен файл: 2624460.xlsx(11Kb)


ЯД-41001506838083
 
Ответить
Сообщение
варианты на формулах

Автор - gling
Дата добавления - 09.09.2017 в 14:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по дате (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!