Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных с отдой книги в другую с "Если". - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных с отдой книги в другую с "Если". (Формулы/Formulas)
Перенос данных с отдой книги в другую с "Если".
Ivan2809 Дата: Понедельник, 11.09.2017, 13:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Подскажите пожалуйста может кто-то встречался с подобной ситуацией. Есть два документа, в одном будет список сотрудников которые были устроены в организацию,а в другом будет производится расчет заработной платы. Нам необходимо что бы в таблицу расчета зп попадали по порядку только те сотрудники у кого статс "уволен" отсутствует. По написанной мною формуле сотрудник переносит два раза. Ни как не могу разобраться как это сделать.
К сообщению приложен файл: 8285173.xlsx(10Kb) · ___.xlsx(12Kb)
 
Ответить
СообщениеДобрый день. Подскажите пожалуйста может кто-то встречался с подобной ситуацией. Есть два документа, в одном будет список сотрудников которые были устроены в организацию,а в другом будет производится расчет заработной платы. Нам необходимо что бы в таблицу расчета зп попадали по порядку только те сотрудники у кого статс "уволен" отсутствует. По написанной мною формуле сотрудник переносит два раза. Ни как не могу разобраться как это сделать.

Автор - Ivan2809
Дата добавления - 11.09.2017 в 13:26
Ivan2809 Дата: Понедельник, 11.09.2017, 13:28 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Может конечно есть и другой вариант, не пользуясь функцией "Если", но я его не знаю.
 
Ответить
СообщениеМожет конечно есть и другой вариант, не пользуясь функцией "Если", но я его не знаю.

Автор - Ivan2809
Дата добавления - 11.09.2017 в 13:28
китин Дата: Понедельник, 11.09.2017, 13:34 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4420
Репутация: 698 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
такк? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС([ном1.xlsx]Лист1!$A$5:$A$10;НАИМЕНЬШИЙ(ЕСЛИ([ном1.xlsx]Лист1!$E$5:$E$10<>"Уволен";СТРОКА([ном1.xlsx]Лист1!$A$5:$A$10)-4);СТРОКА(A1)));"")
К сообщению приложен файл: 0194673.xlsx(10Kb) · 9543266.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетакк? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС([ном1.xlsx]Лист1!$A$5:$A$10;НАИМЕНЬШИЙ(ЕСЛИ([ном1.xlsx]Лист1!$E$5:$E$10<>"Уволен";СТРОКА([ном1.xlsx]Лист1!$A$5:$A$10)-4);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 11.09.2017 в 13:34
_Boroda_ Дата: Понедельник, 11.09.2017, 13:40 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11702
Репутация: 4839 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Почти такой же вариант
Код
=ИНДЕКС([Сотрудники.xlsx]Лист1!$A:$A;НАИМЕНЬШИЙ(ЕСЛИ([Сотрудники.xlsx]Лист1!E$5:E$999="";СТРОКА([Сотрудники.xlsx]Лист1!A$5:A$999));A7))&""

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: -17-1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПочти такой же вариант
Код
=ИНДЕКС([Сотрудники.xlsx]Лист1!$A:$A;НАИМЕНЬШИЙ(ЕСЛИ([Сотрудники.xlsx]Лист1!E$5:E$999="";СТРОКА([Сотрудники.xlsx]Лист1!A$5:A$999));A7))&""

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 11.09.2017 в 13:40
vikttur Дата: Понедельник, 11.09.2017, 13:58 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2521
Репутация: 452 ±
Замечаний: 0% ±

Совсем не такой вариант )
Доп. столбец для отпределения нужных строк:
Код
=ЕСЛИ(СТРОКА(A1)>$A$5;"";СТРОКА(A1))

Извлечение:
Код
=ЕСЛИ($A6="";"";ВПР($A6;[8285173.xlsx]Лист1!$A$5:$G$10;2;))
К сообщению приложен файл: 9395572.rar(17Kb)
 
Ответить
СообщениеСовсем не такой вариант )
Доп. столбец для отпределения нужных строк:
Код
=ЕСЛИ(СТРОКА(A1)>$A$5;"";СТРОКА(A1))

Извлечение:
Код
=ЕСЛИ($A6="";"";ВПР($A6;[8285173.xlsx]Лист1!$A$5:$G$10;2;))

Автор - vikttur
Дата добавления - 11.09.2017 в 13:58
Ivan2809 Дата: Понедельник, 11.09.2017, 13:59 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Именно так и надо было. Вы реально гении. Только есть одна просьба. Вы можете мне простому смертному объяснить как это работает.
 
Ответить
Сообщение_Boroda_, Именно так и надо было. Вы реально гении. Только есть одна просьба. Вы можете мне простому смертному объяснить как это работает.

Автор - Ivan2809
Дата добавления - 11.09.2017 в 13:59
_Boroda_ Дата: Понедельник, 11.09.2017, 14:24 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11702
Репутация: 4839 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня сегодня день объяснялок :D

1. ЕСЛИ([Сотрудники.xlsx]Лист1!E$5:E$999="";СТРОКА([Сотрудники.xlsx]Лист1!A$5:A$999)) - даст нам массив из 999-5+1=995 записей, в котором: если ячейка диапазона E$5:E$999 пуста (человек не уволен), то запишется номер строки, а если не пуста (уволен), то запишется "ЛОЖЬ"
2. НАИМЕНЬШИЙ(п.1 ;A7) - из диапазона, полученного в п.1, выбираем по порядку для первой строки итоговой таблицы - 1-й наименьший, для второй - 2-й наименьший, ... Это будут номера строк, которые нам понадобятся для п.3
3. ИНДЕКС([Сотрудники.xlsx]Лист1!$A:$A; п.2) - выковыриваем из столбца А то, что мы нашли для каждой из строк в п.2
4. &"" - если пошли уже не фамилии (кончились они), а пустые ячейки, то Excel вместо них будет писать 0. Чтобы он этого не делал, мы к пусто приклеиваем еще одно пусто, тогда Excel понимает, что это действительно пусто, а не ноль


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня сегодня день объяснялок :D

1. ЕСЛИ([Сотрудники.xlsx]Лист1!E$5:E$999="";СТРОКА([Сотрудники.xlsx]Лист1!A$5:A$999)) - даст нам массив из 999-5+1=995 записей, в котором: если ячейка диапазона E$5:E$999 пуста (человек не уволен), то запишется номер строки, а если не пуста (уволен), то запишется "ЛОЖЬ"
2. НАИМЕНЬШИЙ(п.1 ;A7) - из диапазона, полученного в п.1, выбираем по порядку для первой строки итоговой таблицы - 1-й наименьший, для второй - 2-й наименьший, ... Это будут номера строк, которые нам понадобятся для п.3
3. ИНДЕКС([Сотрудники.xlsx]Лист1!$A:$A; п.2) - выковыриваем из столбца А то, что мы нашли для каждой из строк в п.2
4. &"" - если пошли уже не фамилии (кончились они), а пустые ячейки, то Excel вместо них будет писать 0. Чтобы он этого не делал, мы к пусто приклеиваем еще одно пусто, тогда Excel понимает, что это действительно пусто, а не ноль

Автор - _Boroda_
Дата добавления - 11.09.2017 в 14:24
Ivan2809 Дата: Понедельник, 11.09.2017, 15:34 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Что-то не работает формула у меня. Выдает в ячейке знач! и всё.
 
Ответить
Сообщение_Boroda_, Что-то не работает формула у меня. Выдает в ячейке знач! и всё.

Автор - Ivan2809
Дата добавления - 11.09.2017 в 15:34
_Boroda_ Дата: Понедельник, 11.09.2017, 15:42 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11702
Репутация: 4839 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вторая книга открыта?
Вводите Вы формулу так, как я написал
Вводится одновременным нажатием Контрл Шифт Ентер
?
Если оба ответа "Да", то покажите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВторая книга открыта?
Вводите Вы формулу так, как я написал
Вводится одновременным нажатием Контрл Шифт Ентер
?
Если оба ответа "Да", то покажите

Автор - _Boroda_
Дата добавления - 11.09.2017 в 15:42
Ivan2809 Дата: Понедельник, 11.09.2017, 15:55 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_,
К сообщению приложен файл: 5116778.xlsx(81Kb) · 6024152.xlsx(40Kb)
 
Ответить
Сообщение_Boroda_,

Автор - Ivan2809
Дата добавления - 11.09.2017 в 15:55
Pelena Дата: Понедельник, 11.09.2017, 16:08 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11769
Репутация: 2599 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
У Вас там циклическая ссылка. Посмотрите в формуле в конце должно быть A7, а у Вас B7. Поэтому ячейка ссылается сама на себя


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ Вас там циклическая ссылка. Посмотрите в формуле в конце должно быть A7, а у Вас B7. Поэтому ячейка ссылается сама на себя

Автор - Pelena
Дата добавления - 11.09.2017 в 16:08
Ivan2809 Дата: Понедельник, 11.09.2017, 18:19 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Спасибо, увидел, исправил. В первой ячейке формула работает, протянул ниже выдает ошибку #Число!Вообще ни чего не понимаю. Видимо мой случай совсем безнадежен. %)
 
Ответить
СообщениеPelena, Спасибо, увидел, исправил. В первой ячейке формула работает, протянул ниже выдает ошибку #Число!Вообще ни чего не понимаю. Видимо мой случай совсем безнадежен. %)

Автор - Ivan2809
Дата добавления - 11.09.2017 в 18:19
Pelena Дата: Понедельник, 11.09.2017, 18:42 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11769
Репутация: 2599 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
У Вас в столбце А какие-то непонятные числа. Продлите номера по-порядку до конца. Или добавьте ЕСЛИОШИБКА()
Код
=ЕСЛИОШИБКА(ИНДЕКС([Сотрудники.xlsx]Лист1!$B:$B;НАИМЕНЬШИЙ(ЕСЛИ([Сотрудники.xlsx]Лист1!P$5:P$999="";СТРОКА([Сотрудники.xlsx]Лист1!B$5:B$999));A7));"")&""


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ Вас в столбце А какие-то непонятные числа. Продлите номера по-порядку до конца. Или добавьте ЕСЛИОШИБКА()
Код
=ЕСЛИОШИБКА(ИНДЕКС([Сотрудники.xlsx]Лист1!$B:$B;НАИМЕНЬШИЙ(ЕСЛИ([Сотрудники.xlsx]Лист1!P$5:P$999="";СТРОКА([Сотрудники.xlsx]Лист1!B$5:B$999));A7));"")&""

Автор - Pelena
Дата добавления - 11.09.2017 в 18:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных с отдой книги в другую с "Если". (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!