Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт заполненных ячеек по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт заполненных ячеек по условию (Формулы/Formulas)
Подсчёт заполненных ячеек по условию
Vinkelman Дата: Среда, 13.09.2017, 21:37 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 26 ±
Замечаний: 0% ±

2003 - 2010
Всем привет!
Прошу помочь. Количество прописанных в квартире отмечено "х", надо в соседнем столбце получить их сумму.
Почти три года не работал с Excel, что-то не получается с формулой - см. пример.
К сообщению приложен файл: 7388022.xls(24Kb)
 
Ответить
СообщениеВсем привет!
Прошу помочь. Количество прописанных в квартире отмечено "х", надо в соседнем столбце получить их сумму.
Почти три года не работал с Excel, что-то не получается с формулой - см. пример.

Автор - Vinkelman
Дата добавления - 13.09.2017 в 21:37
Manyasha Дата: Среда, 13.09.2017, 21:44 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1974
Репутация: 817 ±
Замечаний: 0% ±

Excel 2010, 2016
Vinkelman, здравствуйте. Можно в счетесли еще одно условие добавить:
Код
=ЕСЛИ(A2<>A1;СЧЁТЕСЛИМН($B$2:$B$17;B2;$A$2:$A$17;A2);"")
К сообщению приложен файл: 7388022-1.xls(24Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеVinkelman, здравствуйте. Можно в счетесли еще одно условие добавить:
Код
=ЕСЛИ(A2<>A1;СЧЁТЕСЛИМН($B$2:$B$17;B2;$A$2:$A$17;A2);"")

Автор - Manyasha
Дата добавления - 13.09.2017 в 21:44
buchlotnik Дата: Среда, 13.09.2017, 21:44 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3004
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
типа того
Код
=ЕСЛИ(A1<>A2;СЧЁТЕСЛИМН($A$2:$A$17;A2;$B$2:$B$17;"х");"")
или массивка для совместимости с 2003:
Код
=ЕСЛИ(A1<>A2;СЧЁТ(1/($A$2:$A$17=A2)/ЕТЕКСТ($B$2:$B$17));"")
К сообщению приложен файл: 8670967.xls(24Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 13.09.2017, 21:48
 
Ответить
Сообщениетипа того
Код
=ЕСЛИ(A1<>A2;СЧЁТЕСЛИМН($A$2:$A$17;A2;$B$2:$B$17;"х");"")
или массивка для совместимости с 2003:
Код
=ЕСЛИ(A1<>A2;СЧЁТ(1/($A$2:$A$17=A2)/ЕТЕКСТ($B$2:$B$17));"")

Автор - buchlotnik
Дата добавления - 13.09.2017 в 21:44
gling Дата: Среда, 13.09.2017, 21:45 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1621
Репутация: 394 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте так
Код
=ЕСЛИ(A2<>A1;СУММПРОИЗВ(($A$2:$A$17=A2)*($B$2:$B$17=$B$2));"")
Для Excel 2007 и выше можно так
Код
=ЕСЛИ(A2<>A1;СУМЕСЛИМН($A$2:$A$17;A2;$B$2:$B$17;B$2);"")
 
Ответить
СообщениеЗдравствуйте. Попробуйте так
Код
=ЕСЛИ(A2<>A1;СУММПРОИЗВ(($A$2:$A$17=A2)*($B$2:$B$17=$B$2));"")
Для Excel 2007 и выше можно так
Код
=ЕСЛИ(A2<>A1;СУМЕСЛИМН($A$2:$A$17;A2;$B$2:$B$17;B$2);"")

Автор - gling
Дата добавления - 13.09.2017 в 21:45
_Boroda_ Дата: Среда, 13.09.2017, 21:58 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИ(A2<>A1;СЧЁТ(-1/(A2:A$17&B2:B$17=A2&B2));"")

Не, лучше не В2, а "х" - на случай, если в первой строке пусто
Код
=ЕСЛИ(A2<>A1;СЧЁТ(-1/(A2:A$17&B2:B$17=A2&"х"));"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИ(A2<>A1;СЧЁТ(-1/(A2:A$17&B2:B$17=A2&B2));"")

Не, лучше не В2, а "х" - на случай, если в первой строке пусто
Код
=ЕСЛИ(A2<>A1;СЧЁТ(-1/(A2:A$17&B2:B$17=A2&"х"));"")

Автор - _Boroda_
Дата добавления - 13.09.2017 в 21:58
buchlotnik Дата: Среда, 13.09.2017, 22:02 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3004
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
блин,я один ориентировался на то, что в первом вхождении номера квартиры может быть не прописанный?
UPD - Александр с языка снял :)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 13.09.2017, 22:02
 
Ответить
Сообщениеблин,я один ориентировался на то, что в первом вхождении номера квартиры может быть не прописанный?
UPD - Александр с языка снял :)

Автор - buchlotnik
Дата добавления - 13.09.2017 в 22:02
Che79 Дата: Среда, 13.09.2017, 23:48 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 465
Репутация: 73 ±
Замечаний: 0% ±

Excel 2010 RUS
поздно увидел тему...
Вариант, похожий на один из предложенных выше - массивка
Код
{=СУММ(($B$2:$B$17="х")*($A$2:$A$17=A2)*(A1<>A2))}
и формат ячеек 0;;

Добавлено

Ну и еще один вариант массивкой
Код
{=СЧЁТ(ЕСЛИ($B$2:$B$17="х";ЕСЛИ($A$2:$A$17=A2;ЕСЛИ(A1<>A2;))))}
+ скрытие нулей форматом


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 13.09.2017, 23:58
 
Ответить
Сообщениепоздно увидел тему...
Вариант, похожий на один из предложенных выше - массивка
Код
{=СУММ(($B$2:$B$17="х")*($A$2:$A$17=A2)*(A1<>A2))}
и формат ячеек 0;;

Добавлено

Ну и еще один вариант массивкой
Код
{=СЧЁТ(ЕСЛИ($B$2:$B$17="х";ЕСЛИ($A$2:$A$17=A2;ЕСЛИ(A1<>A2;))))}
+ скрытие нулей форматом

Автор - Che79
Дата добавления - 13.09.2017 в 23:48
Nic70y Дата: Четверг, 14.09.2017, 07:51 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4084
Репутация: 872 ±
Замечаний: 0% ±

Excel 2013
для разнообразия
Код
=ЕСЛИ(A2<>A1;СЧЁТЗ(B2:B$18000)-СУММ(C3:C$18000);"")
К сообщению приложен файл: 6578373.xls(26Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениедля разнообразия
Код
=ЕСЛИ(A2<>A1;СЧЁТЗ(B2:B$18000)-СУММ(C3:C$18000);"")

Автор - Nic70y
Дата добавления - 14.09.2017 в 07:51
Vinkelman Дата: Четверг, 14.09.2017, 18:07 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 26 ±
Замечаний: 0% ±

2003 - 2010
Всем большое СПАСИБО!!!
 
Ответить
СообщениеВсем большое СПАСИБО!!!

Автор - Vinkelman
Дата добавления - 14.09.2017 в 18:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт заполненных ячеек по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!