Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание строк по количеству не пустых столбцов в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание строк по количеству не пустых столбцов в таблице (Формулы/Formulas)
Создание строк по количеству не пустых столбцов в таблице
deda Дата: Суббота, 07.10.2017, 20:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день. Подскажите, пожалуйста, решение. Не знаю возможно ли его достичь формулами, но хотелось бы обойтись без макроса.

Есть таблица с постоянными столбцами и с разным количеством дополнительных столбцов. Необходимо значения из дополнительных столбцов перенести в один столбец на новые строки, при этом заполняя пустые строки из постоянной части таблицы.
К сообщению приложен файл: 0805909.xlsx(9Kb)
 
Ответить
СообщениеДобрый день. Подскажите, пожалуйста, решение. Не знаю возможно ли его достичь формулами, но хотелось бы обойтись без макроса.

Есть таблица с постоянными столбцами и с разным количеством дополнительных столбцов. Необходимо значения из дополнительных столбцов перенести в один столбец на новые строки, при этом заполняя пустые строки из постоянной части таблицы.

Автор - deda
Дата добавления - 07.10.2017 в 20:56
_Igor_61 Дата: Суббота, 07.10.2017, 22:02 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 238
Репутация: 44 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте! Проверяйте:
К сообщению приложен файл: 8015604.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте! Проверяйте:

Автор - _Igor_61
Дата добавления - 07.10.2017 в 22:02
deda Дата: Суббота, 07.10.2017, 23:17 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Igor_61, в примере работает, но если у меня таблица на 1000 строк будет - то подобную формулу будет не так легко прописать.
 
Ответить
Сообщение_Igor_61, в примере работает, но если у меня таблица на 1000 строк будет - то подобную формулу будет не так легко прописать.

Автор - deda
Дата добавления - 07.10.2017 в 23:17
ZORRO2005 Дата: Воскресенье, 08.10.2017, 02:39 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 147 ±
Замечаний: 0% ±

Excel2010
... но если у меня таблица на 1000 строк будет - то подобную формулу будет не так легко прописать.

В F11 замените на формулу массива (CTRL+SHIFT+ENTER):
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$4:$A$7;СУММ(--(СТРОКА(A1)>СУММЕСЛИ(СМЕЩ($B$4;;;СТРОКА($B$4:$B$7)-СТРОКА($B$3));"<>")))+1);"")

или немассивную:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$4:$A$7;ЧАСТОТА(СУММЕСЛИ(СМЕЩ($B$4;;;СТРОКА($B$4:$B$7)-СТРОКА($B$3));"<>");СТРОКА(A1)-1)+1);"")
К сообщению приложен файл: 2017_10_08.xlsx(13Kb)


Сообщение отредактировал ZORRO2005 - Воскресенье, 08.10.2017, 02:52
 
Ответить
Сообщение
... но если у меня таблица на 1000 строк будет - то подобную формулу будет не так легко прописать.

В F11 замените на формулу массива (CTRL+SHIFT+ENTER):
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$4:$A$7;СУММ(--(СТРОКА(A1)>СУММЕСЛИ(СМЕЩ($B$4;;;СТРОКА($B$4:$B$7)-СТРОКА($B$3));"<>")))+1);"")

или немассивную:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$4:$A$7;ЧАСТОТА(СУММЕСЛИ(СМЕЩ($B$4;;;СТРОКА($B$4:$B$7)-СТРОКА($B$3));"<>");СТРОКА(A1)-1)+1);"")

Автор - ZORRO2005
Дата добавления - 08.10.2017 в 02:39
_Igor_61 Дата: Воскресенье, 08.10.2017, 10:55 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 238
Репутация: 44 ±
Замечаний: 20% ±

Excel 2007
ZORRO2005, хорошее дополнение! Я со СМЕЩ пока не научился как следует обращаться, спасибо за пример!
 
Ответить
СообщениеZORRO2005, хорошее дополнение! Я со СМЕЩ пока не научился как следует обращаться, спасибо за пример!

Автор - _Igor_61
Дата добавления - 08.10.2017 в 10:55
deda Дата: Воскресенье, 08.10.2017, 13:50 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
ZORRO2005, спасибо, все получилось и работает как надо.
 
Ответить
СообщениеZORRO2005, спасибо, все получилось и работает как надо.

Автор - deda
Дата добавления - 08.10.2017 в 13:50
_Boroda_ Дата: Понедельник, 09.10.2017, 13:09 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я со СМЕЩ пока не научился как следует обращаться

Она волатильная http://www.excelworld.ru/forum/5-237-1#2622 По возможности стоит избегать
Еще немассивный вариант для площадок, отсортированных по алфавиту (как в примере)
Код
=ИНДЕКС(A:A;ПРОСМОТР(СТРОКА(J1);СУММЕСЛИ(A$4:A$8;"<"&A$4:A$8;B$4:B$8)+1;СТРОКА(A$4:A$8)))&""
К сообщению приложен файл: 2017_10_08_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Я со СМЕЩ пока не научился как следует обращаться

Она волатильная http://www.excelworld.ru/forum/5-237-1#2622 По возможности стоит избегать
Еще немассивный вариант для площадок, отсортированных по алфавиту (как в примере)
Код
=ИНДЕКС(A:A;ПРОСМОТР(СТРОКА(J1);СУММЕСЛИ(A$4:A$8;"<"&A$4:A$8;B$4:B$8)+1;СТРОКА(A$4:A$8)))&""

Автор - _Boroda_
Дата добавления - 09.10.2017 в 13:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание строк по количеству не пустых столбцов в таблице (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!