Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как вычислить интервал времен - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вычислить интервал времен (Формулы/Formulas)
Как вычислить интервал времен
Serak Дата: Понедельник, 09.10.2017, 18:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Необходимо вычислить целое количество часов работы в смене.
У меня не получается считать через полночь.
Файл прилагаю.

Колонки:
A - Дата заступления на смену
B - День недели
C - Время начала смены
D - Время конца смены
E - Количество отработанных часов (надо показать целым числом)
F - Начисления (не актуально)
Время начала и конца м.б. от 0 до 24:00, смена не м.б. больше 24 часов.
К сообщению приложен файл: 2741586.xlsx(10Kb)


С уважением.
 
Ответить
СообщениеНеобходимо вычислить целое количество часов работы в смене.
У меня не получается считать через полночь.
Файл прилагаю.

Колонки:
A - Дата заступления на смену
B - День недели
C - Время начала смены
D - Время конца смены
E - Количество отработанных часов (надо показать целым числом)
F - Начисления (не актуально)
Время начала и конца м.б. от 0 до 24:00, смена не м.б. больше 24 часов.

Автор - Serak
Дата добавления - 09.10.2017 в 18:35
jakim Дата: Понедельник, 09.10.2017, 18:52 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 810
Репутация: 210 ±
Замечаний: 0% ±

Самый простой метод-вводить дополнительно дату конца смены.
К сообщению приложен файл: 8401890.xlsx(10Kb)
 
Ответить
Сообщение
Самый простой метод-вводить дополнительно дату конца смены.

Автор - jakim
Дата добавления - 09.10.2017 в 18:52
buchlotnik Дата: Понедельник, 09.10.2017, 19:09 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3437
Репутация: 922 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
если правильно понял:
Код
=ЕСЛИ(D3<=C3;1-C3+D3;D3-C3)
К сообщению приложен файл: 3345038.xlsx(10Kb)


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
Сообщениеесли правильно понял:
Код
=ЕСЛИ(D3<=C3;1-C3+D3;D3-C3)

Автор - buchlotnik
Дата добавления - 09.10.2017 в 19:09
Che79 Дата: Понедельник, 09.10.2017, 19:36 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
[offtop]Долго думал, выкладывать ли свой вариант, по сути, он дублирует варианта Михаила (buchlotnik). Ну пусть тоже будет...
Код
=ТЕКСТ(((D3-C3)*(D3>C3))+((1-C3+D3)*(D3<=C3));"[ч]")


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop]Долго думал, выкладывать ли свой вариант, по сути, он дублирует варианта Михаила (buchlotnik). Ну пусть тоже будет...
Код
=ТЕКСТ(((D3-C3)*(D3>C3))+((1-C3+D3)*(D3<=C3));"[ч]")

Автор - Che79
Дата добавления - 09.10.2017 в 19:36
_Boroda_ Дата: Понедельник, 09.10.2017, 19:44 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты
Код
=ABS(C3-D3-(D3<=C3))

Код
=D3-C3+(D3<=C3)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты
Код
=ABS(C3-D3-(D3<=C3))

Код
=D3-C3+(D3<=C3)

Автор - _Boroda_
Дата добавления - 09.10.2017 в 19:44
Serak Дата: Понедельник, 09.10.2017, 20:11 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ТЕКСТ(((D3-C3)*(D3>C3))+((1-C3+D3)*(D3<=C3));"[ч]")

Получилось идеально. Спасибо.


С уважением.
 
Ответить
Сообщение
=ТЕКСТ(((D3-C3)*(D3>C3))+((1-C3+D3)*(D3<=C3));"[ч]")

Получилось идеально. Спасибо.

Автор - Serak
Дата добавления - 09.10.2017 в 20:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как вычислить интервал времен (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!