Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка данных внутри формулы массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка данных внутри формулы массива (Формулы/Formulas)
Сортировка данных внутри формулы массива
nono4ka Дата: Пятница, 27.10.2017, 10:05 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Не могу решить задачу, точней частично решил)
Исходная задача следующая: есть множество точек на плоскости, определить какие точки попадают к каждой точке в заданном радиусе.
Исходные данные: у каждой точки есть имя, координаты. Задается радиус определения.
Необходимый результат: для каждой точки получить имена попавших в заданный радиус точек.
На данный момент реализовал поиск точек попавших в радиус к каждой точке, результат записывается в массив, в виде названия каждой точки. На лист результат выводится по средствам функции НАИБОЛЬШИЙ, но проблема в том, что название точек могут быть текстовые, и соответственно при сортировке они уходят в конец массива.
Отсюда и вопрос, как внутри массива отсортировать данные так, чтобы в начале оказались не нули или не пусто.

Пытался максимально понятно объяснить, надеюсь ясность внесет прикрепленный файл!
К сообщению приложен файл: 6969638.xlsx(20Kb)
 
Ответить
СообщениеДобрый день!
Не могу решить задачу, точней частично решил)
Исходная задача следующая: есть множество точек на плоскости, определить какие точки попадают к каждой точке в заданном радиусе.
Исходные данные: у каждой точки есть имя, координаты. Задается радиус определения.
Необходимый результат: для каждой точки получить имена попавших в заданный радиус точек.
На данный момент реализовал поиск точек попавших в радиус к каждой точке, результат записывается в массив, в виде названия каждой точки. На лист результат выводится по средствам функции НАИБОЛЬШИЙ, но проблема в том, что название точек могут быть текстовые, и соответственно при сортировке они уходят в конец массива.
Отсюда и вопрос, как внутри массива отсортировать данные так, чтобы в начале оказались не нули или не пусто.

Пытался максимально понятно объяснить, надеюсь ясность внесет прикрепленный файл!

Автор - nono4ka
Дата добавления - 27.10.2017 в 10:05
_Boroda_ Дата: Пятница, 27.10.2017, 10:26 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11644
Репутация: 4825 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС($A:$A;НАИМЕНЬШИЙ(ЕСЛИ(КОРЕНЬ(($B3-$B$3:$B$32)^2+($C3-$C$3:$C$32)^2)<$G$2;СТРОКА($A$3:$A$32));H$2));"")
К сообщению приложен файл: 6969638_1.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС($A:$A;НАИМЕНЬШИЙ(ЕСЛИ(КОРЕНЬ(($B3-$B$3:$B$32)^2+($C3-$C$3:$C$32)^2)<$G$2;СТРОКА($A$3:$A$32));H$2));"")

Автор - _Boroda_
Дата добавления - 27.10.2017 в 10:26
nono4ka Дата: Пятница, 27.10.2017, 11:51 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, да! отлично! спасибо большое, Вы открыли мне мир функции СТРОКА hands
 
Ответить
Сообщение_Boroda_, да! отлично! спасибо большое, Вы открыли мне мир функции СТРОКА hands

Автор - nono4ka
Дата добавления - 27.10.2017 в 11:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка данных внутри формулы массива (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!