Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/нумерация строк по нескольким параметрам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » нумерация строк по нескольким параметрам (Формулы/Formulas)
нумерация строк по нескольким параметрам
bukent Дата: Понедельник, 30.10.2017, 06:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Помогите пожалуйста подобрать формулу, для нумерации строк, по параметрам указанным во вложении. Спасибо
К сообщению приложен файл: 2017.10.30.xlsx(11Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите пожалуйста подобрать формулу, для нумерации строк, по параметрам указанным во вложении. Спасибо

Автор - bukent
Дата добавления - 30.10.2017 в 06:38
Nic70y Дата: Понедельник, 30.10.2017, 07:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(A2="СТР";"STR";(110+СЧЁТЕСЛИ(ИНДЕКС(A$1:A2;ПОИСКПОЗ("我";B$1:B1)+1):A2;A2))*10)
ток не понятно почему
STR079, а потом STR003
К сообщению приложен файл: 1055365.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(A2="СТР";"STR";(110+СЧЁТЕСЛИ(ИНДЕКС(A$1:A2;ПОИСКПОЗ("我";B$1:B1)+1):A2;A2))*10)
ток не понятно почему
STR079, а потом STR003

Автор - Nic70y
Дата добавления - 30.10.2017 в 07:35
bukent Дата: Понедельник, 30.10.2017, 07:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, ваше решение не совсем корректное
у вас
ОП 1120
ТМЦ 1110
а надо
ОП 1120
ТМЦ 1120
ток не понятно почему
STR079, а потом STR003

так надо :)
Нумерация только по "ОП", по "ТМЦ","ВСП" привязка к нумерации верхнего "ОП"


Сообщение отредактировал bukent - Понедельник, 30.10.2017, 08:05
 
Ответить
СообщениеNic70y, ваше решение не совсем корректное
у вас
ОП 1120
ТМЦ 1110
а надо
ОП 1120
ТМЦ 1120
ток не понятно почему
STR079, а потом STR003

так надо :)
Нумерация только по "ОП", по "ТМЦ","ВСП" привязка к нумерации верхнего "ОП"

Автор - bukent
Дата добавления - 30.10.2017 в 07:50
Nic70y Дата: Понедельник, 30.10.2017, 08:06 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
промахнулся
Код
=ЕСЛИ(A2="СТР";"STR";(110+СЧЁТЕСЛИ(ИНДЕКС(A$1:A2;ПОИСКПОЗ("我";B$1:B1)):A1;A2))*10)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениепромахнулся
Код
=ЕСЛИ(A2="СТР";"STR";(110+СЧЁТЕСЛИ(ИНДЕКС(A$1:A2;ПОИСКПОЗ("我";B$1:B1)):A1;A2))*10)

Автор - Nic70y
Дата добавления - 30.10.2017 в 08:06
bukent Дата: Понедельник, 30.10.2017, 09:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, если ТМЦ встречаются 2 строки то они нумеруются :(
ОП 1100
ТМЦ 1100
ТМЦ 1110

надо
ОП 1100
ТМЦ 1100
ТМЦ 1100
 
Ответить
СообщениеNic70y, если ТМЦ встречаются 2 строки то они нумеруются :(
ОП 1100
ТМЦ 1100
ТМЦ 1110

надо
ОП 1100
ТМЦ 1100
ТМЦ 1100

Автор - bukent
Дата добавления - 30.10.2017 в 09:35
Pelena Дата: Понедельник, 30.10.2017, 11:48 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11755
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Похожая формула
Код
=ЕСЛИ(A2="СТР";"STR";ЕСЛИ(A2="ОП";1100+СЧЁТЕСЛИ(ИНДЕКС($A$1:A1;ПОИСКПОЗ("яяя";B$1:B1)):A1;"ОП")*10;B1))
К сообщению приложен файл: 0276587.xlsx(13Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПохожая формула
Код
=ЕСЛИ(A2="СТР";"STR";ЕСЛИ(A2="ОП";1100+СЧЁТЕСЛИ(ИНДЕКС($A$1:A1;ПОИСКПОЗ("яяя";B$1:B1)):A1;"ОП")*10;B1))

Автор - Pelena
Дата добавления - 30.10.2017 в 11:48
bukent Дата: Понедельник, 30.10.2017, 13:45 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena,
заработало,

всем участовавшим спасибо за труд.
 
Ответить
СообщениеPelena,
заработало,

всем участовавшим спасибо за труд.

Автор - bukent
Дата добавления - 30.10.2017 в 13:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » нумерация строк по нескольким параметрам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!