Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать количество, если строка содержит текст - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать количество, если строка содержит текст (Формулы/Formulas)
Посчитать количество, если строка содержит текст
Naolsa Дата: Четверг, 02.11.2017, 15:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Необходимо посчитать количество строк в диапазоне, которые содержат "товар/". Но в формуле должна быть ссылка именно на ячейку "товар".
Возможно можно прописать через сцепить или как-то по-другому.
не могу найти хороший вариант.
Спасибо за помощь!
К сообщению приложен файл: 7130395.xls(26Kb)


Сообщение отредактировал Naolsa - Четверг, 02.11.2017, 15:15
 
Ответить
СообщениеДобрый день!
Необходимо посчитать количество строк в диапазоне, которые содержат "товар/". Но в формуле должна быть ссылка именно на ячейку "товар".
Возможно можно прописать через сцепить или как-то по-другому.
не могу найти хороший вариант.
Спасибо за помощь!

Автор - Naolsa
Дата добавления - 02.11.2017 в 15:06
китин Дата: Четверг, 02.11.2017, 15:14 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4409
Репутация: 697 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
не очень понятно. а вдруг правильно?
Код
=СЧЁТЕСЛИ(D2:D8;A2&"/")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениене очень понятно. а вдруг правильно?
Код
=СЧЁТЕСЛИ(D2:D8;A2&"/")

Автор - китин
Дата добавления - 02.11.2017 в 15:14
pabchek Дата: Четверг, 02.11.2017, 15:16 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 779
Репутация: 173 ±
Замечаний: 0% ±

Excel 2007
наверно, все же
Код
=СЧЁТЕСЛИ(D2:D8;A2&"/")

Упс. Прости Игорь ))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Четверг, 02.11.2017, 15:17
 
Ответить
Сообщениенаверно, все же
Код
=СЧЁТЕСЛИ(D2:D8;A2&"/")

Упс. Прости Игорь ))

Автор - pabchek
Дата добавления - 02.11.2017 в 15:16
Naolsa Дата: Четверг, 02.11.2017, 15:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
pabchek, китин, как же все оказалось просто.
спасибо Вам огромное!натупила что-то %)
 
Ответить
Сообщениеpabchek, китин, как же все оказалось просто.
спасибо Вам огромное!натупила что-то %)

Автор - Naolsa
Дата добавления - 02.11.2017 в 15:17
Naolsa Дата: Четверг, 02.11.2017, 15:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а если будет так?
К сообщению приложен файл: 0280336.xls(27Kb)
 
Ответить
Сообщениеа если будет так?

Автор - Naolsa
Дата добавления - 02.11.2017 в 15:21
китин Дата: Четверг, 02.11.2017, 15:23 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4409
Репутация: 697 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
Прости

за что Витя? это форум и тут демократию Сергей установил :D :D :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
Прости

за что Витя? это форум и тут демократию Сергей установил :D :D :D

Автор - китин
Дата добавления - 02.11.2017 в 15:23
_Boroda_ Дата: Четверг, 02.11.2017, 15:23 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А что получить нужно?
Так?
Код
=СЧЁТЕСЛИ(D2:D8;A2&"/*")

ЛОучше даже так - СЧЁТЕСЛИ сама отрубает лишнее в диапазоне, поэтому можно ей скармливать весь столбец
Код
=СЧЁТЕСЛИ(D:D;A2&"/*")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА что получить нужно?
Так?
Код
=СЧЁТЕСЛИ(D2:D8;A2&"/*")

ЛОучше даже так - СЧЁТЕСЛИ сама отрубает лишнее в диапазоне, поэтому можно ей скармливать весь столбец
Код
=СЧЁТЕСЛИ(D:D;A2&"/*")

Автор - _Boroda_
Дата добавления - 02.11.2017 в 15:23
Naolsa Дата: Четверг, 02.11.2017, 15:27 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, да, работает. спасибо.
Только подскажите, что в данном случае делает "*"?
 
Ответить
Сообщение_Boroda_, да, работает. спасибо.
Только подскажите, что в данном случае делает "*"?

Автор - Naolsa
Дата добавления - 02.11.2017 в 15:27
_Boroda_ Дата: Четверг, 02.11.2017, 15:29 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
* - любое кол-во любых символов
? - один любой символ
Если нужно найти сами знаки * или ?, то перед ними ставим тильду
~* или ~?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение* - любое кол-во любых символов
? - один любой символ
Если нужно найти сами знаки * или ?, то перед ними ставим тильду
~* или ~?

Автор - _Boroda_
Дата добавления - 02.11.2017 в 15:29
Naolsa Дата: Четверг, 02.11.2017, 15:33 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, спасибо за помощь и развернутый ответ!
еще учиться и учиться!
 
Ответить
Сообщение_Boroda_, спасибо за помощь и развернутый ответ!
еще учиться и учиться!

Автор - Naolsa
Дата добавления - 02.11.2017 в 15:33
Nic70y Дата: Четверг, 02.11.2017, 15:45 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
* - любое кол-во любых символов
это не правда!
К сообщению приложен файл: 18-45.xlsx(8Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
* - любое кол-во любых символов
это не правда!

Автор - Nic70y
Дата добавления - 02.11.2017 в 15:45
_Boroda_ Дата: Четверг, 02.11.2017, 15:56 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11647
Репутация: 4828 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ничё не знаю :D , читай справку Майкрософта
https://support.office.com/ru-ru....816df34

Цитата
=СЧЁТЕСЛИ(A2:A5;"*")

Количество ячеек, содержащих любой текст, в ячейках А2–А5. Подстановочный знак "*" обозначает любое количество любых символов. Результат — 4.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНичё не знаю :D , читай справку Майкрософта
https://support.office.com/ru-ru....816df34

Цитата
=СЧЁТЕСЛИ(A2:A5;"*")

Количество ячеек, содержащих любой текст, в ячейках А2–А5. Подстановочный знак "*" обозначает любое количество любых символов. Результат — 4.

Автор - _Boroda_
Дата добавления - 02.11.2017 в 15:56
Nic70y Дата: Четверг, 02.11.2017, 15:59 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
там таки правильно :)
Цитата
...содержащих любой текст...


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 02.11.2017, 16:00
 
Ответить
Сообщениетам таки правильно :)
Цитата
...содержащих любой текст...

Автор - Nic70y
Дата добавления - 02.11.2017 в 15:59
pabchek Дата: Четверг, 02.11.2017, 16:00 | Сообщение № 14
Группа: Проверенные
Ранг: Ветеран
Сообщений: 779
Репутация: 173 ±
Замечаний: 0% ±

Excel 2007
[offtop]
за что Витя?

За дублирование ответа. Не по джентльменски получилось))[/offtop]


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение[offtop]
за что Витя?

За дублирование ответа. Не по джентльменски получилось))[/offtop]

Автор - pabchek
Дата добавления - 02.11.2017 в 16:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать количество, если строка содержит текст (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!