Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как правильно отсортировать товар по дате поступления?? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как правильно отсортировать товар по дате поступления?? (Формулы/Formulas)
как правильно отсортировать товар по дате поступления??
Nik57 Дата: Пятница, 03.11.2017, 16:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем привет! Подскажите кто знает как разрешить ситуацию.
Есть условная таблица из 4 листов (их может быть множество).
На 1 листе ячейка А1 заполняется вручную, там дата прибытия товара на склад. Требуется чтобы при изменении этой даты на необходимую, автоматически формировался диапазон выделенный серым цветом на листе 1 (он так же показан условно). На листе 2,3,4 вся выборка прихода товара. Тоесть если на листе А1 выбираю дату 11.08.2017, то автоматически появляется время прибытия, наименование сорта и позиции с оставшихся листов именно за эту дату (как это указано в примере зеленым цветом). Желательно чтоб это еще было в порядке возрастания времени поступления. Если выбирая 12.08.2017, то в сером диапазоне появлялись товары 12 августа и тд. Если кто может подсказать как это сделать без макроса формулами было бы отлично., так как количество листов со временем будет увеличиваться. Пытался это прописать сам через поиск позиций, но ничего не получилось...
Заранее благодарю за помощь!
К сообщению приложен файл: 6508847.xlsx(13Kb)
 
Ответить
СообщениеВсем привет! Подскажите кто знает как разрешить ситуацию.
Есть условная таблица из 4 листов (их может быть множество).
На 1 листе ячейка А1 заполняется вручную, там дата прибытия товара на склад. Требуется чтобы при изменении этой даты на необходимую, автоматически формировался диапазон выделенный серым цветом на листе 1 (он так же показан условно). На листе 2,3,4 вся выборка прихода товара. Тоесть если на листе А1 выбираю дату 11.08.2017, то автоматически появляется время прибытия, наименование сорта и позиции с оставшихся листов именно за эту дату (как это указано в примере зеленым цветом). Желательно чтоб это еще было в порядке возрастания времени поступления. Если выбирая 12.08.2017, то в сером диапазоне появлялись товары 12 августа и тд. Если кто может подсказать как это сделать без макроса формулами было бы отлично., так как количество листов со временем будет увеличиваться. Пытался это прописать сам через поиск позиций, но ничего не получилось...
Заранее благодарю за помощь!

Автор - Nik57
Дата добавления - 03.11.2017 в 16:43
krosav4ig Дата: Пятница, 03.11.2017, 17:08 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1479
Репутация: 599 ±
Замечаний: 0% ±

Excel 2007, 2013
здравствуйте
вариант с доп. столбцом
Код
=НАИМЕНЬШИЙ(ЕСЛИ(Лист2!$A$1:A99=Лист1!$A$2;СТРОКА(Лист2!$A$1:A99));СТРОКА(Лист1!G1))

и формула в таблице
Код
=ИНДЕКС(ВЫБОР(ОКРВВЕРХ(СТОЛБЕЦ()/3;1);Лист2!$A:$A;Лист2!$B:$B);$G2+(ОСТАТ(СТОЛБЕЦ();3)=0))
К сообщению приложен файл: 9274373.xlsx(15Kb)


(_)Õvõ(_)
 
Ответить
Сообщениездравствуйте
вариант с доп. столбцом
Код
=НАИМЕНЬШИЙ(ЕСЛИ(Лист2!$A$1:A99=Лист1!$A$2;СТРОКА(Лист2!$A$1:A99));СТРОКА(Лист1!G1))

и формула в таблице
Код
=ИНДЕКС(ВЫБОР(ОКРВВЕРХ(СТОЛБЕЦ()/3;1);Лист2!$A:$A;Лист2!$B:$B);$G2+(ОСТАТ(СТОЛБЕЦ();3)=0))

Автор - krosav4ig
Дата добавления - 03.11.2017 в 17:08
Nik57 Дата: Вторник, 07.11.2017, 09:43 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да, вариант такой просматривается, только есть три но))

1. выборка идет только с одного листа 2, а не всех листов
2. если меняется число, которого нет в таблице, то выскакивает ошибка как "ЧИСЛО", а необходимо чтоб в таких случаях были пустые ячейки
3. и время не в порядке возрастания.

возможно это все кажется как мелочи, просто когда в таблице будет порядка 200 позиций, будет крайне неудобно выбирать числа в порядке возрастания вручную
 
Ответить
СообщениеДа, вариант такой просматривается, только есть три но))

1. выборка идет только с одного листа 2, а не всех листов
2. если меняется число, которого нет в таблице, то выскакивает ошибка как "ЧИСЛО", а необходимо чтоб в таких случаях были пустые ячейки
3. и время не в порядке возрастания.

возможно это все кажется как мелочи, просто когда в таблице будет порядка 200 позиций, будет крайне неудобно выбирать числа в порядке возрастания вручную

Автор - Nik57
Дата добавления - 07.11.2017 в 09:43
Nik57 Дата: Вторник, 07.11.2017, 09:44 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
может есть у кого еще какие нибудь варианты??
 
Ответить
Сообщениеможет есть у кого еще какие нибудь варианты??

Автор - Nik57
Дата добавления - 07.11.2017 в 09:44
TimSha Дата: Вторник, 07.11.2017, 10:05 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 525
Репутация: 82 ±
Замечаний: 0% ±

Excel 2013 Pro +
может есть у кого еще какие нибудь варианты??

кто может подсказать как это сделать без макроса формулами

О каких еще вариантах может быть речь?!. ;)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
может есть у кого еще какие нибудь варианты??

кто может подсказать как это сделать без макроса формулами

О каких еще вариантах может быть речь?!. ;)

Автор - TimSha
Дата добавления - 07.11.2017 в 10:05
nilem Дата: Вторник, 07.11.2017, 13:15 | Сообщение № 6
Группа: Авторы
Ранг: Старожил
Сообщений: 1324
Репутация: 469 ±
Замечаний: 0% ±

Excel 2013
вариант:
К сообщению приложен файл: _0988081.xlsm(23Kb)


Яндекс.Деньги 4100159601573
 
Ответить
Сообщениевариант:

Автор - nilem
Дата добавления - 07.11.2017 в 13:15
Nik57 Дата: Вторник, 07.11.2017, 17:54 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
nilem, подскажите, пожалуйста (я просто в макросах не соображаю) а как макрос изменится, к примеру, в такой ситуации как в прикрепленном примере?
Дело в том что количество листов и диапазон будет меняться в таблице, чтоб я мог провести аналогию между двумя вашими макросами и понять цепочку?
К сообщению приложен файл: 0617558.xlsx(12Kb)
 
Ответить
Сообщениеnilem, подскажите, пожалуйста (я просто в макросах не соображаю) а как макрос изменится, к примеру, в такой ситуации как в прикрепленном примере?
Дело в том что количество листов и диапазон будет меняться в таблице, чтоб я мог провести аналогию между двумя вашими макросами и понять цепочку?

Автор - Nik57
Дата добавления - 07.11.2017 в 17:54
nilem Дата: Вторник, 07.11.2017, 20:30 | Сообщение № 8
Группа: Авторы
Ранг: Старожил
Сообщений: 1324
Репутация: 469 ±
Замечаний: 0% ±

Excel 2013
вот эта строка
[vba]
Код
x = wsh.Range("A1").CurrentRegion.Value: k = 0
[/vba]
изменится вот так
[vba]
Код
x = wsh.Range("I2").CurrentRegion.Value: k = 0
[/vba]
Заголовки и расположение таблицы на Лист1 д.б. как в файле из сообщ.6


Яндекс.Деньги 4100159601573
 
Ответить
Сообщениевот эта строка
[vba]
Код
x = wsh.Range("A1").CurrentRegion.Value: k = 0
[/vba]
изменится вот так
[vba]
Код
x = wsh.Range("I2").CurrentRegion.Value: k = 0
[/vba]
Заголовки и расположение таблицы на Лист1 д.б. как в файле из сообщ.6

Автор - nilem
Дата добавления - 07.11.2017 в 20:30
krosav4ig Дата: Четверг, 09.11.2017, 17:45 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1479
Репутация: 599 ±
Замечаний: 0% ±

Excel 2007, 2013
куча формул (волатильных!!!)
в диспетчере имен
Код
AA    =ЯЧЕЙКА("имяфайла";Лист1!K1)
Код
BB    =ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1;СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(AA;"]";ПОВТОР(" ";999));ПОИСК("[";AA)+1;999)))
Код
CC    =ПОИСКПОЗ(BB;BB;)
Код
DD    =СЧЁТЕСЛИ(ДВССЫЛ("'"&BB&"'!A:A");Лист1!$A$2)
Код
EE    =МУМНОЖ((CC<=ТРАНСП(CC))*(DD);ТРАНСП(CC^0))
Код
FF    =ИНДЕКС(BB;ПОИСКПОЗ(СТРОКА()-1;EE)+1)
Код
GG    =ПОЛУЧИТЬ.ДОКУМЕНТ(10; FF)
Код
HH    =ДВССЫЛ("'"&FF&"'!A1:A"&GG)
Код
II    =ДВССЫЛ("'"&FF&"'!B1:B"&GG;1)
Код
JJ    =СТРОКА()-ПРОСМОТР(СТРОКА()-1;EE)
Код
KK    =НАИМЕНЬШИЙ(ЕСЛИ(HH=Лист1!$A$2;СТРОКА(HH));JJ)
Код
LL    =ИНДЕКС(ВЫБОР(ОКРВВЕРХ(СТОЛБЕЦ()/3;1);HH;II);KK+(ОСТАТ(СТОЛБЕЦ();3)=0))
в ячейках
Код
=ЕСЛИ(СТРОКА()-1>=СУММ(DD);"";LL)
К сообщению приложен файл: 6508847.xlsm(20Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Четверг, 09.11.2017, 17:49
 
Ответить
Сообщениекуча формул (волатильных!!!)
в диспетчере имен
Код
AA    =ЯЧЕЙКА("имяфайла";Лист1!K1)
Код
BB    =ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1;СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(AA;"]";ПОВТОР(" ";999));ПОИСК("[";AA)+1;999)))
Код
CC    =ПОИСКПОЗ(BB;BB;)
Код
DD    =СЧЁТЕСЛИ(ДВССЫЛ("'"&BB&"'!A:A");Лист1!$A$2)
Код
EE    =МУМНОЖ((CC<=ТРАНСП(CC))*(DD);ТРАНСП(CC^0))
Код
FF    =ИНДЕКС(BB;ПОИСКПОЗ(СТРОКА()-1;EE)+1)
Код
GG    =ПОЛУЧИТЬ.ДОКУМЕНТ(10; FF)
Код
HH    =ДВССЫЛ("'"&FF&"'!A1:A"&GG)
Код
II    =ДВССЫЛ("'"&FF&"'!B1:B"&GG;1)
Код
JJ    =СТРОКА()-ПРОСМОТР(СТРОКА()-1;EE)
Код
KK    =НАИМЕНЬШИЙ(ЕСЛИ(HH=Лист1!$A$2;СТРОКА(HH));JJ)
Код
LL    =ИНДЕКС(ВЫБОР(ОКРВВЕРХ(СТОЛБЕЦ()/3;1);HH;II);KK+(ОСТАТ(СТОЛБЕЦ();3)=0))
в ячейках
Код
=ЕСЛИ(СТРОКА()-1>=СУММ(DD);"";LL)

Автор - krosav4ig
Дата добавления - 09.11.2017 в 17:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как правильно отсортировать товар по дате поступления?? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!